Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help! SpringBoard stuck in loop.

  1. #1
    Default Help! SpringBoard stuck in loop.
    Hello,

    Back story: I bought a 1.1.4 iPhone, jailbroke it, downloaded installer.app, started installing various programs. I compiled the helloWorld from iphonegameover.com, exec'd it from the SSH command line, it worked just fine. I took the next step to create helloWorld.app with the following files:

    + helloWorld.app (directory)
    --- helloWorld (executable)
    --- Default.png (white square)
    --- icon.png (happy face)
    --- Info.plist (copied from another app and edited for helloWorld)

    SpringBoard apparently found the new app and did the thing that it always does when it finds a new app:

    1) it went into a little reset mode wherein it displayed its "I'm busy" icon (spokes on a wheel), then
    2) it flashed the Apple logo on a blank screen followed very quickly by the application icons zooming in from around the edges to their new arrangement.

    My new happy face icon.png appeared with the rest. I exec'd helloWorld.app by clicking the icon and everything seemed ok in iPhone-land.

    Now the problem. The SpringBoard has been continuously looping through steps 1 and 2 above (with an extra step 3 popup about editing the home screens) for 12 hours. It will not stop! I tried rebooting the iPhone, resetting via the hold-down-both-buttons trick, executing other applications (SpringBoard quickly resets again). I removed helloWorld.app altogether, no luck. I even tried copying an existing application and renaming it helloWorld.app to try to placate the thing -- all in vain! ITunes does not see the phone so I can't restore it, it won't receive any calls. All I can do is SSH into the thing.

    The REALLY bad news:

    Process: SpringBoard [50]
    Path: /System/Library/CoreServices/SpringBoard.app/SpringBoard
    Version: N/A (N/A)
    Code Type: 0000000C (Native)
    Effective UID: 501
    Parent Process: launchd [1]

    Date/Time: 2008-03-28 23:50:43.435 -0600
    OS Version: OS X 1.1.4 (4A102)
    Report Version: 101

    Exception Type: EXC_BAD_ACCESS
    Exception Codes: KERN_PROTECTION_FAILURE at 0x00000004


    Help!

    Thanks,
    G
    Last edited by gkip; 2008-03-29 at 04:08 PM.

  2. #2
    iPhone? More like MyPhone
    Join Date
    Mar 2008
    Location
    Not too far from Mr. Miyagi's place
    Posts
    126
    Thanks
    36
    Thanked 21 Times in 17 Posts

    Basically the iPhone's OS is getting a kernel panic (aka, kernel exception) while the mobile user (501) is using SpringBoard.

    Given what you're describing, it sounds like exactly what happens after using the passwd utility in the BSD Subsystem (which seems to be incompatible with 1.1.3 and 1.1.4) to change root and/or mobile's passwords.

    Your best bet would be restore, though you said iTunes isn't recognizing it. In this case, it will probably be best to force the phone into DFU mode. If you haven't done this before, hook the phone up to the computer, hold the Sleep/Wake button and the Home button for about 10 or so seconds, the screen should blank to black (you may have to do this a few times, when I had the same issue my unit was resetting itself before it would respond to me). After a second or so with the black screen, release the Sleep/Wake button and keep Home held. iTunes should recognize it in about 10-15 seconds if the unit's not being a total pill.

    From there it'd be best to restore, bar none. As for helloWorld and unlock related stuff, I'm not too well versed in it but hopefully the issue wasn't due to your recompiled helloWorld.
    I came, I saw, I forgot what the hell I was there for.

  3. #3
    Another thing that will cause this symptom is exceeding 79 apps installed without having the latest version of Summerboard installed (which fixes the limit).

    So you might just manually delete a few applications via SSH and see if that solves the problem.

  4. #4
    DaveiPhone nailed it. Cheers to Dave!
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  5. #5
    I had this 3 times, too...Had to restore 3 times! But then the 4th time and I decided to fix it, I used SSH, and It worked, WiFi is probably activated when the wheel loops, so I went to Summerboard/Themes and deleted the theme I was using, and the phone booted from that point..Could be your problem, too...So use SSH or iBrickr/iPhone PC Suite, and go toe Library/Summerboard/Themes and delete the theme you were using when your phone got the spinning wheel, and it should work, I deleted SMBPrefs.app aswell, but it booted as soon as I deleted the used theme...So you should try that, too...

  6. #6
    hello
    i tried the Restore Way and Ziph.. and now it's fine ! Many thanks !

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •