im trying to instal anythign on my phone it ays i need to instsal th ebsd subsystem but when i try to do that it says i need the bsd subsystem to instal the bsd subsystem what should i do?

it al;so says i could have cydia i have no idea what that is