Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Bluetooth/Wifi/Edge enable/disable widget App?

  1. #1
    Default Bluetooth/Wifi/Edge enable/disable widget App?
    Someone mentioned this app in the EIP forum, a Bluetooth/Wifi/Edge enable/disable widget App. Anyone heard of it?

  2. #2
    I believe you are talking about Services.app which can be found on Installer.app as of just an hour or so ago. I'm the creator and I tend to mostly watch the linked thread for proposed enhancements and conflict resolution.

  3. The Following User Says Thank You to cehoffman For This Useful Post:

    ynogatna (2007-10-05)

  4. #3
    Here's a question. I originally had SSH installed and then I uninstalled due to battery life problems. I just installed Services and it shows a switch to turn on SSH. After reinstalling a new package of SSH and now I see two switches for SSH.

    Questions:
    1) Did the original SSH installation stay active?
    2) Do I need to turn on both switches to activate SSH now?

    Any help would be appreciated.

    (BTW, this is just an aesthetic opinion, so take it with a grain of salt, but I think the switch looks better without all the icons.)

  5. #4
    An SSH button exists for each of the SSH solutions for the phone, dropbear and OpenSSH. My guess is that you removed the binary for dropbear but didn't actually remove it from the phones launchservices.

    From the command line:

    Code:
    which dropbear && launchctl unload -w /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear.plist
    rm /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear.plist
    rm `which dropbear`
    The quotes in the last command are actually back ticks found usually found on the tilde key. These command check if dropbear binary is on the system, if it is it unloads it from launch services. Then it deletes the control that tries to autoload dropbear and then the last one tried to remove the dropbear binary from the system.

    Remember though, these are just a guess of what is going on but it is a common theme.

  6. #5
    Thanks for your troubleshooting support...I appreciate it immensely. I'm uncertain with the file structure and commands required to resolve this. The SSH client that I installed and uninstalled was an old version of OpenSSH via Installer. The SSH client that I have now is the current version of OpenSSH.

    The ability to turn off EDGE is fantastic feature BTW. I'm loving it.

  7. #6
    The only way for two SSH buttons to come up if you have the most recent OpenSSH is if one of these files exits

    /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear.plist
    /Library/LaunchDaemons/au.asn.ucc.matt.dropbear.plist

    Try to delete thosel.

  8. #7
    Thanks. You're absolutely right. I forgot that Independence has an installer and I selected that after an activation routine. Sorry about that.

  9. #8
    I have selected edge off yet the E continues to apear on the top bar..

  10. #9
    me too. Still getting the E - worse though, it is most definitely trying to hunt for EDGE as it keeps on saying it can't find it, and I have to manually force it to look for wifi by going into the wifi settings and doing a search for wireless networks. As soon as the phone goes to sleep and is re-awakened, its back looking for EDGE.
    any help would be greatly appreciated.
    thanks

  11. #10
    Yes that is exactly the same problem im haveing.

  12. #11
    now...also after unistall the program as the phone goes to sleep and is re-awakened, its with wifi connected back looking for EDGE !! HELP !

  13. #12
    ok - so I think I've solved my problem for now...

    ...if anyone else is having a similar problem of turning off EDGE and the phone seems to continue to hunt for EDGE and not resort to looking for WiFi as it did before services is installed (using firmware 1.0.2 of course) , I turned off EDGE and WiFi from services then restarted the phone then turned on wifi from settings/wifi then restarted the phone again.

    I now seem to have EDGE off and WiFi working just the way I want. May have been a fluke but might help others!

    anyways, thanks for making the app cehoffman.

  14. #13
    Quote Originally Posted by charliec View Post
    ok - so I think I've solved my problem for now...

    ...if anyone else is having a similar problem of turning off EDGE and the phone seems to continue to hunt for EDGE and not resort to looking for WiFi as it did before services is installed (using firmware 1.0.2 of course) , I turned off EDGE and WiFi from services then restarted the phone then turned on wifi from settings/wifi then restarted the phone again.

    I now seem to have EDGE off and WiFi working just the way I want. May have been a fluke but might help others!

    anyways, thanks for making the app cehoffman.
    What happens if you turn off Wifi? Does the E re-appear and do you get those annoying pop ups again? That's what happens to me... I tried what you suggested, but after turning off wifi again it just comes back. I like to turn wifi off to conserve battery life when I'm not using it... and man that pop up for edge is so annoying.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •