When will it be updated? Says it's incompatible. Of course we still need this for certain apps.