Page 1 of 2 12 LastLast
Results 1 to 20 of 28

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Major Activator Problems

  1. #1
    Default Major Activator Problems
    Yesterday I checked cydia and updates some of my packages, among them was an update to backgrounder. The latest revision of backgrounder had a new dependency that I did not have installed: Activator. I installed said package, and thats when I started having problems:

    1. After a reboot or a respring, I can launch any app. If I then quit out of said app, any subsequent app launch crashes almost immediately back to springboard. Hence I can not launch any other apps or have multiple apps running.

    2. I can however get into sbs and check processes... and whatever app I initially launched is still in the process tree, however it is not deletable (delete is dimmed to indicate it has already been selected)

    3. By removing the backgrounder and activator packages, my phone reverts back to normal behavior... however I obviously lose multi-app environment (without bg or act).

    4. I tried installing circuitous which also has activator as a dependency and it suffers the same exact symptoms, therefore I am almost certain it is a problem with activator.

    I would love to get my multi-app environment back, and try circuitous to boot. Any help would be greatly appreciated.

    Thanks

    ~Poser

    iPhone 3g 3.1.2 (t-mo)

  2. #2
    Go and asked for a refund, you are not happy and you didnt get wat you paid for, and they should have informed you that she is still learning. I would make a huge scene... well thats me, and then demand that someone fix your hair, that is someone with the experience.

  3. #3
    Im having the exact same issues with activator and i have to delete backgrounder and activator for my phone to open apps. Has anyone got a fix for this?

  4. #4
    I have the same problem. The only work around I found was to open springboard and close it again. This allowed me to open another app. Each time I wanted to open a new app i had to open and close SB. After a few hrs of doing this I said decided it wasn't worth it and uninstalled activator/backgrounder.

    Hopefully the creator of activator knows about this issue and is working on it. Backgrounder appears to be ok.

  5. #5
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Quote Originally Posted by aldin.aldis View Post
    Go and asked for a refund, you are not happy and you didnt get wat you paid for, and they should have informed you that she is still learning. I would make a huge scene... well thats me, and then demand that someone fix your hair, that is someone with the experience.
    These apps are free. Looks like you will just have to wait for an update from one or the other to fix compatibility.

  6. The Following User Says Thank You to Poseidon79 For This Useful Post:

    area51crypto (2010-05-07)

  7. #6
    The other option i guess is to restore and rejailbreak and see whether it works after that. I have deleted other cydia apps to try and sort out a possible Conflict without success. I really dont want to restore my phone as i have loads of stuff from cydia and a customised theme which will take ages to put back on. If anyone has a solution please let us know.

    Also tkoden i have the exact issues u have and have used sb settings/processess to close apps so that i can open other appd
    Last edited by cahoosersnip; 2010-05-06 at 11:15 PM. Reason: Automerged Doublepost

  8. The Following User Says Thank You to cahoosersnip For This Useful Post:

    PantherUK (2010-08-10)

  9. #7
    Quote Originally Posted by cahoosersnip View Post
    The other option i guess is to restore and rejailbreak and see whether it works after that. I have deleted other cydia apps to try and sort out a possible Conflict without success. I really dont want to restore my phone as i have loads of stuff from cydia and a customised theme which will take ages to put back on. If anyone has a solution please let us know.

    Also tkoden i have the exact issues u have and have used sb settings/processess to close apps so that i can open other appd
    Are you still having problems even after you uninstall activator? My phone is back to 100% but all I have installed right now is Cyida and notifier. I am just going to hold out hope that the activator programmer will realize there are issues with the 3GS and newer 3G phones and fix the issue. The rev is at 1.3.1 right now so just watch for a new rev and give that a try.

  10. #8
    Yeah my phone works fine whe activator is uninstalled. There doesnt seem to be much on the internet about this issue which makes me think that possibly we have picked up a bug somewhere and restore seems the only likely remedy. If i can be bothered with the restire i will post on here to let you know whether that fixes our problem.

  11. #9
    Have you heard of anyone that has jailbroken their 3GS with spirit that has successfully installed activator? Please let me know if the restore works.

  12. #10
    I dont know anyone with spirit jailbreak but il deffo post here on the restore

  13. #11
    to add to this...

    this problem also affects me:

    2nd Gen Ipod Touch on 3.1.3 firmware
    Jailbroken using Spirit

    i tried turning off Orbit, Infiniboard, and Quick Scroll 2 to appease it, but nothing worked.

    so it's not just the iphones being affected by this...

    but it is interesting to note that activator/multiflow/backgrounder did work when I was running off of 3.1.2 firmware jailbroken with blackra1n

    until that got caught in the restart loop and I had to nuke it.

  14. #12
    Ok i have found a cure for the problems after hours of farting around and hope this simple solution works for everyone. I downloaded ifile from cydia and into the bar i typed in activator. Activator plist and other crap came up such as icons and catalogues.. I just deleted the lot. I did the same for backgrounder and deleted the lot. (Make sure you uninstall backgrounder and activator through cydia first before doing the above as there maybe unforseen issues) let me know how you get on

    The bar i was on about was the search bar. At the end i just reinstalled activator and then backgrounder and wahey my phone multitasks and im happppppy!
    Last edited by cahoosersnip; 2010-05-15 at 12:05 AM. Reason: Automerged Doublepost

  15. #13
    didn't do anything for me. can you give me a more detailed analysis of what you did? possibly what you deleted, what directory you were in, etc.

  16. #14
    Sorry to hear that. In ifile type into the search bar activator and select hiearchy. I had plists and icons come up at this point from a previous install. I deleted the lot. I reloaded activator and it now works. I did exactly the same for backgrounder.maybe if u have an app that runs activator delete that through cydia and make sure the files have gone using the technique in ifile explained above.

    You can find activator in
    /library
    im sure my plist was hidden somewhere else hence i searched for it. Must have been a bad install/ uninstall that caused this problem for me. Have you downloaded any other program that has installed activator with it ( such as backgrounder)
    Last edited by cahoosersnip; 2010-05-15 at 09:23 AM. Reason: Automerged Doublepost

  17. #15
    I think I had to turn hidden files on, but it worked. Thanks a lot for finding this solution. It was bugging the crap out of me

  18. #16
    You are right. I had to turn hidden files on. Sorry i didnt include that. Im glad its sorted for you too.

  19. #17
    Can someone with this issue get on #iphone on irc.saurik.com and message me? I've had _no_ details reports come in on this one.

    (note: I don't visit modmyi and it's unlikely I will read replies here)

  20. #18
    Worked like a charm. Thank you VERY much. Is someone going to talk to Ryan about the issues? I don't even know how to get onto IRC anymore. It has been 10+ years since I have used MIRC back in the day.

  21. #19
    I was ezperiencing similar problems, i first reinstalled Activator then Backgrndr and this seems to have solved mine

  22. #20
    Its good to see the developer on here showing interest in sorting this issue. Fair play. ryan..Im not sure if this is a widespread issue. I started having problems after your acivator was bundled with the last backgrounder update. I originally had overboard which i think had activator added in an update and i had issues with my home button not working when assigned to home so i deleted both apps. I then got backgrounder and i also downloaded some backgrounder badges. Backgounder was working fine though the badges didnt. Backgrounder as u know wasnt packaged with activator at first. Backgrounder became packaged with activator and i started having issues with apps opening then shutting straight away. I deleted bacgrounder and then the badges Like i said earlier in this thread. Looking back on it i should have uninstalled the badges seperately perhaps. When i used ifile i found parts of activator still left on my phone(plists) and also some files associated with backgrounder badges that should have removed themselves on uninstall.. Which was done through cydia. Im not a programmer more a jailbreak nube but id guess theres a bug on uninstall for some iphones that is causing the issue. of course it could be an issue with backgrounder or even a bug picked up fom overboard. Maybe activator could be packaged with ifile lol. Good if u could let us know on here of your findings and keep up ur good work.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •