Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: nmap "Unable to open /etc/resolv.conf"

  1. #1
    Default nmap "Unable to open /etc/resolv.conf"
    I have installed and nmap along with it. Everytime I run it, it tells me "Unable to open /etc/resolv.conf". I can't do reverse DNS lookup because of this though. I couldn't find anything on google or this site about it. I looked in /etc/ and resolv.conf is there. I also tried to chmod 777 it and It says it can't perform that on a "dangling symlink" so that indicates the file is no longer present on the device. I'm not sure where to go from here so I'm wondering

    1) How can I find resolv.conf?
    2) Is this a supported feature in the iphone version of nmap?

    Thanks for all help

    When asked what he would say to the columbine killers, Marilyn Manson said, "I would say nothing to them. I would listen to what they have to say, because that's what nobody else did" from the movie Farenheit 9/11

  2. #2
    hey first of all in the /etc directory run this command

    ls -n
    as you can see this is a symbolic link
    it should be in red in mobile terminal because the place it is linking it is no longer there lol!!!!!

    you will have to create a new resolv.conf in the following directory



  3. #3
    Wow thanks for your reply! It worked!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts