Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Looking for Java runtimes for iPhone 3G

  1. #1
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Default Looking for Java runtimes for iPhone 3G
    I came across a game called TextTwist written in javascript on a website called TextTwist | Apple iPhone School. It was written to run on a 1st generation iPhone as long as a Java Runtime Environment (JRE) called Jiggy is also installed. Jiggy runs the java application interpretively and does not compile the javascript into an Apple application.

    To my knowledge, Jiggy was never updated to install on an iPhone 3G. Does anyone know of Java Runtimes Environment (JRE) that would allow Java applications to run on an iPhone 3G interpretively?

    I would rather avoid methods involving having to compile java application into an Apple Application.

  2. #2
    Go to java section on cydia.You will find many packages there which are needed to run java on 3G.
    Select IPhone/Java.It will install most of the needed packages which includes vm,libraries,etc.
    Install Jikes package as a compiler
    Go to Installed Packages tab.Check that Classpath,IPhone/Java,JamVM, Jikes are installed.
    Exit cydia&reboot your phone...

  3. The Following User Says Thank You to dejawoo For This Useful Post:

    reddawg (2009-03-06)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •