Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: "error during install script execution!" how to fix?

  1. #1
    What's Jailbreak?
    Join Date
    Jul 2007
    Posts
    20
    Thanks
    4
    Thanked 2 Times in 1 Post
    Default "error during install script execution!" how to fix?
    I tried searching, but couldn't really find the answer... I hope someone can help me out here.

    Details:
    - I just updated to 1.0.2 and iTunes 7.4.1.
    - I'm running MacOSX 10.4.10 intel
    - After update, I used AppTapp installer (itunes 7.4 version) to install installer.app
    - Then I ran INdependence (itunes 7.4 version) and installed ssh on iphone
    - SSH and SFTP seem to work fine.

    Problem:
    Installer.app shows up in springboard just fine. It also launches fine. But when it tries to install an application, i get the error: "Error during install script execution!"

    I have seen the post at
    http://www.modmyi.com/forums/showthread.php?t=3560
    that says to be sure ditto is 775. I have tried to chmod 775 ditto using sftp in terminal and i have tried to chmod using Transmit OSX application, but neither work. Transmit shows a Could not change permissions, Failed error. And sftp shows a "Read-only file system" error. I am logged in as root.

    What am I doing wrong? permissions on ditto is set to -r-xr-xr-x.

    i am going mad i tell you... just maaaadddd...
    thanks in advance.
    D

  2. #2
    I have exactly the same problem, with exactly the same configurations and versions.
    Previously t used to work fine, then i had to restore the iphone and re-activate.
    The new things between before and now is the new iTunes and then the new AppTapp and Independence.
    Anyone know how to solve this?

    to be more specific:
    I can launch installer and install community sources but then i can't install the BSD, and thus no more apps, since almost all need the BSD.

    Help is very welcome!

    Thanks.
    Last edited by gemballa; 2007-09-12 at 02:24 PM. Reason: Automerged Doublepost

  3. #3
    Same problem and same configuration, any one with any insight on the matter?

    I cannot install, update or remove any apps with installer.app

  4. #4
    Default Found problem
    The phone is not jailbroken.
    Now it is fine.
    Was quite stupid i guess.

  5. #5
    I have same problem now, have you fixed it yet? Pls advise. Thank you.

  6. #6
    Quote Originally Posted by gemballa View Post
    The phone is not jailbroken.
    Now it is fine.
    Was quite stupid i guess.
    I only encountered this problem after doing the YouTube fix if I jailbreak it again will it break YouTube again also will I have to unlock it for t-mobile use again. Any one know?

  7. #7
    I am having this same problem, and seem to have confirmed what Sideshow says...

    It seems that I can't have an jailbroken iphone that supports my T-Mobile carrier or that allows youtube to work. To install apps, I have to jailbreak the phone, but then to use it, I have to reactivate T-Mobile, which relocks the phone.

    So the question, for me at least, is "Is there a way to have a working T-Mobile iPhone that is jailbroken?"

    It seems like maybe other T-Mobile users don't have this problem, so maybe there's an answer. Anyone?

  8. #8
    Quote Originally Posted by gemballa View Post
    The phone is not jailbroken.
    Now it is fine.
    Was quite stupid i guess.
    I was encountering the same problem as mentioned in the previous posts. However my iPhone was already jailbroken and activated (using INdependence) I still got the same error. Not a wifi problem either as I was able to download the community apps as well as browse YouTube.

    On the specs, the only diff is I have a PPC G4. Otherwise everything else is the same.

    Are there any fixes for this?

  9. #9
    I could also install the Community sourses on the phone but, when i try to instal "DNS tools" i get the ERROR message... ANY CLUES?

  10. #10
    I had this problem, but I fixed it by deleting Installer.app from SSH and then re runing the AppTap installer and everything works fine now

  11. #11
    It seems that there are a lot of gurus on the iPhone field out there but non have either the time to post or knowledge to resolve this kind of problem. I have the exact same issue and I bet there has to be thousands that have it as well. The problem, I believe, is at the time of unistalling an application (maybe is a particular one) a file (or some files, maybe a folder) is erased from it's expected place or creation place... or maybe is a problem with the TIFF format. The reason I say this is because my problems began after uninstalling a few unused applications. I'll tell what I have tried so far and you be the judge..

    After trying to install and update a couple fo applications with no success, I tried to reinstall the Installer (since it doesn't allow me to uninstall itself). That only works if you do it once because it only performs the clean up and not the downloading. If you try to reinstall the installer for a second time (on the same open session) the "downloading package" will show up and immediately will take you out to the springboard. Once I go back in to installer again, I try to download any other application, and after downloading it (it says "installing package" and, bam! it goes back to the springboard or (sometimes) it shows a message saying "error: main script failed!

    I have been with the iPhone since summer and I don't recall having this kind of problems with the early versions of the Installer app. I believe it has something to do with the latest update version 1.1.1 that prevents something with the TIFF files. I'm not an expert but, that's my guess as a .net programmer. I bet there are real gurus of the iPhone out-there. I invite them to share their knowledge on this issue that many of us have.

    I refuse to believe that the only solution to resolve problems of this kind is by formatting and re-installing operating systems.. that's dumb and cheap tech support solutions from non-experts.
    Last edited by xpous; 2007-12-31 at 06:34 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •