Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Manually installed apps crash istantly.

  1. #1
    Default Manually installed apps crash istantly.
    Ok so the problem I am having is that when I try to use an application I have installed manually using SSH the icon appears and I can click on it and it loads a blank white screen then crashes. I have tried many different apps and cant figure out whats wrong...it does it with all of them. I also had this problem when I first got my iphone a few days ago when I was installing apps from apples app store onto my phone directly. They would only work if I downloaded them on my computer first then transfered them to my iphone. Thanks for the help.

  2. #2
    Set the folder permissions to 775 or 777. And if it still doesn't work select all files in the folder and set the permissions of all those files to 775 or 777

  3. #3
    I have tried that and they still don't work. Any app I install from cydia works but ones I manually put on dont.

  4. #4
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,302
    Thanks
    349
    Thanked 1,175 Times in 724 Posts

    You're putting them in the right place? Where are you loading them?

  5. #5
    I have tried several things but they all failed as well. I have tried to install 6 applications manually:
    - Correct folder each
    - Chmod on directory and files
    - Chmod on executable file
    - Chown on executable file (tried several, root, mobile, root:admin, root:wheel, mobile:admin, mobile:wheel

    Still does not work, application crashes instantly after click.

  6. #6
    iPhoneaholic equlizer's Avatar
    Join Date
    Jul 2008
    Location
    Alberta, Canada
    Posts
    308
    Thanks
    7
    Thanked 5 Times in 5 Posts

    when you first do that, you need to install a regular app from the app store (pick any free one) along with one you SSH to the iphone and that should fix your problem.

  7. #7
    I can not do that because, my itunes sync everything except applications. I am running the itunes i downloaded from apple, my phone is running 1.1.4.
    I have purchased 6 free applications. They show up in the library and are now downloaded to my pc. Example Google application.
    However in the device, there is no application tab, so I can not set the sync via itune.
    What I did is take the application from the library, unziped them and put them in the correct directory in the iphone and then reset the permissions (chown, chmod). The applications and icon show up in the iphone and I can click them. They start up and 1 sec later they crash, I tried this with 6 applications:
    - Twitterific
    - Google
    - eReader
    - MobileNews
    - Eventful
    - PangeaVR
    each one behave a little different (Some show the slash screen, other don't); but they all crash some how.
    There must be some ini or DB file in the ihpone which requires an entry in it; but I don't know which one or how to edit. Thanks in advance

  8. #8
    Livin the iPhone Life SundayDuffer's Avatar
    Join Date
    Aug 2007
    Location
    Northern California
    Posts
    1,503
    Thanks
    32
    Thanked 181 Times in 164 Posts

    i dont think 1.1.4 fw works with these apps.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •