Results 1 to 19 of 19

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: BossTool on 1.1.3?

  1. #1
    Default BossTool on 1.1.3?
    When I last had a hacked 1.1.3, I ran BossTool to free up some space. Which, according to today's events, ended up horribly. It replaced most/all my applications with the 1.1.2 versions, and crashed most of them, including stock Apple applications. So what I want to ask is, after following this tutorial, will I still encounter that problem if I try to run Bosstool?

  2. #2
    iPhone? More like MyPhone DirtyDan's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, Texas
    Posts
    164
    Thanks
    17
    Thanked 75 Times in 31 Posts

    Try following this it worked for me:

    http://www.modmyi.com/forums/showthr...owngrade+1.1.3


    Good Luck!

  3. #3
    Oh no, it works fine right now. I followed the updated version of that, and I am now running 1.1.3 jailbroken AT&T, but I'm very wary to use bosstool free up space, based on previous experiences. Did I just get unlucky, or is there a flaw in the program?

  4. #4
    Bump! Please, I'm running out of room

  5. #5
    Looking for similar answers! Today was phone from hell day. I had a perfectly stable JB113 and decided to run BossTool 35. Everything seemed to work - moved fonts, ringtones, then apps.

    Seemed to work.. Can't say if I blame BossTool or myself for what would happen next - but in traversing structures - I noticed that BossTool appeared to have replicated the Application folder within itself! I had /Applications/Applications with everything replicated... So I thinking this was in error - I removed the dupe within Apps folder.. Well, whatever cross linking went on , it resulted in phone, sms, calendar, and mail all where DOA after this. 4 hours tonight reloading phone

  6. #6
    iPhone? More like MyPhone kutrackkid's Avatar
    Join Date
    Dec 2007
    Location
    KU
    Posts
    177
    Thanks
    4
    Thanked 7 Times in 6 Posts

    i moved fonts and ringtones and got over 100mb just doing that but im not going to do apps too risky and i have enough space.
    -20" iMac 2.2 Core Duo, 2 GB Ram
    -13" MB 2.2 Core 2 Duo, 2 GB Ram
    -iPhone 3G 8GB
    -Canon 50D

  7. #7
    Livin the iPhone Life Bernie-Mac's Avatar
    Join Date
    Aug 2007
    Location
    Las Vegas, NV
    Posts
    1,533
    Thanks
    162
    Thanked 136 Times in 95 Posts

    i moved my fonts, ringtones, and apps and my iphone is running great
    iLive an iLife

  8. #8
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    When I only moved fonts and ringtones it crashed my iPhone, but when I moved fonts, ringtones AND apps it runs great. In fact moving these things is the very first thing you should do after Jailbreaking 1.1.3 and installing BSD Subsystem and Open SSH. Otherwise you WILL run out of space for installing apps and your phone will freeze.

  9. #9
    Well I moved fonts, ringtones, and apps on my jailbroken 1.1.3 iPhone as well and the phone is running great with no issues. Though, in my case, the thing that freed up the most space as stated earlier was just moving the fonts so you may just want to do that at a minimum.

  10. #10
    So, I have more information based on my personal experience to offer...

    At this time, I would recommend against attempting to use BossTool v.35 on a 1.1.3 device. Can't say much about 1.1.2, but 1.1.3 is definitely problematic. The stubborn fool I am, after completely wiping my phone back to 1.1.1 and back up to 1.1.3 I re-attempted BossTool (installed on JB 1.1.3).

    Fonts and Ringtones worked like a charm - apparently. When I attempted Apps, it sat there for a bit then dropped back out to main screen. By all appearances, it looked like it failed for "some" reason and still remained available the option to move Apps. So I clicked again. Same result. Now, not realizing that there is minimal error recovery in this process, I realized I was compounding my problem with each successive attempt.

    Here's what was happening:

    - BossTool appears to distribute with it's own mv command, since I later observed CrashReports pointing to BossTool.app/mv failures (sorry, I didn't save that log to upload to assist dev).

    - BossTool properly created symbolic links for Fonts and Ringtones, as expected via front-end.

    - BossTool had moved / copied apps to the /private/var/Applications folder. In the process of moving, it failed and left a number of applications in the /Applications folder and a copy of those same apps (plus some that apparently successfully "moved") in /private/var/Applications

    - The /Applications folder was an actual folder with the actual applications - no symbolic link created at this point. So there are now dupes of apps between / and /private/var

    - On attempting to move apps again, it actually created a mirror of /private/var/Applications into /private/var/Applications/Applications. Since there was no symbolic link created yet, I assume there's some funky logic that starts progressively nesting copies with each failure.

    - I believe the first time I bricked my phone, I may have deleted a nested image which was the target of /Applications symbolic link (i.e. /Applications -> /private/var/Applications/Applications). My lack of diligence.

    - Nonetheless, I was able to correct the mess it made by manually ensuring all instances of apps where in /private/var/Applications (complete with proper permissions), backing up the root /Applications and creating a clean sym link to /private/var/Applications. Renaming /private/var/Applications/Applications, and finally testing all apps. Once I completed testing I was able to delete the backups and consider it a success.

    Boss - hope your reading this

  11. The Following User Says Thank You to Atreides For This Useful Post:

    Teamster (2008-02-09)

  12. #11
    FYI, if this helps anyone, I found the following thread useful in the final repairs:
    http://www.hackint0sh.org/forum/show...23&postcount=2

    Here where my steps (tweaked from those contained in above thread) (PROCEED AT YOUR OWN RISK!!) Assumes a jailbroken 1.1.3 phone:

    1. SSH into phone
    2. "cd /"
    3. "ls -le"

    Should get something like this:
    lrwxr-xr-x 1 root admin 25 Feb 8 03:57 Applications -> /private/var/Applications
    drwxrwxr-x 8 root admin 408 Feb 8 09:31 Library
    drwxr-xr-x 3 root wheel 102 Dec 14 23:22 System
    drwxr-xr-x 2 root wheel 1394 Feb 8 01:21 bin
    drwxrwxr-t 2 root admin 68 Dec 12 02:39 cores
    dr-xr-xr-x 3 root wheel 740 Feb 8 11:40 dev
    lrwxr-xr-x 1 root admin 11 Feb 8 00:52 etc -> private/etc
    lrwxr-xr-x 1 root admin 11 Feb 8 00:52 mach -> mach_kernel
    drwxr-xr-x 4 root wheel 136 Dec 14 23:51 private
    drwxr-xr-x 2 root wheel 646 Feb 8 01:21 sbin
    lrwxr-xr-x 1 root admin 15 Feb 8 00:52 tmp -> private/var/tmp
    drwxr-xr-x 7 root wheel 238 Dec 14 23:49 usr
    lrwxr-xr-x 1 root admin 11 Feb 8 00:53 var -> private/var

    Likely, you should see the Applications folder without the -> private/var/Applications - that's where we start fixing... The remainder of my steps taken presume it does not have that sym link.

    4. Now comes the fun part - reconcile the folders. Issue a "cd /private/var" followed by "ls -le". What has bosstool done yet? Here are some scenarious:
    4a) Applications folder does not exist : Well, this one is simple - issue a "cp -pr /Applications /private/var/Applications"
    4b) Applications folder exists : Issue a "cd ./Applications" followed by "ls -le". If there is an embedded Applications folder, again in this folder - issue a "mv ./Applications ./Applications.old". Now, reconcile the file lists from the /Applications to this folder. In my case, the /Applications folder was a subset of the /private/var/Applications folder.

    5. "cd /"
    6. "mv Applications Applications.old"
    7. "ln -s /private/var/Applications Applications"

    8. Reboot phone
    9. Test EVERY application. Any failures will require going back to the backups and moving where appropriate..

    10. If everything tested fine, you can than run a, b, and c below:
    10a) "rm -r /Applications.old"
    10b) "rm -r /private/var/Applications.old"
    10c) "rm -r /private/var/Applications/Applications.old"

    This is how I went about this. It now works just fine. For those wanting to use my outline above, please use it as a general guideline - not as a concrete step by step since 1) i've drafted this in short time with competing priorities (work) and 2) there might be better ways, this happened to work for me and 3) my steps can't possibly contemplate the variations which might exist...

    Cheers
    Last edited by Atreides; 2008-02-09 at 12:05 AM. Reason: Corrections

  13. The Following User Says Thank You to Atreides For This Useful Post:

    iphoneaddict (2008-02-09)

  14. #12
    Can I upgrade from 1.1.2 to 1.1.3 with BOSSTOOL installed?
    Will it crash my iPhone?
    Will I have to undo BoosTool to Upgrade?

  15. #13
    Quote Originally Posted by macauba View Post
    Can I upgrade from 1.1.2 to 1.1.3 with BOSSTOOL installed?
    Will it crash my iPhone?
    Will I have to undo BoosTool to Upgrade?
    On my first time around - I installed BossTool first and performed the moves, followed by the [devteam] Update.app it puts in there when clicking the jailbreak prep button. It all seemed to work like a charm frankly.

    What I noticed after upgrading was that some applications could not be uninstalled from Installer.app (HP calculators specifically). It was giving me a scripting error. That's when I investigated and saw some funky duplications. My error was deleting items at OS level too hastily.

    The real issue is running BossTool under 1.1.3. Once you run BossTool it can be deleted, since it's a one time patch.

  16. #14
    Green Apple
    Join Date
    Oct 2007
    Location
    United States
    Posts
    57
    Thanks
    7
    Thanked 8 Times in 7 Posts

    Thank you..I've go the symlink running now and BossTool now shows the applications have been moved...regained some disk space. My final question, just so I don't delete something (or rename to old) in private/var/Applications is a second folder called Applications. This is the one I'm suppose to rename to old or can I just delet it. Thanks again for your guide. This was my last hangup after upgrading to 1.1.3

  17. #15
    So is it safe to move applications using Bosstool?

  18. #16
    Livin the iPhone Life Bernie-Mac's Avatar
    Join Date
    Aug 2007
    Location
    Las Vegas, NV
    Posts
    1,533
    Thanks
    162
    Thanked 136 Times in 95 Posts

    ^ yes
    iLive an iLife

  19. #17
    My advice is to back that one up too. It's far easier to SSH in a restore from backups than to perform full restores. After you test everything out - and the symlink clearly points to /private/var/Applications - than it's safe to delete the backups...

    I think that the move operation that BossTool is using can fail midway. So in theory when it created that nested double applications folder, which if you delete without testing could be the only place left for a given app... This is what happen to me - I deleted the nested folder not realizing that the root files where corrupted.

  20. #18
    Livin the iPhone Life
    Join Date
    Jan 2008
    Location
    sd
    Posts
    1,084
    Thanks
    8
    Thanked 99 Times in 79 Posts

    i just left my apps folder and moved fonts, got over 108mb of free space and doubt ill be installing over 200 apps in the future. (most apps are less then 1mb or even half of that)

  21. #19
    I only attempted to move my fonts folder, it came back with increased space but when i tried opening apps they would just crash back to springboard.

    I then proceded to turn the phone off and on again but i am now stuck at the apple logo boot screen with a swirly wheel.

    Any ideas apart from yet another restore?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •