Page 1 of 4 123 ... LastLast
Results 1 to 20 of 72

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 1.1.3 Summerboard/Springboard App Limit?

  1. #1
    Default 1.1.3 Summerboard/Springboard App Limit?
    Hey, I just reached 79, or 80 apps, not sure, and Springboard crashed.

    It just shows a blank Apple logo on bootup, Springboard will not start. I was able to SSH in and delete some apps, and it instantly beings working again. Does anybody know why this is? I'm pretty sure I had more than 80 on my 1.1.2 jailbroken phone.

    I currently have 77 apps in the /Applications folder, and it's gonna stay that way, I guess, unless anybody has a fix?

  2. #2
    This may be the case. I am going to try to reproduce this and test it later.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  3. #3
    Thanks. Is it known what causes this? Anything changed in the 1.1.3 Summerboard that would affect this?

  4. #4
    I seem to be having the same issue. And, there are 79 Apps in my /Applications directory!

    Posted below is my list of applications.

    ls /Applications:
    15.app
    4Balls.app
    APlogger.app
    Aquarium.app
    Backgammon.app
    BallFight.app
    Balls.app
    Banner.app
    BeatPhone.app
    BlockPuzzle.app
    Books.app
    BossPrefs.app
    Caissa.app
    Calculator.app
    Categories.app
    Chess.app
    Colloquy.app
    ContraSense.app
    Customize.app
    DemoApp.app
    Domino.app
    FieldTest.app
    Finder.app
    FiveDice.app
    Frotz.app
    Funiculus.app
    Garf.app
    Installer.app
    Labyrinth.app
    Lights Off.app
    Make My Day.app
    Maps.app
    Marble.app
    Metronome.app
    Mines.app
    MobileAddressBook.app
    MobileCal.app
    MobileMail.app
    MobileMusicPlayer.app
    MobileNotes.app
    MobilePhone.app
    MobileSMS.app
    MobileSafari.app
    MobileSlideShow.app
    MobileStore.app
    MobileTimer.app
    MusicQuiz.app
    NES.app
    Oblique.app
    Othello.app
    PigShooter.app
    Poof.app
    Preferences.app
    Services.app
    Stocks.app
    Stumbler.app
    TTR.app
    Tapp.app
    Term-vt100.app
    Tetromino.app
    TicTacToe.app
    TowersOfHanoi.app
    VNotes.app
    VNsea.app
    Weather.app
    YouTube.app
    Zune2.app
    iBlackjack.app
    iCrossword.app
    iDigger.app
    iFob.app
    iPhysics.app
    iPong.app
    iPowerHour.app
    iRadio.app
    iSlots.app
    iSnake.app
    iSolitaire.app
    openttd.app
    There are 79 applications here. Installing more than this will cause SpringBoard to crash continuously, with the spinny circle thingie, and if you reboot the phone its stuck at that Apple logo as he mentioned.

    Fortunately, I can get rid of a newly installed app through SSH (Thank god for SSH!!!) and SpringBoard will spring right back into action. It seems that ANYTHING i put on that raises this count to 80 or more will cause SpringBoard to crap out.

    Is there ANYBODY out there who is having this problem? I used to have like 9 pages full of apps on 1.1.2.

    Even if some of these apps are hidden (using the individual App's Info.plist's hidden feature that is used by Customize), it still counts as one of these 79 apps. I used to use Categories to make things simpler, but this is still a problem.

    I don't have Customize installed, nor do I have SummerBoard, only Categories.

    A little history:
    My phone is an original, I bought it early July 2007.
    I've been all the way up from 1.0 to 1.1.3
    I have restored my iPhone countless times, trying as many different guides as I could. The first time I put 1.1.3 on, I had the following issues:
    - No Cellphone Reception (Common problem)
    - No DRM (Common problem)
    - Other weird quirks (Many common)
    That was Nate's hack. Then I used the Dev Team's hack. All those weird things were fixed for the most part, but one of the times I restored and jailbroke 1.1.3 every thing that could go wrong did. Then one of the times I did that everything worked, except the sound. NO SOUND whatsoever! Not through headphones, earpiece, speakers, nothing. Solution for that was to install BSD Subsystem when you jailbreak 1.1.2/1.1.1.

    Also, one of the times I did the jailbreak, installing certain things like Services.app caused SpringBoard to do the same thing.

    These problems were presented by a combination of not having the BSD Subsystem installed and restoring from Backups in iTunes when its best not to.

    Now, In previous times, I used the jailbreak 1.1.3 in Installer, the official devteam one. This very last time, I did the jailbreak 1.1.3 kit that comes in a zip archive you download to your PC and upload to your Phone.

    As my apple powerbook is a PowerPC and iNDependence sucks on Non-Intel macs, I've been using my PC for the entire restoring/jailbreaking.

    I've been doing the DFU stuff right, I've really got it down on how to do the jailbreaks right, its just this one thing that has really been upsetting me and it looks like i'm the only one having this problem besides the original topic starter. Does nobody put more than 50 third party apps on their phone or something?

    If someone needs me to post my localpackages.plist file i will, as it may help someone to see if there are conflicting packages that aren't evident in this application list.

    This problem is also not an app space limit, as I have ran the following script that I wrote and kept handy to automagically move my apps to free space (and I used BossTool to move Fonts and Ringtones, it doesn't like moving Applications for some reason)
    appmove.sh:
    #!/bin/sh

    # NOTE: Installer.app is going to be considered a built-in application.
    # It is essentially an integral part of every jailbroken iPhone.

    # Tell springboard to shut it!
    # (Pause springboard so it doesn't discover a missing Applications folder)
    /bin/echo "Freezing SpringBoard... (So SpringBoard doesn't freak out)"
    /usr/bin/killall -v -STOP SpringBoard

    # Create Applications_builtin folder
    /bin/echo "Creating builtin-apps directory..."
    /bin/mkdir /Applications_builtin

    # Move all the builtin apps to the builtin directory
    /bin/echo "Moving files..."
    /bin/mv -vn /Applications/Calculator.app /Applications_builtin/
    /bin/mv -vn /Applications/DemoApp.app /Applications_builtin/
    /bin/mv -vn /Applications/FieldTest.app /Applications_builtin/
    /bin/mv -vn /Applications/Installer.app /Applications_builtin/
    /bin/mv -vn /Applications/Maps.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileAddressBook.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileCal.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileMail.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileMusicPlayer.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileNotes.app /Applications_builtin/
    /bin/mv -vn /Applications/MobilePhone.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileSMS.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileSafari.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileSlideShow.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileStore.app /Applications_builtin/
    /bin/mv -vn /Applications/MobileTimer.app /Applications_builtin/
    /bin/mv -vn /Applications/Preferences.app /Applications_builtin/
    /bin/mv -vn /Applications/Stocks.app /Applications_builtin/
    /bin/mv -vn /Applications/Weather.app /Applications_builtin/
    /bin/mv -vn /Applications/YouTube.app /Applications_builtin/


    # Copy everything else to this new directory:
    /bin/echo "Copying /Applications to /var/Applications..."
    /bin/cp -RPpv /Applications /var/Applications

    # Remove original Applications Directory
    /bin/echo "Deleting /Applications..."
    /bin/rm -Rv /Applications

    # Create Symbolic Link to the "new" Applications directory
    /bin/echo "Creating link to /var/Applications at /Applications..."
    /bin/ln -sv /var/Applications /Applications

    # Create Symbolic Links to the builtin applications
    /bin/echo "Creating links to all builtin apps in /var/Applications..."
    /bin/ln -sv /Applications_builtin/* /var/Applications/

    # Set Permissions
    /bin/echo "Setting permissions..."
    # Sometimes the chown stuff can be flaky as it can't find chown,
    # but permissions are usually set to this anyway, and I check them
    /bin/chown -hv root:admin /Applications_builtin /Applications
    /bin/chmod -v 0775 /Applications_builtin /Applications



    # Unfreeze Springboard and reboot to make things graceful
    /bin/echo "Unfreezing SpringBoard and Rebooting iPhone in 5 seconds..."

    # Thank the customer
    /bin/echo "Thank you for using CLL App-Mover!"
    /bin/sleep 5
    # May speed up reboot process if springboard responds to exit calls.
    /usr/bin/killall -v -CONT SpringBoard
    /sbin/reboot


    I need some help.

    Also, I've tried google-searching the following terms (in case it helps someone with the same problem get here)
    1.1.3 springboard infinite crash
    1.1.3 springboard crash
    1.1.3 springboard app install crash
    1.1.3 springboard application limit
    and "1.1.3 springboard app limit" brought me here.

    Any ideas? I am really annoyed by this and I really am hoping there's a patch or a fix or something that someone has already figured out.

    I thought of some workarounds, such as putting applications in a separate folder and using MobileFinder to get to them or something, but I really like the setup of Categories.

    Thanks in advance,
    CLL

  5. #5
    Argh, yesterday, I forgot again, was at school, and accidentally installed another app again, didn't realize until the spinning wheel never stopped.

    I had no way of finding ip address, so I waitied till I got home so I could look in the router, and I was able to SSH in again and delete. Argh, this is really getting annoying. I have 78, crashes at 79. I DO have Summerboard installed, and used the natetrue jailbreak.

    I was thinking about trying a symbolic link, but I'm guess that won't work.
    If you like or found helpful anything I have said, please click that nice little Thanks button!

  6. #6
    I have the same issue with 77 apps

  7. #7
    Small update: Adding webclips don't add to this limit. I was really scared for a bit, since I added a webclip, and it somehow crashed. Screen turned off, wouldn't turn back on, held power and home, and it booted up, but was at the apple logo for a little bit longer than normal, but it started up fine.
    If you like or found helpful anything I have said, please click that nice little Thanks button!

  8. #8
    You should be able to have up to nine pages in 1.1.3 I think... dunno if it's the same for 1.1.2 or below

  9. #9
    What's Jailbreak?
    Join Date
    Aug 2007
    Location
    Jupiter, Florida, United States
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    yep I get the 77 max limit on apps as well. I did a restore and rejailbreak and added apps one at a time to see if any individual app caused the problem. I did not install customize or Summerboard or anything (other than BossTools) that messed with directories.

    Hit 77 and it happened again. As mentioned earlier, you can SSH in and delete back below the limit to get everything working again.

    This is a real pain. BTW, if you add Categories in Boss' Categories App, they get counted in your limit as well.

    CGM

  10. #10
    iPhone? More like MyPhone techgirl's Avatar
    Join Date
    Jul 2007
    Location
    Newark, New Jersey
    Posts
    227
    Thanks
    30
    Thanked 15 Times in 10 Posts

    Not that you need any seconds here... But I second that! I am addicted to apps and have quickly reached by 79 app limit. Will donate to get a real fix for this. Who's with me?


    Techgirl at your service... Modding MyPhone since Day 1!

    AIM: lindseycholmes
    Skype: lindseycholmes
    Facebook: lindseycholmes


  11. #11
    Well, I tried doing the whole thing again last night. It's obviously can't be something I'm doing wrong, as far as I can tell.

    Here's what I did.

    >> Restored officially to 1.1.3 using iTunes
    >> Booted iPhone into DFU mode (no picture on display but in restore mode)
    >> Shift-Restored to 1.1.1 using iTunes, received error (1015) as expected.
    >>> Phone shows connect to iTunes pic now.
    >> Shift-Restored to 1.1.1 using iTunes AGAIN, without touching the iPhone, received same 1015 error.
    >> Used iBrikr v0.91 to boot the phone. Display background turns red (good) and eventually boots up.
    >> Dialed *#307#, then 0, then Answer, then Hold, then Decline
    >> set prefs: as url #1, http://jailbreakme.com/ as url #2
    >> clicked prefs:, set Wireless AP, set to Auto-Lock: Never, pressed home button
    >> Dialed 0, Answer, Hold, Decline, tapped http://jailbreakme.com/, install AppSnapp.
    >> Phone rebooted soon (within a minute)
    >>> Jailbroken 1.1.1 phone now.
    >> Installed BSD Subsystem
    >> Installed OktoPrep (to jailbreak 1.1.2)
    >> Shift-Updated iPhone using iTunes, received same (1015) error, as expected.
    >> Used 1.1.2 Jailbreaking Java App to boot iPhone, then used that same app to jailbreak it.
    >>> Now I have a 1.1.2 Jailbroken iPhone
    >> Then I Reinstalled BSD Subsystem, just to make sure.
    >> I installed "Official 1.1.3 Upgrader" by devtem.
    >> Ran the updater app.
    >> Answered NO to hacktivation (I can use iTunes to activate)
    >> Answered YES to restore (wipes out all my old iTunes settings, if there, including Music, etc. The upgrader recommended me to do this)
    >> Let sit for a good hour or however long it takes.
    >>> iPhone reboots to the Slide to Emergency screen asking me to connect to iTunes
    >> Fired up iTunes and let it do its thing, ask me to set up as a new phone.
    >>> iTunes unlockes my iPhone to let me use it.
    >>> iPhone says "Waiting for Activation" from the AT&T people.
    >> Reinstall BSD Subsystem
    >> Install OpenSSH (for the first time in the entire process here)
    >> Install my app mover script via scp
    >> SSH into my iPhone, set execute bit for the script, run it.
    >> Script works with no errors (script is posted in post #4)
    >> Install about 60 apps or so.

    >>> At EXACTLY the 80th application installed (INCLUDING apple-apps built in), SPRINGBOARD CRAPS OUT!

    Can someone tell me if I'm doing something wrong or is this a bug (on anyone's part, including mine(Apple/DevTeam/App Devs/Me))?

    The only other thing I can think is going on is that Apple decided they were never going to put more than 80 apps on the Phone and that somehow there is a special Applications folder or something in the /private/var/mobile/ that is expected to be there when iTunes lets people put on Official 3rd Party apps, which could be potentially unlimited.

    Even if someone could develop a patch for SpringBoard, that'd be great. Right now, I'm gonna take a look at SpringBoard's crash log, and if anyone needs to see it, let me know and I'll post it tonight.

  12. #12
    My iPhone is a Part of Me tsatryan's Avatar
    Join Date
    Aug 2007
    Location
    Clifton, NJ
    Posts
    919
    Thanks
    219
    Thanked 419 Times in 157 Posts

    I can also confirm that this is indeed a real problem. After once again doing a complete downgrade and upgrade to 1.1.3, and in the process of installing apps again, I eventually hit a threshold, and after installing an app, Springboard was stuck with the spinning circle for a very long time, which followed by being stuck on the apple logo.

    I found this thread, and instead of once again doing a total restore, used WinSCP to manually delete the apps I was installing when this happened, and as soon as I deleted, SpringBoard immediately came back to life.

    I'm not at all sure what the solution is, but it is a very real situation. Right now, I have exactly 77 apps installed. I will add one at a time to see if more can be added, now that I know how to remedy the situation.

    A word to the wise - until a fix is found, be very selective in how many apps you install!!

    Edit -
    I have tried and tried, and it appears that there is a "wall" that I hit as soon as I try to install an 80th app. All is ok with 79. When I install the 80th - either through Installer or adding the app manually - as soon as you refresh SpringBoard, things freeze. So, through WinSCP, I will manually delete an app, and it doesn't appear to matter what the app is, just pick one, and everything refreshes.

    It looks as though this is a problem with the current version of SummerBoard. Hope that this can be resolved.
    Last edited by tsatryan; 2008-02-09 at 08:12 PM. Reason: Automerged Doublepost

  13. #13
    Happens to me at 78 or 79 now.
    If you like or found helpful anything I have said, please click that nice little Thanks button!

  14. #14
    My iPhone is a Part of Me tsatryan's Avatar
    Join Date
    Aug 2007
    Location
    Clifton, NJ
    Posts
    919
    Thanks
    219
    Thanked 419 Times in 157 Posts

    bump

  15. #15
    I'm using Categories, so I only have 1 page of apps showing on my SpringBoard, but I get the same problem as soon as I install the 80th app.

    Thank god for SSH though.

  16. #16
    My iPhone is a Part of Me tsatryan's Avatar
    Join Date
    Aug 2007
    Location
    Clifton, NJ
    Posts
    919
    Thanks
    219
    Thanked 419 Times in 157 Posts

    Does NullRiver know about this situation? I googled a bit, and this was also a problem with a previous version, with a limit of 80 apps.

    Using Categories works fine - I use it myself - but it does nothing to change the number of apps limited by Summerboard. In fact, creating a category acutally ADDS an app to the list, since the program technically creates a program in the Applications list for each category you create. So, if you have say 6 categories, then that is 6 fewer real applications you may install.

  17. #17
    Yep. I've also noticed that it doesn't matter how many FOLDERS are in Applications, since I deleted the contents of the folder through SSH, and Springboard came back immediately, before I had a chance to delete the folder itself.

    Also, an idea. Extended Prefs adds an option to have hidden apps. Those apps are placed in a different directory (/AppleInternal/Applications/). Perhaps we could put apps in there, disable the hidden apps so they show up, and it'll be there?
    If you like or found helpful anything I have said, please click that nice little Thanks button!

  18. #18
    Same here, Springboard crashes at 80 applications in /Applications (including built in apps). 79 works fine, crashes at 80. This is on a 1.1.3 firmware.
    Last edited by michelkenny; 2008-02-12 at 01:11 AM.

  19. #19
    Interesting. Everybody else seems to be crashing at 80. I crash at 78 for some reason.
    If you like or found helpful anything I have said, please click that nice little Thanks button!

  20. #20
    My iPhone is a Part of Me tsatryan's Avatar
    Join Date
    Aug 2007
    Location
    Clifton, NJ
    Posts
    919
    Thanks
    219
    Thanked 419 Times in 157 Posts

    What's even more interesting is that this thread isn't being over-run with posts. Is this problem only affecting the few of us that are posting here, or are other people not installing that many apps? I would have thought that this would be big news and a big problem, but other than this one little thread, I don't hear or see anything at all about it.

Page 1 of 4 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •