Page 1 of 2 12 LastLast
Results 1 to 20 of 40

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: OpenSSH - Server unexpectedly closed network connection

  1. #1
    Green Apple
    Join Date
    Jul 2008
    Location
    Someplace around here....
    Posts
    48
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question OpenSSH - Server unexpectedly closed network connection
    To everyone out in Modmyifone land! You are all extremely intelligent with the ways of the iPhone, and was hoping someone could quickly answer if they know if with iPhone 2.0.1 pwned, will not allow SSH connections.

    I only updated when I got word that 2.0.0.4 was out, and have read Saurik's messages constantly on Cydia, but I don't see any updates about SSH on 2.0.1. If I try WinSCP, I get a "Server unexpectedly closed network connection."

    Obviously I've done some obvious things:--

    OpenSSH is installed, and I've reinstalled, as well as uninstalled, rebooted and installed yet again. Still nothing. I have Bossprefs installed, and I know that OpenSSH is 'On', but same thing.

    If I turn it off, I get a different error. So I know its sort of working, but not fully.

    Any help?

    I've also tried OpenSSL, uninstalling warns of irreversible damage... So that's no good.

    Does 2.0.1 need BSD Subsystem? Cause I can't find it on Cydia, nor installed.... I know it was required on 1.1.x,

    THANKS IN ADVANCE to anyone who might be able to help..

  2. #2
    Green Apple
    Join Date
    Jul 2008
    Location
    Someplace around here....
    Posts
    48
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Got 'er done...

    I restored again to the broken custom 2.0.1 and it just works..

    I've researched everywhere! People say to reinstall OpenSSH, reinstall WinSCP, and all that garbage...

    Log in with iphonebrowser, and delete the openSSH keys. None of that worked.

    Restore with the custom firmware... Started working right away!

  3. #3
    allright, I may be a noob, but i figured it out for you all!

    I have an iphone 3g - firmware 2.2.1, jailbreaked with quickpwn 2.2.1

    I tried and tried and tried to connect thru winscp but kept getting that message "server unexpectedly closed network connection"

    I installed "openSSH" and unix subsystems in installer. But STILL I was getting the same error. I tried adding "vsftpd" (from BigBoss) in Cydia. Still no luck. Then I noticed openSSL in installer. I installed that and VOILA!!

    Matter of fact, to my recolection, openSSH and openSSL and unix subsystem were pre-installed when I did the jailbreak. But in my stupidity I unistalled what I thought were uneeded programs. There you have it. When using quickpwn, TRUST them! Hence why all of you who repeated the jailbreak process were able to fix your problems.

    I guess my only question is now, how to I get my phone to stay "awake" during file transfer - because letting it sleep cuts out the wifi connection ??

  4. #4
    My iPhone is a Part of Me JAG2621's Avatar
    Join Date
    Jan 2008
    Location
    Alabama
    Posts
    510
    Thanks
    20
    Thanked 58 Times in 45 Posts

    Quote Originally Posted by austenbach View Post
    I guess my only question is now, how to I get my phone to stay "awake" during file transfer - because letting it sleep cuts out the wifi connection ??

    Set Auto-Lock to never and when you get done set back to whatever setting you had it on.
    Last edited by JAG2621; 2009-02-13 at 08:30 PM.
    If anything was usefull a thanks would be great!

  5. #5
    What's Jailbreak?
    Join Date
    Nov 2008
    Location
    Trinidad
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I suddenly started getting this error. No clue what to do to solve it. Tried,
    respringing iPhone,
    rebooting iPhone,
    restarting WinSCP,
    reinstalling OpenSSH & OpenSSL
    none worked. Even updated WinSCP to its latest BETA. Anyone could help?

    Thanks.


    Sent from my iPhone 4

  6. #6
    Yesterday mine started saying this
    ssh_exchange_identification: Connection closed by remote host
    and I couldnt for the life of me SSH into my phone..
    finally had to restore... everything works fine now.

  7. #7
    I'm having a similar problem. What keeps happening is that I have to reinstall OpenSSH each time I want to do anything to my iphone.

    Once I reinstall, I have a period of approximately 15 seconds or so before I get the server closed network connection message and I then have to reinstall OpenSSH.

    Any thoughts?

  8. #8
    same problem anyone help??

  9. #9
    I was searching high and low for the cause of this problem and realized that I got the ikee worm!!

    You guys probably have it too...

    follow the instructions below :-

    * Variants A-C Follow these steps

    1. First Change your root password (Follow Answer 2).
    2. Now, will start deleting bunch of virus effected files..
    3. Type “rm /var/mobile/Library/LockBackground.jpg” and hit return- With out “s
    4. “rm /System/Library/LaunchDaemons/com.ikey.bbot.plist” and hit return
    5. “rm /bin/poc-bbot” and hit return
    6. “rm /bin/sshpass” and hit return
    7. “rm /var/log/youcanbeclosertogod.jpg” and hit return
    8. Now, close Terminal app.
    9. Select your favorite wallpaper and reboot your iPhone.

    * Variant D – Follow these steps

    1. First Change your root password (Follow Answer 2).
    2. Now, will start deleting bunch of virus effected files..
    3. “rm /usr/libexec/cydia/startup” and hit return
    4. “rm /usr/libexec/cydia/startup.so” and hit return
    5. “rm /usr/libexec/cydia/startup-helper” and hit return
    6. “rm /System/Library/LaunchDaemons/com.saurik.Cydia.Startup.plist” and hit return
    7. Now, close Terminal app.
    8. Reboot your iPhone.
    ****If you got effected with Variant D. You need to reinstall
    Cydia.


    iPhone Virus (ikee or rockroll) - Protect your iPhone | Mac Hack PC - Hack it all you can...
    Last edited by Doppelgriff; 2009-12-02 at 07:13 AM. Reason: Automerged Doublepost

  10. The Following 2 Users Say Thank You to Doppelgriff For This Useful Post:

    DJ Bless One (2010-11-30), jogosnick (2010-08-08)

  11. #10
    Default Another Possible Fix
    Hey I think i have a solution for those who didn't find the answer earlier, My i3G had no worms, not sure what was wrong with it but everytime i reinstalled openssh it would allow me to connect for about 15 to 30 seconds from installing, I did the reinstalls from rock, for change i uninstalled it from cydia , which prompted an error that it couldn't delete the directory "\etc\ssh" so i used iFile to deleted it , then reinstalled openSSH and voilla, it worked...
    PS: my first post to the IT world ever!

  12. The Following User Says Thank You to Soloplay For This Useful Post:

    Dara (2010-05-12)

  13. #11
    Yes !!!!!!!!! It also worked for me finally !!.
    I've uninstalled OpensSSH and installed it again using Rock application. Many thanks !!

  14. #12
    Figured out a Fix that doesn't require restore

    1. Open Cydia
    2. Go into "Manage" -> Packages.
    3. In the top right corner, click, Simple.
    4. Reinstall OpenSSL, OpenSSH and sbsettingstoggles (Use the Queuing function to ReInstall all in one hit).
    5. ReBoot.
    6. Change your password: http://cydia.saurik.com/password.html


    FIXED!

    Edit: This seems to be a temporary fix, and the problem will re-occur!

    Edit: Seems there is no permanent fix
    Last edited by mofolo; 2010-03-11 at 10:10 AM.
    myRepoSpace.com - Easily create your own Cydia Repo.

  15. #13
    So I've taken the leap of faith,

    I've restored and have NOT installed the latest Cydia Updates.

    SHH and SSL works 100% smoothly.

    I think there is a bug in the new library's that affect SSH.

    Someone must report it.
    Last edited by mofolo; 2010-03-12 at 03:52 AM.
    myRepoSpace.com - Easily create your own Cydia Repo.

  16. #14
    Green Apple McMike's Avatar
    Join Date
    Jul 2009
    Location
    America's Wang (Florida)
    Posts
    90
    Thanks
    73
    Thanked 10 Times in 9 Posts

    Uninstalled SSH w/Cydia, reinstalled with Rock - worked like a charm. Thanks!

    Minor correction: This seems to be a temporary fix. Later attempts to SSH into my phone werent successful - had to uninstall/reinstall over again.

    Very inconvenient, but its better than having to restore my phone again...
    Last edited by McMike; 2010-04-08 at 02:26 AM.
    _____________________________________________
    - iPhone 4S, Black/32GB, 6.1
    - iPhone 4, Black/8GB, 6.0 (wife's)
    - 13" MacBook Pro, OS X 10.8.2 / Windows 7 via Parallels

  17. #15
    I'm having the same problem here. Has anyone found a fix?

  18. #16
    iPhone? More like MyPhone
    Join Date
    Oct 2007
    Location
    Minneapolis, MN
    Posts
    179
    Thanks
    12
    Thanked 12 Times in 10 Posts

    Same problem here.....no fix.

  19. #17
    Thumbs up SSH ( server unexpectedly closed ) FIXED
    Thanks for the hero Soloplay for his Solution

    about this silly error

    this my fisrt post i liked to share it with u cause it works

    with me on : jailbroken iphone 3gs .. V 3.1.3 .. BB 5.12.01

    here's The full Tutorial made by me to fix it in 10 steps it's not

    that diffcult just focus


    ** The tutorial **


    first you have two things to do if you have

    backgrounder unistall it ( its for multiapp run ) it's cause of

    the problem don't ask me why but when i deleted it everything

    goes as it should is that clear

    Second you must change your default root password you can do that simply by mobile

    terminal can be found in cydia here is how install it from cydia then open it and type

    these commands one by one

    login " and hit return "
    root " and hit return "
    now type the default password wich is : alpine
    now type " passwd " without (")
    type your new password and hit return and confim it again and
    done.you can exit the terminal

    let's complete fixing SSH

    1- now go to ( Cydia - manage - packages ) and remove OpenSSH

    2- in cydia search for (ifile) from Bigboss and install it

    go back to your apps list and run ifile

    3- now click on ( etc ) delete the directory ( SSH )

    4- Reboot your device

    5- Go to cydia and install rockapp ( Rock ) it's made by modmyi

    6- Press home button and find rock open it it's similar to cydia

    7- Now search for OpenSSH and install it

    8- Reboot your device

    9- before trying to access your phone please make sure autolock

    is set to ( never ) till you finish using SSH


    10- Done ..

    you must have now the full access to your phone without

    disconneting after period seconds


    ** Tips **

    *Make sure that your ssh clint on the computer is up to date i

    recommend WinSCP very simple and stable


    WinSCP :: Download

    * Make sure of setting your SSH Clint with your new root password

    wich is will be like this


    host : Your Iphone IP
    Username: root
    Password: the new one you've created with mobile terminal above


    if the problem still pop up you have to restore your device

    with a cfw just google it but im sure it's gonna work

    finally i hope that was helpfull

  20. #18
    Me and my Girlfriend have the same problem on both our Iphone 3G. Hope they can fixed this soon. It is not worthy having you phone Jailbroken and not be able to us SSH.

  21. #19
    i've used ssh yesterday and its working fine on my phone, suddenly today im getting this error

  22. #20
    Thumbs up Update : Temporary solution for the Problem
    days later the error returned again without knowing a reason

    Damn .. i thought that was good enough ..

    But don't worry guys i made a Temporary solution may be usefull

    and it's very easy to do ...

    * get ifile from cydia

    * download the attach file down here

    ( it's OpenSSH app but in .deb fromat

    * just drop it after extract it in /var/mobile/ you can use iphonebrowser to

    browser files for now or access via ssh i think you have the

    time to drop 337Kb file .. anyway

    * after that open ifile and navigate to the directory you

    Dropped the file in ( /var/mobile/ )

    * tap on it and select installer (must have mobile terminal)>cydia

    * after the proccess complete you will access

    SSH again and browse files and even the error appear during

    copying files or anything don't abort just install again

    like you did , it gonna reconnect Directly you will not lose anything then

    i think this so much easier instead of install again 'N' again with cydia


    i'll do my best to solve the problem i promise
    Attached Files Attached Files
    Last edited by vistax; 2010-05-31 at 04:53 PM.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •