Page 6 of 10 FirstFirst ... 45678 ... LastLast
Results 101 to 120 of 185

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help! Categories messed up my iphone

  1. #101
    Hello, Im on a Touch with firmware 1.1.1. I had categories, played around with it then I pressed the help function inside it. It crashed my ipod so I rebooted. I was able to get into the installer with SSH and uninstall categories then installer the Stock Display order thing. Didnt do anything.
    What should I do?


    EDIT: I think ive fixed it, it was that damn iPhone Home app that bugged it up. (I think). Ill run some more tests to make sure it was that and Im not still faced with a bigger issue. It seems to be working fine now. I will edit, or reply if I encounter more issues.

    I must say, this Categories app is great! I have like 150 apps and this is great tool to organize them with. If this works properly (It seems to be so far ) then I want to thank BigBoss for making such a wonderful app! I like BossPrefs too!!!
    Attached Files Attached Files
    Last edited by gameplaya3159; 2008-01-03 at 07:04 AM.

  2. #102
    I think I finally have found and fixed the display order bug thanks to a few people that sent me their corrupted display order plist files! I have updated categories to v1.40. In addition to the display bug being (hopefully) fixed, I have added some extra display order protections to prevent messing up anyone's phones:

    1) Now have a display order plist validate function that checks that the proposed display order categories is going to write is "sound". This means that all the <dict> have matching </dict> etc.
    2) The above check should also prevent saving a 0 byte display order when the system drive is full!
    3) The finaly check is done when categories exits. At any time if the display order is bad and you try to exit categories, the back up display order plist will be copied into place. (Of course, if the drive is full, this wont help). Unfortunately, since this runs when the app exits, there is no way to prompt the user that I have found.

    Check out my changelog (written for iPhone display from within the categories app):
    http://sleepers.net/~iphone/categories/changelog.shtml
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  3. #103
    Green Apple
    Join Date
    Oct 2007
    Location
    Somewhere Here
    Posts
    89
    Thanks
    2
    Thanked 12 Times in 10 Posts

    I installed an app called VKConverter (found here: http://code.google.com/p/iphone-converter/ Installer link: http://iphone.vladimirkofman.com/).

    If I tap on its icon in the springboard, it launches fine BUT when I added it to one of my categories (Utilities) tapping on it just returns me to my springboard.

    The app's icon is present both in my springboard and in my Categories "Utility" folder. The app wouldn't launch if tapped inside the Utilities folder but launches fine when tapped in springboard (I hid the icon in springboard using customize and the same thing happens).

    Thanks!

  4. #104
    I seem to have exactly the same problem as you with Convert & Categories - strange

  5. #105
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Location
    Orlando, FL
    Posts
    121
    Thanks
    10
    Thanked 3 Times in 3 Posts

    Same problem here but with NES
    but not a big deal... I can live with this minor bugs
    Major credit to the Programmers.
    Your efforts makes the IPHONE that much better. Thank You! Without you, There is no Us!!

    I believe in beta testing for free and paying for Smooth integrated, Compatible, and functioning Apps.

  6. #106
    Nice find AMF! It's because VKConverter's plist file is in uncode. I fixed it and will post the fix in a bit.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  7. #107
    Green Apple
    Join Date
    Oct 2007
    Location
    Somewhere Here
    Posts
    89
    Thanks
    2
    Thanked 12 Times in 10 Posts

    I tried v1.41 and VKConverter is now launching properly. I still can't see an icon though for fieldtest and demo apps...

    And thanks for the acknowledgment in the change log! And for the continuous update and improvements you're doing. Thanks a lot!!!

  8. #108
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Location
    Orlando, FL
    Posts
    121
    Thanks
    10
    Thanked 3 Times in 3 Posts

    I might have missed this thru the thread but is there a way
    to arrange the icons with the category?

    I also want to express my gratitude for your continous efforts
    Thank You
    Last edited by dmighty; 2008-01-05 at 02:50 AM.
    Major credit to the Programmers.
    Your efforts makes the IPHONE that much better. Thank You! Without you, There is no Us!!

    I believe in beta testing for free and paying for Smooth integrated, Compatible, and functioning Apps.

  9. #109
    I might have missed this thru the thread but is there a way
    to arrange the icons with the category?
    Yes, just load the categories app, click the category, and rearrange the items you want the way you want them.

    Same problem here but with NES
    but not a big deal... I can live with this minor bugs
    I have never (and still do not) have a problem with NES app. Maybe try uninstalling and reinstalling it.

    I still can't see an icon though for fieldtest and demo apps...
    Damn, I didnt update the "updater" app . Try removing and readding those and I bet you see the icons. Damn, tried that and it recopies the group icon instead of the blank. Ok guess I need to fix that too
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  10. #110
    That fixed it, thanks!

    - just a 'cosmetic' : the 'spring' is a bit tight at the bottom of the config window.

    - I think the 'No Plist Protection' option would be more logical like this:
    Plist Protection ON/OFF
    with it set to ON by default.

    - the same with 'Remove Prefs Warning' :
    Prefs Warning ON/OFF
    Last edited by jrentzke; 2008-01-05 at 01:47 PM.

  11. #111
    I agree it would be more logical that way but the reason I can't do it that way is because of existing installs. The config file is 256 bytes and the unused potion is set as 0. So when I add anything and I want it to default to "on", I have to make sure that 0 is "on" so the config option ends up being some form of not.

    Anyways, I think I'm going to pull out the stability warning and pack this up for STE this weekend.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  12. #112
    Hi BBoss i had 1.1.1 when it first came out and intall summer board and it said i was running out of space .so i rebooted and my Iphone became a ipod.I had to reinstall every thing over again I think it has to do with running out of space.... So your app is not the only app turning the iphone into ipod. Hope this help.

  13. #113
    Loving this app!

  14. #114
    Hi BBoss i had 1.1.1 when it first came out and intall summer board and it said i was running out of space .so i rebooted and my Iphone became a ipod.I had to reinstall every thing over again I think it has to do with running out of space.... So your app is not the only app turning the iphone into ipod. Hope this help.
    That could be true but I think now it will be impossible for my app to cause this problem with the extra safeguards. If there is no free space, it will not write the plist file any more. I plan to submit to STE repository this weekend.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  15. #115
    Nice update, 1.50. Now that you have the displayname instead of the appnames would it be possible to have the displaynames on the edit screen for a category too?

    Besides the things i've said before about future features i think that Categories would be even better if it has the feel of not beeing a app, but a extension to SB. So i was sorry to see the addition of the Edit button. I think both the Screen, category name and Edit button should be in the settings and not inside the categories. But that's just my opinion.

    Not that it is possible now but what would be cool, maybe in the future if 1.1.3 has the features that have been rumored and is possible to jailbreak, is to drag and drop icons on a category to add it to that category.

    Anyway, i would like to see Categories to go in the way that it dont feel like a app but a part of SB. And that would be no buttons or things inside a category. I hope it will be that way in the future. But even if it is not it is a great app.

    EDIT: Think i've found a bug. Dont know if it has been reported before. But if i add Photos app(didnt know it was called MobileSlideShow so it took me a while to find it) when SB has been restarted, the first time it runs the Camera app starts. Every time after that the Photos app starts. It is after a SB restart this happend.
    Last edited by raptorjr; 2008-01-06 at 03:09 PM.

  16. #116
    Nice update, 1.50. Now that you have the displayname instead of the appnames would it be possible to have the displaynames on the edit screen for a category too?
    Ah, yep thats a good idea. I missed that one.

    Anyway, i would like to see Categories to go in the way that it dont feel like a app but a part of SB. And that would be no buttons or things inside a category. I hope it will be that way in the future. But even if it is not it is a great app.
    I'll probably make a config option to hide the nav bar entirely. Showing the dock would be much more work.

    Think i've found a bug. Dont know if it has been reported before. But if i add Photos app(didnt know it was called MobileSlideShow so it took me a while to find it) when SB has been restarted, the first time it runs the Camera app starts. Every time after that the Photos app starts. It is after a SB restart this happend.
    That is a funny one. I reproduced it also. There are some weird things about adding some of the apps. I have it listed in my "known issues" section. But I'm not sure if you noticed when you added the photos app that it didnt hide from the desktop.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  17. #117
    hi BigBoss,
    thank you for a powerful app.
    it realy cleaned my desktop.



    Q1:is there a way to move Camera.app ,photos etc? i cant find them on customize
    Q2:how can i edit category name?
    Q3:will the Fix Disk Space application ( http://eugeneciurana.com/site.php?page=iphone )
    will mess up Categories.app

    (too late but ) Happy new year all

    Simon

  18. #118
    Ok I just had the same problem happen on my phone too. I am running firmware 1.1.2 on my iPhone. I installed Catagories and made 4 catagories, added tons of apps to each catagory and was happy until I noticed every time I tried to update an app using Installer that the app would partially install then fail. It happened when I tried to install new apps too. Also when I uninstalled it would only partially uninstall, leaving the app dir in applications with some of the app parts left in it.

    So i decided to uninstall Catagories since these problems only showed up after using Catagories. I cleared out all the apps out of Catagories and then removed the catagories from Catagories and then using Installer, I uninstalled Catagories. I then rebooted my iphone.

    Then the nightmare started, my phone screen came up with my wallpaper and the word iPod in the section of the Title bar where the phone reception bars normally are. My wifi connection is showing as is the time and the battery icon. When I click the Home button I get the iPod music bar in the middle of my screen. When I call my iPhone from another phone it shows the caller and yet when I slide the bar to answer, it doesn't slide open and answer, yet after the call drops, I can slide the bar and it shows my phone screen, with Favs Recent Contacts keypad & Voicemail like usuall, yet if I click the Home button, the iPod bar comes up and it takes me out of the phone screen back to the wallpaper minus any icons.

    I am SSH'd into the phone and found the Catagories directory still intact with the M68AP.plist still in the directory. It appears that that file is a few bites smaller than the same file located in the system/Library/Core Services/SpringBoard.app dir.

    I have copied both using SSH and I am about to copy the one from the Catagories dir over to the SpringBoard.app dir now for testing.

    No blame over here, just a commitment to making my phone return to normal.

    Thanks,

    JintheC

    Ok, Success!!! Here's what I did...

    I renamed the M68AP.plist file in System/Library/Core Services/SpringBoard.app dir to M68AP.plist.old and then copied the M68AP.plist file from Var/Root/Library/Applications/Catagories using SSH through wifi.

    I then rebooted my phone and I was back in business with my home screen back to normal.

    I wonder how Catagories handles unistall in that perhaps it just doesn't copy the M68AP.plist file from it's directory to the System/Library/Core Services/SpringBoard.app???

    Well I just went into Installer and did the update that was failing while I had Catagories installed and now it finishes the update.

    I am wondering if the problem with the installs and updates has something to do with the hidding and relocation of app icons that seem to be under Catagories control?

    Love to use this app again in the future when these issues are addressed.

    Thanks BiggBoss for all the work, this app is nearly perfect, and I am eager to use it when it is.

    JintheC
    Last edited by jinthec; 2008-01-08 at 05:14 PM. Reason: Automerged Doublepost

  19. #119
    Ok I just had the same problem happen on my phone too. I am running firmware 1.1.2 on my iPhone. I installed Catagories and made 4 catagories, added tons of apps to each catagory and was happy until I noticed every time I tried to update an app using Installer that the app would partially install then fail. It happened when I tried to install new apps too. Also when I uninstalled it would only partially uninstall, leaving the app dir in applications with some of the app parts left in it.
    I cant comment without seeing your phone and what happened, but it sounds like your / partition ran out of disk space. Do you still have the M68AP.plist file from when things were not working? Thats the only way I can ever fix something. Also, what version were you using? The latest version(s) should not have any more display order issues.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  20. #120
    Quote Originally Posted by mcgill4 View Post
    I'm just glad it worked for you. These threads saved my butt to, so I'm glad I could help someone else.
    mcgill4,
    You are a LIFESAVER!!! Thank god that you helped put up this link! I'm also going to say thanks to "mjdaul" too.

    BigBoss:
    I had spent alot of time reading through these forums, and want to say a big thank you for devoting your time to refining your app and helping us. The problem I had was that I messed around with the configuration without really knowing what I was doing, and slid on the "Allow Hide Icons", which I read somewhere that you identified as a bug and turned it off as default.
    Once that was on, and I did something else (cant remember, was half-asleep in bed... NOT a good idea!) then the screen went blank like the others described.
    Anyway, here's my 'corrupted' M68AP.plist file if it helps you to further iron out bugs. My iPhone is a v1.1.1. http://pastebin.com/m7d449a82
    Good work!!!

Page 6 of 10 FirstFirst ... 45678 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •