Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Building a custom package problems

  1. #1
    Default Building a custom package problems
    So basically I'm trying to create my own source and am having problems.

    Firstly, is there something special I need to do to let installer know it needs to update a package? I changed the version number on the package's plist, but that doesn't seem to let installer know it needs to update a package.

    Secondly, I've already looked at this http://iphone.nullriver.com/beta/ but it doesn't seem like there's a complete list of script commands (like CopyPath), is there somewhere I need to be looking to find those?

    Thanks for any help.

    EDIT:

    Thanks to CyberGreg I got a definitive answer to my question.

    You have to use a number on the version number or it messes it up. Like an idiot i used "BETA" as the version number.

    Luckily I also messed up the unistall script so now I'm screwed. any ideas how i can remove it from installer?

    EDIT:

    I used my thinking powers and figured it out. I had to go into var/root/Library/Installer and edit the LocalPackages.plist
    Last edited by chemicalcomfort; 2007-11-15 at 06:08 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •