I haven't seen anything about this, nor did any true answers come up in my search, so I was wondering, is Categories 1.72 safe on 1.1.3?

I had Categories on my 1.1.3 before, however after I heard it gave many people problems, I uninstalled it.

Thanks for the help!