Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Term-vt100 svn278 Problem!!

  1. #1
    Default Term-vt100 svn278 Problem!!
    i update my term-vt100 to svn278 but i have some problems now...

    1. when i try to work as root user by typing "sudo".. gives error "command not found"
    2. when i try to log in as root by typing "su", password "alpine" is not ok...


    i installed SUID Lib Fix already.. it didn't help...

    what can i do? i can't do anything with the "mobile" user..

  2. #2
    using commands: "login" after that type: "root" - pass: "alpine"
    Work is Glory!

  3. #3
    thanks.. i didn't know the command "login"..

    but what is the command not found issue for sudo?!

    new terminals menu has sudo command...

  4. #4
    how can you press control-c with the new interface?

  5. #5
    iPhone? More like MyPhone
    Join Date
    Mar 2008
    Location
    Not too far from Mr. Miyagi's place
    Posts
    126
    Thanks
    36
    Thanked 21 Times in 17 Posts

    The fact that you can really only be the mobile user using the updated Term-vt100 doesn't help all that much. I've tried the login command with and without various arguments/switches and still can't get root access.

    But the Hack that Phone source (hackthatphone.com/1 is the source to add if I recall) has the old svn198 version of Term-vt100. I installed that, installed the BSD fix as well as the SUID fix from the Tweaks (1.1.3) and plain Tweaks sections and life is back to normal now.

    Might want to go back to the older version for the added flexibility. The new one may work a lot better if you have Cydia installed since it has a much better working BSD subsystem. I personally don't like the file system layout Cydia does and I get along without a problem using the standard buggy one. (I did change my password for my root and mobile users editing the master.passwd file using the vi program, so security isn't an outstanding issue).
    I came, I saw, I forgot what the hell I was there for.

  6. #6
    add this source:
    iphone.lenlolabs.com

    and install BSD Subsystem 2.x SU ...

    the "su" command works now for me.. but there is no sudo still...

    ctrl+c command is still at the same place just move your finger from center to right up fastly

  7. #7
    Whein I try to use 'cp' or 'mv' I always got a "Permission Denied" error

    So I tried to use 'sudo' but this command was not found

    Whats going on with this version ??

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •