Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: HELP: rSBT has hidden ALL of my Applications

  1. #1
    Default HELP: rSBT has hidden ALL of my Applications
    Hello,

    Here is my situation:
    -Iphone is brand new with original firmware 1.1.1 installed.
    -Used Independence (beta 1.3?) to Unlock & Jailbreak
    -Used Installer to install 3rd party Apps
    -Long story short, rSBT ended up HIDING ALL MY APPS (EVERY SINGLE ONE).

    Skip to the CliffNotes if you dont want to read all this =)

    **I originally used a Mac to unlock, but a PC is readily available**

    I've read a few solutions, but the basis of most approaches were either to use SSH or Ibrickr to route into the phone folders, and (it seems) the most successful approaches were:
    1) Modify M68AP.plist on the PC and replace it on the iPhone
    2) Restore with Independence

    Here's my issue.
    A) I'd really like to just try approach #1, BUT my particular unlock guide instructed me to remove SHH after jailbreaking. Also- I DID NOT WRITE DOWN my IP Address (i know im an idiot). So even if I were to reinstall SSH, I would not be able to pull up my IP.
    B) Being that my phone was originally 1.1.1 and I've now unlocked and jailbreaked it. My understanding is that I cannot now just use Independence to restore the whole thing.


    Any ideas?

    [Cliffnotes]
    - Can I install SSH now that now that I have 0 Apps on my screen?
    - and if so what are the most common IP Addresses for Iphones?
    - Can I use Independence to RESTORE a Phone that was ORIGINALLY 1.1.1, but is now unlocked/hacked?
    - Finally, am I totally screwed?

    I'm sure many of you are sensitive to the possibility of having a 400dollar paperweight because of a really stupid mistake. Feeling some anxiety at the moment and im stuck at work... Thank you in advance and 10 dollar PayPal donation to the first person to provide the fix for this
    Last edited by alo717; 2007-10-30 at 06:08 PM.

  2. #2
    jyst restore and start from scratch it will probably be easieer for you that way being that theres no way to navigat in summerboard

  3. #3
    Yes- but can I restore in my present state? (remember brand new it was 1.1.1 and now that its hacked and re-upgraded to 1.1.1)

    And how do I do this with Independence?

    Thanks

  4. #4
    alo717,
    you cant restore your iphone because you've unlocked it , so whatever you DONT restore or you will have some more problems. Here is what I can offer you as a solution:
    1. Use your mac
    2. Hook up your iphone and launch Independence then install SSH ( you should still be able to do it)
    3. Then log into your router (ex. 192.168.1.1) and look at connected wireless IP's , one of them should be your iphone depending on your network. Write all the IPs down.
    4. Log into terminal and type: ssh -l root IPADRESSHERE
    5. You should connect , use the password alpine.
    ... if for some reason you get a long list of errors then just come back and post the error....
    6. type: "cd .." no quotations and make sure there is a space between the dots and cd
    7. type: "cd .." no quotations and make sure there is a space between the dots and cd
    8. type: "ls"
    9. You should see the entire root like Applications, Var , System and so on
    10. type: "cd /Applications"
    11. type: "cd /Customize
    12. type: "./Customize"
    13. Then Customize should be up and running , go ahead and edit rSBT
    14. when you are done hit "ctrl+up" in terminal to get to the home screen .
    15. Reboot and viola
    P.S. THis is assuming that you are using Customize to edit the plist.
    Any Questions just POST

  5. The Following User Says Thank You to DVCATSCAN For This Useful Post:

    alo717 (2007-10-30)

  6. #5
    Will independence allow installation of dock or the the pxl plugin? If so, install dock (or install pxl support and install dock from http://iphone.exploit.org/pxl/), use dock to open customize and fix the rSBT problem.

  7. The Following User Says Thank You to Spamdumpster For This Useful Post:

    alo717 (2007-10-30)

  8. #6
    thank you DVCATSCA, youve made my day!

    to be honest ive been very distracted at work because I was worried my iphone was toast; this sounds like it should work. Will try the moment I get home.

    Thanks again !

  9. #7
    Glad i could help, tell me how it goes.

  10. The Following User Says Thank You to DVCATSCAN For This Useful Post:

    alo717 (2007-11-01)

  11. #8
    Hello- sorry for the delayed response, but basically got my iphone back to original (well hacked and unlocked state). Thought Id suggest my workaround as yet another potential solution for those unlucky enough to have hidden all their applications with rSBT.

    I tried very very hard to Terminal into my phone (for about 2 hours) and I thought Id seen every permutation of outputs possible, but ultimately my terminal kept ending the session before i had a chance to type in my commands... Reinstalled/Uninstalled SSH with Independence a whole host of times. still did not work.

    So as a last attempt before bed (at 1am), I decided to use Cyberduck and see if I could actually tunnel into it. I was amazed at how quickly and cleanly this worked in giving me access to the iPhones folder structures. I quickly searched around for a Mpa64.pls (or something) file on the internet and replaced the original one with this new (virgin) version. Restarted.... Prayed... and Voila ! MOST of my apps were back. After it was all done, i soon realized how strange this was since... i thought my SSH was not working... but clearly without SSH i woudlnt have been able to Cyberduck into my iphone. werd...

    But then I still noticed I could not access Installer and Customize. So I used independence to delete it (even though I could not see it on my Iphone) and then as Cybergreg PMed with... I downloaded the AppTapp installer, did the (CTRL + Right Click), pulled out the Installer.App. And once again -Cyberducked into my Iphone, dropped Installer.App into the Applicatins list. Ran it, and started installed Customize... as well as a whole host of other useless but fun apps.

    Long story short- I am very happy and please do not take my instructions above word for word, as Im sure my terminologies are all incorrect and there are any number of ways to accomplish what I just did.

    In any event- thanks again to everyone who provided info !
    Last edited by alo717; 2007-11-01 at 04:33 AM.

  12. The Following User Says Thank You to alo717 For This Useful Post:

    msipf (2007-11-05)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •