Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Did customize delete your homescreen icons and say "iPod"?

  1. #1
    Default Did customize delete your homescreen icons and say "iPod"?
    I had this problem and I wanted to help anyone else who might also have it: I was fiddling around in Customize v1.13 and when trying to save some settings the application reverted back to the homescreen and deleted all homescreen icon, leaving a small, blank dock and the word "iPod" replacing the service icon in the left of the status bar. I tried to rearrange the icons through customize's rSBT by using the Dock application to open it but the icon list was really messed up (pressing and icon selected a totally different icon in the list) and when I tried to save it the application reverted back to the blank homescreen. Uninstalling customize didn't work either. I fixed it by replacing my M68AP.plist file, which keeps the homescreen icon order, with a default version of it. I found this solution in a similar thread:

    Quote Originally Posted by mjdaul View Post
    what version of the firmware do you have...

    try this:
    1. stfp into your phone, use cyberduck, fugu, whatever you want
    2. navigate to /System/Library/CoreServices/SpringBoard.app/
    3. 1.0.2 firmware: replace DisplayOrder.plist with the one ive attached (not actually attached, find it yourself)
    1.1.1 firmware: replace M68AP.plist with the one ive attached
    4. restart youre phone
    This will bring back your icons and your theme, unless you deleted something, and somehow fixes rSBT in Customize so u can rearrange your icons. Any "icon.png" files you may have modified in the application directories will be deleted tho. Here's the M68AP.plist that I used:
    Attached Files Attached Files

  2. The Following 7 Users Say Thank You to elr0y7 For This Useful Post:

    alex8228 (2007-11-05), catalinaversace (2007-10-20), edhodges (2007-11-07), pastyclay (2007-10-24), PhoneLine (2007-10-21), ShadyBeagle (2007-10-27), torrentprime (2007-10-31)

  3. #2
    Green Apple mjdaul's Avatar
    Join Date
    Aug 2007
    Location
    Milwaukee, WI
    Posts
    91
    Thanks
    3
    Thanked 26 Times in 15 Posts

    i just wanted to say thanks for actually quoting me, but i didnt say "(not actaully attached, find it yourself)" lol

    the DisplayOrder.plist can be found in the original post here.
    Last edited by mjdaul; 2007-10-18 at 02:09 AM.

  4. The Following User Says Thank You to mjdaul For This Useful Post:

    PhoneLine (2007-10-21)

  5. #3
    I had a similar experience, actually twice: customize deleted my springboard when I restored from backup, and when I selected a springboard of "zero applications." (I thought everything would go to the extended springboard.

    So I was in the same boat, ipod for carrier, no apps on screen, no way to get back into springbaord.

    Luckily, I had installed the pxl support plugiin for safari. I installed the dock app hrough phone.exploit.org. Then I used the dock app to rerun customize, fix my problerm, and I'm back in business.

  6. #4
    Quote Originally Posted by mjdaul View Post
    i just wanted to say thanks for actually quoting me, but i didnt say "(not actaully attached, find it yourself)" lol

    the DisplayOrder.plist can be found in the original post here.
    NP, I just did it again. I didn't add tht displayorder file because I'm pretty sure that customize only glitches like that on a 1.1.1 iphone. Thanks again for the file btw.
    "Spaceships don't come equipped with rear view mirrors..." -Andre Benjamin the 3000th

  7. The Following User Says Thank You to elr0y7 For This Useful Post:

    PhoneLine (2007-10-21)

  8. #5
    OK. It's 2.20am and I had semi-bricked my phone (as above, no icons, iPod symbol) at 8.30pm. It's taken that whole six hours to find this simple solution.

    THANK YOU!

    I was really starting to think I'd have to reinstall 1.1.1.

    Anyway, it's very important to note the change from DisplayOrder.plist (in firmware 1.02 and below) to m68ap.plist (in 1.1.1) which I haven't seen explained anywhere else at all. I tried adding displayorder a number of times.

    Everything is working great now. Cheers!

    OK. It's 2.20am and I had semi-bricked my phone (as above, no icons, iPod symbol) at 8.30pm. It's taken that whole six hours to find this simple solution.

    THANK YOU!

    I was really starting to think I'd have to reinstall 1.1.1.

    Anyway, it's very important to note the change from DisplayOrder.plist (in firmware 1.02 and below) to m68ap.plist (in 1.1.1) which I haven't seen explained anywhere else at all. I tried adding displayorder a number of times.

    Everything is working great now. Cheers!
    Last edited by catalinaversace; 2007-10-20 at 11:33 PM. Reason: Automerged Doublepost

  9. #6
    My iPhone is a Part of Me PhoneLine's Avatar
    Join Date
    Aug 2007
    Location
    New York City
    Posts
    508
    Thanks
    65
    Thanked 155 Times in 54 Posts

    What a scare!

    I was messing around with rSBT via customize 1.13 and just had this happen tonight. I also though, great, time to do the whole restore and jailbreak again.

    Thats so much for posting this! It worked like a charm.

    I don't think I'll be using rSBT till maybe the next version of customize.......I think it has a couple of kinks!

  10. #7
    This same exact thing happened to me, Only thing is that i went ahead and restored my phone. Restore looked like it went fine until my phone tried to activate thru itunes. Itunes lists the iphone but then it stops and says that The Itunes store is busy please check your internet connection. Help!

  11. #8
    Thanks a million! I too was brutally victimized by Customize but am back in business now. Keeping default M68AP.plist file in my lifesaver folder.

  12. #9
    My iPhone is a Part of Me PhoneLine's Avatar
    Join Date
    Aug 2007
    Location
    New York City
    Posts
    508
    Thanks
    65
    Thanked 155 Times in 54 Posts

    One thing I suggest is if your going to mess around with the rSBT in the current version of customize is make sure your SSH is turned on if you have the services app to turn it off. So if it goofs you can get in and replace the needed file.

    Mine was actually off, but thankfully I had the dock application installed and even though I had no icons I was able to launch services via the dock to turn ssh on and then restore the plist. Cause aint no other way with no icons.

  13. #10
    omg why couldnt i have found this earlier? i had this problem...and i restored it, and now everything is fine, but now i cant restore back to 1.0.2 to try the jailbreak over again...

  14. #11

  15. #12
    Just to add my voice to the chorus of thanks for finding this fix. I was pretty worried there for a bit...All good now!

  16. #13
    Thanks for this topic

    This saved me ALLOT.

  17. #14
    Thanks, I just had this problem, this fixed it right up, and it kept the icons i had changed! Wonder why customize does this, its a wierd glitch .

  18. #15
    Thank you !!!! i would like to add you to my best friends for this help

  19. #16
    wow, I thought it was just me... Wish I had found this sooner... I restored and went through the "long" method of jailbreaking3 times since I am a slow learner :-) and kept messing with customize again and again... Just out of curiosity how many who have had this problem have been using the dock app that comes out from the corner as well? Could it be some kind of conflict?

    I was using both. Sounds like some others were too...
    Last edited by edgewise; 2007-11-06 at 05:52 PM.

  20. #17
    Wow that was scary! Thanks very much for posting a default plist for repair purposes, lifesaver!

  21. #18
    Thank you it works fine...

  22. #19
    my screen blanks out on me when I uninstall apps

  23. #20
    Just wanted to say thx - saved me a lot of truble. Was worried there for a bit but this works like a charm..

    Pie

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •