Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: MyWi Wifi Tethering Stopped Working

  1. #1
    Default MyWi Wifi Tethering Stopped Working
    Friday the app was working great. I heard the chime indicating it was disconnecting and since that time is will not connect.

    1. It no longer makes the chime when you turn on WiFi tethering
    2. The blue bar indicating it's connected is not showing up
    3. There is a black bar at the bottom that says it is on
    4. I have reinstalled MyWi and rebooted my iPhone

    Any other suggestions as to what might be going on with this app?

  2. #2
    Retired Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Hammond Louisiana
    Thanked 7,065 Times in 4,206 Posts

    Have ya tried re installing it?

  3. #3
    Yeah, that was number 4 on the list above.

    I just removed the app, reinstalled it and rebooted the iphone. This also did not work.


    I don't remember seeing the black bar at the bottom in the past. But you can see there is no blue "connected" bar at the top despite Wifi tethering being on.
    Last edited by markrowan; 2013-04-29 at 04:01 PM.

  4. #4
    I am suffering the exact same problem. Was there ever a fix for this?
    My situation is word for word exactly the same as the original post.

    Before the failure, it was working solid for 12 hours and was easily the best tethering app i have ever used. Rock solid, never dropped out, great speeds.
    The fact that this happened "Mid" tether i find strange. As the OP says, i heard the "bing" and it disconnected, never to connect again.

    However, i traced it a bit further, and find the problem to be my iPhone is no longer leasing DHCP address's anymore.
    Hence the WiFi connection was lost and it will never regain.

    This problem is now common across all of my iPhone's attempts to tether via WiFi.
    TetherMe which previously worked, now no longer does.
    MyWi which previously worked, now no longer does.

    I can ONLY tether via USB now.

    When activating MyWi 6.0.14, it will initialise, and the connect to my client devices, but NO address is given out.
    The SSID is visible, and the laptop will connect, but with no address, hence i get the "!" in my WiFi icon.

    I have an iPhone4 with iOS 6.1.3 with a tethered JB (redsn0w)
    I did previously have PdaNet installed which did not work for me.
    It was uninstalled in the MyWi 6.0.14 installing process.

    I have uninstalled MyWi and reinstalled it many times, with no difference.
    I have not Restored my iPhone yet, but am leaving that until my last option.

    It also seems to start my iPhones WiFi now, which in turn drops out my 3G connection.
    It never did that when it worked.
    And it would even let you connect the iPhone to a LAN WiFi at the same time it was tethering to it, which i thought was amazing.

    Hope there is a common fix for this

    Thank You
    Last edited by Dani69; 2013-07-21 at 04:18 AM.

  5. #5
    Double Post
    Last edited by Dani69; 2013-07-21 at 04:18 AM.

  6. #6
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Thanked 70 Times in 67 Posts

    Hi, maybe Dani69 and markrowan could compare tweaks to see if you have any in common. Might TetherMe (which does turn off wifi) conflict with MyWi? Mark Rowan said it started on 26th April. Check to see what new or updated tweaks came out about that time which you may have at
    For example, the first release of Message Box
    Last edited by DC_Dave; 2013-07-20 at 06:09 PM.

  7. #7
    I removed all Cydia Mobile Substrates and then Installed MyWi 6.0.14 only
    Exactly the same problem still exists sadly.

    EDIT: Managed to get it working again Rebooting the iPhone after all Substrates were removed.
    It did not take action from just a respring

    I'll see how long it lasts though, until its worked consistently for a week, i'm saying nothing
    Last edited by Dani69; 2013-07-21 at 04:19 AM.

  8. #8
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Thanked 70 Times in 67 Posts

    Hi, I had a similar problem with Bluetooth tethering from my iPad to my iPhone getting disconnected after 10 seconds. That turned out to be another Bluetooth tweak Blutrol/Bluetooth Companion.
    With that in mind, maybe your iTransmission3, 3G unrestrictor, TetherMe and MyWi won't play well together?

  9. #9
    Yes maybe, although i have had all of those uninstalled and there is still a strange problem.
    Another fault occurs, which it did once before too.

    While tethering with MyWi, and you go to use another App on the phone (in my case both times it was Viber, but very random, you could Viber 100 times, then on 101, it locked)
    It locked my phone, then came back in "safe mode"
    Ironically the tether still worked perfectly while in "safemode".... BUT
    The second you go the "Respring out of SafeMode" you are doomed.... It goes back to not handing out DHCP address's
    Back to Square one!

    The only solution...

    Once again, delete all substrates from Cydia (which were only MyWi and its associates)
    Download MyWi again
    And hope for the best

    It gave me so much trouble, i am trialing another tethering solution, which doesn't work as well as MyWi, but it does work

    I never managed to get MyWi to work more that 12 hours without crashing or causing a failure.
    But will agree it is a brilliant app, when it works
    Last edited by Dani69; 2013-07-21 at 03:00 PM.

  10. #10
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Thanked 70 Times in 67 Posts

    Hi, yes MyWi was the reason I first jailbroke back on iOS4.1, cost $20. I decided not to pay the extra $5 for the iOS6 version as I read reports of people having problems with it and the fact that your carrier can detect if you are tethering your 3G connection with it. Instead I purchased TetherMe which sends all data as if its for the iPhone.

  11. #11
    I used TetherMe for ages, but it doesn't allow a lot of things to happen.

    1) It does not hand out proper DHCP server address's that can be used by other devices other than a Laptop or Tablet
    (i connect to an Access Point which then supplies my whole house, Infrastructure Mode, TetherMe will not allow such a connection)

    2) The Tether can stop or fail if a text or phone call is made/received (MyWi allowed all of this, no problem)

    3) Tether Me does not allow simultaneous Hotspot Broadcast and WiFi connection, which MyWi does
    (Eg: I Tether my phone to my home network, then connect to my home network with the same phone, with MyWi, this works perfectly)

    And as far as "Hiding" your Tether, from what i understand, there is no such thing.... All some of these Apps do is "Allow" you to tether and don't Allow the carrier to stop it with basic instructions sent to the handset.
    All they need to do is look at the log files of your data usage to see its used Chrome from a Mac, or Chrome from a Windows machine etc.... You just cant hide the strings that are sent out.

    Same with Android, they know its happening, but what can they do?
    Here in Australia, i can use my "Non Tether-able Deal" in an Android phone and download 50Gb a month... and have been for 12 months or more.
    Never been questioned, called, emailed.... nothing.
    I have been trying the same SIM in my iPhone.... but as we know, they can have more control over an iPhone....

    So as yet, i have not found a stable, consistant workable solution with the iPhone for Tethering.

    MyWi 6 worked the best, but crashes the iphone into safemode, then you have to reinstall.
    PdaNet works, but will not handle a phone call at the same time (drops the 3G), it will also fail after some time of active tethering
    TetherMe works, but often drops out, needing to be restarted and your phone put into Airplane mode and back out to reset the 3G connection to the cell tower so you have an active internet connection again.

    All in all, the Android totally flogs all of the above.... BUT... I really would like to find a solution for the iPhone.

    MyWi seems so good, so well thought out... It just needs a couple of bugs sorted out and it would be perfect, i'd happily pay the $19.95 asking price!!!!

    The only thing i don't know, is if these crashes are caused perhaps from a command sent from the provider?
    I will have to try with a Carrier deal that allows tethering to check this out.

    What is more surprising to me... Is that this isn't a more popular subject on the net? or here....
    I'm sure i cant be the only person that is trying to do this?
    Or coming across the problems mentioned above?

    Perhaps not many people are trying to connect to a "Home" network using their phones 3G connection as the modem (or Gateway).
    There are a couple of WiFi Routers that allow you to connect (Tether) your iPhone via USB to the routers USB port.
    Hence having a solid wired connection, then broadcast it out the home WiFi and Wired LAN (also charges your iphone)

    But i like the complete wireless option, it allows you to have the phone in your hand, make calls, send and receive texts, move it around.
    Last edited by Dani69; 2013-07-22 at 02:51 AM.

  12. #12
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Thanked 70 Times in 67 Posts

    Hi, TetherMe says all data will appear to come from your iPhone's own data APN. But if you are saying there is also a log file they can read, then using a free VPN app like Onavo Protect might help. I wonder if your MyWi stays connected with Onavo Protect installed? If so, I might buy the $5 iOS6 upgrade.
    Last edited by DC_Dave; 2013-07-22 at 10:48 AM.

  13. #13
    All Data no matter where it is used, on the handset itself, or tethered.... comes and goes through the same APN
    It is what is attached with that data that gives away if it is used on the phone or a laptop.

    The systems put in place by carriers that do not allow tethering on the iPhone are simple measures, they generally send an OTA command to disable the "Hotspot" option in "Settings" menu.
    I believe they also try other techniques... but i am only guessing.

    The fact is, Carries can not stop tethering on an Android device (well, not in Oz anyway).

    There are torrents clients for iphone, android, macs and PC's.... so people have the choice to download a torrent for example on the handset itself. No tethering needed..... They might catch you out doing this by looking closer at your data usage.
    A VPN will not stop this either....

    So the TetherMe statement is correct, there App will make your data look like its coming from the phones APN... because ALL data is coming from the phones APN Without an APN, you dont have a data connection.

    Many of people have tried to use a VPN on PC's to hide activity like torrents.... Im not sure if it makes a difference.

    I will try what you have suggested "Onavo Project"

    The sad thing about all of this, is on an Android phone, tethering is as simple as flicking a switch, and its done, i've had an Android phone tethered 24/7 for over a week....
    So it must be simple

    Why is it so hard on an iPhone???
    Last edited by Dani69; 2013-07-22 at 02:55 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts