Results 1 to 17 of 17

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: USB tethering wont work

  1. #1
    Default USB tethering wont work
    Im trying out MyWi and i got the usb tethering to work last night, but today when i plug it in nothing happens. I dont get internet connection and my pc wont even recognize the phone. I checked device manager and there are no drivers installed for iPhone or IVT_Virtual_0000. does anyone know where i can get the drivers or get this fixed?

  2. #2
    Try it with Itunes open. I have a similar problem where all of a sudden, tethering will not work unless Itunes is open.

  3. #3

    My USB tethering is not working. The blue bar shows up on the status bar when I turn it on and says that it is tethering, but there is no up/down bite transfer. The numbers just get stuck and nothing happens.

    Initially I tried reinstalling and uninstalling altogether before reinstalling. That didn't work. I decided to uninstall rock because I figured now that it merged with cydia maybe the old program was causing a problem (that's where I had downloaded the trial version from). That actually worked for about a day. Then the next morning I plugged the phone in and turned the tethering on and it's stuck again. I already tried deleting and reinstalling, but that's not working.

    Forgot to add, have tried it with iTunes open too. No difference. Any suggestions?
    Last edited by Dodgyvibe; 2010-09-21 at 12:08 AM. Reason: Automerged Doublepost

  4. #4
    Does it show up under network connections when you connect it? If not, have you tried a different USB port? Also, I have had issues where it does show up as a network connection, but is disabled for some reason(and will not reenable without rebooting). I have also seen cases where the transfer numbers are stuck on 0, when it is actually working just fine.

    p.s. Rock is still a seperate app that can now be installed from within Cydia(just use the search feature). I wouldn't bother with Rock unless you need MyWi version 3 or another app that you can only download through Rock(and I think that is even temporary until Rock gets all it's licenses transferred over to Cydia).

  5. #5
    if it is in network connections i'm not seeing it anywhere. i did another delete and reinstall and it actually started working again. but again, after 24 hours, it stopped. sometimes it says 0 bites and doesn't move. other times the numbers climb for a few seconds and then stop. either way it doesn't work. it's almost like there's some 24 hour limit. i know mywi previously had problems with only being able to use the usb tethering once, but the 4.4 update supposedly fixed that.

    i tried deleting and reinstalling a few times today but it hasn't come back this time. the same problems are there -- tethering status bar shows up, numbers climb for a few seconds (or stay at zero) and then don't move. no connection either way.

    tried other usb ports and that made no difference either.

    anyway, it's super annoying to waste a day removing and installing over and over again hoping it might work. for $20 it should just work.

  6. #6
    Have you tried rebooting your phone inbetween un/reinstalls? I understand your frustration-it certainly "kinda" works, and has a lot of remaining kinks. I tried v4 for a couple hours on the trial and just went back to the paid version of 3.52 because it seems to be less buggy.

  7. #7
    yeah. i really tried everything. and i don't know what it was exactly that made it work again during a particular reinstall. nevertheless it still kicked out after a day. i sent several emails to intelliborn support and bugs department but who knows when anyone will read that. i'll just stick with the wifi tethering for now and hope they can patch it up.

  8. #8
    I was using the previous version of mywi with no issues until the trial ran out. Purchased this version and have been unable to get it to work until tonight. I had the same problems as the original poster. I unistalled Rock, unistalled mywi, restarted phone, and redownloaded mywi. It's working for now. I'll update whether it continues to work over the next few days.

    9.25 MyWi still working... posting right from MyWi because it's faster than the hotel's wifi ;P
    Last edited by darkstahr; 2010-09-25 at 09:52 PM.

  9. #9
    I used MyWi through the trial period and decided last week to go ahead and purchase. Worked fine both via WiFi and USB on my laptop but my Netbook would only connect via WiFi. This morning my laptop would not connect via USB all of the sudden. Rebooted the laptop with no change then rebooted the phone. When I plugged in again it installed an ethernet driver, don't recall but either Apple or iPhone specific. Had to reboot the laptop after the install but works fine now

  10. #10
    I tried doing the same (uninstall rock, uninstall MyWi, restart phone, re-download MyWi)...but my laptop still won't connect. I have a WinXP laptop using USB tethering. It has worked fine for over a month since I bought stopped working when I tried to do the Rock-to-Cydia license transfer or something. I have to use USB tethering because of a group policy preventing my laptop from connecting via wifi to an ad-hoc network.

  11. #11
    Well, anyone know how to revert back to the previous version before 4.8.3? Since upgrading to 4.8.3 I no longer can USB tether no matter what I try to do. I've tried everything you guys listed above and every computer I try it on never gives me an ip (limited connectivity error). It always worked fine with the previous version and now I have no idea how to find or reinstall it.

  12. #12
    My USB tethering isn't working either. I noticed it broke immediately after the last software update. I don't think there's much to do until it's fixed or reverted back to an older version. I could tell right away that it was broken because it behaved differently when connected via USB to the computer. Typically, when in USB tether mode, the computer doesn't act like it's trying to install a driver or pop-up with the device trying to browse files, this time it did. It does still appear under "network connections" but it never establishes a connection. ...everything still works fine in Wi-Fi tethering mode though.

    I didn't like the changelog for the latest version either. It mentioned a fix for when Wi-Fi is disabled but that has always worked. In fact, I frequently intentionally disable Wi-Fi before launching MyWi via USB mode to keep it off that network.

    MyWi 4.8.3
    Device + Firmware: iPhone 3Gs, iOS 4.0.1
    Computer OS: Win7 Home(64-bit)
    Last edited by bosnoval; 2010-10-23 at 06:29 PM.

  13. #13
    I reinstalled version 4.8.1 using diskaid. Mine works fine as usual again now. 4.8.3 definitely has some issues. This is the first time i've ever had issues with the program since it came out.

  14. #14
    I was having issues getting my iphone to USB tether with my ubuntu boxes. 10.10 is still a problem, but after downgrading mywi to 4.7.7, 10.4 is working like a champ. I haven't upgraded the kernel on it yet...and quite frankly i don't want to everything is running perfectly.

  15. #15
    Where can we download version 4.8.1 again?

  16. #16
    google it. how i found it. got it off a site or something. should be a .deb file

    UPDATE: here is the's the first post and the second file in the post.
    Last edited by gsuaaron; 2010-10-25 at 08:58 PM. Reason: update

  17. #17
    The latest release fixed it!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts