Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Connected by WiFi but no internet

  1. #1
    Default Connected by WiFi but no internet
    I set up MyWi on my 3GS 3.1.3 and connected with my laptop (running Win 7 32bit) alright, but when I try to connect via Wifi hotspot there's not internet connectivity (yellow triangle in the network symbol).
    Any idea what I could try?

  2. #2
    I've been having the same issue sporadically. MyWi sometimes will not service DHCP requests. It appears that the DHCP functionality is coming from the native iPhone tethering daemon. I have had some luck with toggling tethering on and off in the settings panel jogging the app into working.

    FYI - some of my issues may be coming from running 3.1.3 on my 3G

  3. #3
    I just jailbreak my iphone 3G on OS 3.1.3 last night and installed Mywi (the only reason for the JB)... trying to get my iPad to tether via wifi and found that it only worked if I soft reset first, otherwise I can connect the iPad but no internet. Also the blue tether bar seems to appear and disappear quite randomly... anyone has idea how to make it more stable?

  4. #4
    I managed to get internet after switching the phone on and off again...
    Temporarily, I had lost internet connectivity on the iPhone altogether until I did that!

  5. #5
    I am having the same issue, I am on 3.1.2 still, I get the ad-hoc wi-fi, but I am not getting an IP from DHCP on any connected device, any suggestions.

    Another issue is USB/BT sets itself to on after I turn on WiFi tethering, regerdles of the previous setting.

    I'm still on trial, but it hardly convinces me to pay for the full version...

  6. #6
    Quote Originally Posted by err404 View Post
    FYI - some of my issues may be coming from running 3.1.3 on my 3G
    I'm pretty sure that's the case. Everything I've read has said to not upgrade to 3.1.3.

  7. #7
    I just got MyWi working after hours of fiddling with it.

    Firstly, it did crash repeatedly while I was trying to register with Rock; I eventually managed to fill out the registration page very quickly and, while it did crash again, it had apparently made it far enough to register me. Since then, no crashes that I can think of.

    The problem I had after that was that devices (my iPad and MacBook Pro) weren't being assigned an IP address after connecting to the network, and the phone didn't appear to have given itself an address either. I tried rebooting, restarting, reconfiguring, reconnecting and desperate things like manually assigning IP addresses, but I never got internet access. I am pretty sure I also tried turning off WEP with no luck, which is funny because…

    Eventually I tried turning off WEP and it suddenly worked. The only thing that might further distinguish this attempt from others is that before turning on MyWi I had been using normal USB tethering with my MacBook Pro. I turned tethering off, turned on MyWi without WEP, and found that the iPad was now able to get an address when joining the MyWi network. Since then I've toggled WEP on and back off and sure enough the DHCP problem returns when WEP is on, but it's smooth sailing with WEP off.

    Hope that helps/encourages someone. This was on an iPhone 3GS running OS 3.1.3 and never jailbroken before a few days ago when I used the Spirit jailbreak. Obviously I wish I could use some kind of security (WEP, MAC filter, hidden SSID) but for the moment none will have to do.
    Last edited by ilikeimac; 2010-05-08 at 08:31 PM.

  8. #8
    I found that WEP works, however there is a bug in MyWi. If you exit and go back into MyWi you will notice a bunch of zeros added to the end of the wep key. If you replicate that key onto your remote device with the zeros it will work everytime.

  9. #9
    Same here. I paid for MYWI and I just can't get it to work. I'm on a 3G phone that I upgraded to 3.1.3 then discovered the world of Jailbreak. Did that and installed MYWI and then bought an iPad. Well it sees it...but does not connect fully. So no surfing....Im not using wep...any advice...Lately it assigns everything but the Router....ugh......

  10. #10
    Default Bricked!
    Quick update: my phone froze up and wouldn't reboot past the Apple logo today, so I had to restore it. MyWi was off, but that and OpenSSH are the only jailbreak packages I've installed since jailbreaking a few days ago.

  11. #11
    I am confused to say the least. I thought that mywi lets you use someone elses (secured wifi) and tether off it. (This is ofcourse off of a network I do not have the password to). So I JBroked my 3.1.3/05.12.01/3GS/16GB. And I installed mywi. And after doing so I tried to use mywi, and after doing so, it showed that I had all three wifi bars, except I can NEVER connect from my mywi connection! What am I doing wrong? I've already turned off/on my 3GS. I have gone into my settings, and turned on bluetooth, and went into mywi, and turned that on, then I went back into settings and selected my mywi connection, and nothing! Pages, won't load on my Safari. What do I do? Do I have the wrong program for what I'm trying to do? Is there an app out there for what I'm looking for? Where is it?

    Also I am not using (no rocks) version. I don't know what you call my version of mywi, but I got it from a sinful/repo type site. Does that matter?
    Last edited by replytodan; 2010-05-10 at 10:50 PM. Reason: Automerged Doublepost

  12. #12
    ^Yes, it does matter where you got it from. Basically by not obtaining it from an official source, there is no way to ensure you have the latest and greatest version and that the package is not damaged. The first piece of advice that you'll get is to remove it and install via Cydia or Rock. However; you may not need to go that far since I don't believe that the app is what you are actually looking for .
    MyWi is not a tool for hacking WiFi connections. It is meant to share your phones 3G data connection with other devices. When MyWi is running on your phone, you can connect your Laptop (or other device) to you phone so you can access the internet from you laptop.

  13. #13
    So is wefi or aircrack what I'm looking for? Do you know if those are the best for what I'm looking for? I mean does wefi mean that I can get internet whereever I go? Or that it's my best option for the closest thing to a nationwide free internet? Also is there anyone else like wefi? How do I know wefi is in my location of washington? Who are Wefis competitors? I just wanted to know before I get it from cydia. And where do I get this whole aircrak thing I've been reading about? Is there any other program like aircrak that I can use that is better? Or is as good but easier to use? Is it guarenteed or almost guarentee to work?

    Also does anyone know about: WiFi Unlocker - Get the KEY to Unlock WiFi Today ???

    IS there anyone else like them? Are they trustworthy?

    And just for the record this is all just for educational (legitamite, non-illegal) purposes only.

  14. #14
    Wink This made me sooo mad!
    this worked for me atleast:
    1. chekk if the internet connection still dosnt work by opening safari or any other internet application.
    2. try to renew your internet by going to: Settings-general-internet-klick the blue arrow beside the name of your internet-renew lease.
    3. repeat step 1.
    4.turn off your internet and wait for 10 sec then turn on again.
    repeat step 1 and i should work.

    tell me if this helped!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •