Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Free T-Mobile Internet not working any more

  1. #1
    Question Free T-Mobile Internet not working any more
    I have had free T-Mobile internet (T-Zones) for over 4 years now. I have been using this free internet on an iPhone for about a year and a half , which of course I can't complain about.

    This was great up until two or three days ago, when all of a sudden my T-Zones internet stopped working. Now when I try to use Edge to connect to the internet, I am redirected to m.web2go.com/upsell/... to accept a $1.99/MB plan on my contract. Is T-Mobile cracking down on free users or something? I would really hate to lose my free internet, and I have been unable to find anyone else with this issue on google.

    I have an Apple iPhone 3G, with 3.1.2 installed, jailbroken and unlocked. Currently using T-Mobile, with a 500 Min/Mth and Unltd Text plan. I tried changing the APN to all the different domains out there, but none of them work. I have also tried to reset the network settings, and this hasn't worked either. Does anyone have any ideas?

  2. #2
    iPhone? More like MyPhone Thenextkiller's Avatar
    Join Date
    Jun 2010
    Location
    USA
    Posts
    203
    Thanks
    5
    Thanked 45 Times in 39 Posts

    I doubt there is such thing as "free" internet.
    Am firin ma lasah

  3. #3
    Quote Originally Posted by Thenextkiller View Post
    I doubt there is such thing as "free" internet.
    Actually there is. It seems to be a glitch in the T-Mobile Data system that I discovered a few years ago. Back then I activated a $4.99 T-Zones plan and then canceled it the next day and was only charged for a prorated amount (like $0.15). After I canceled the T-Zones plan, the internet was still working on my line. This was over 4 years ago, and I have had free internet on all my phones since then, up until two or three days ago. I'm trying to figure out if this is something that T-Mobile did, or if it's something that happened on my end.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •