Struggling with this problem for a while now. Hope someone can help me out..

I have unlocked/Activated the phone all fine. The thing is, when the phone is placed in the dock the signal is very strong. But as soon as a grab it and undock it, it loses carrier signal and a while later "NO SERVICE" is displayed and all calls are failed. If I lay it on the table for a while the carrier signal returns, but not as strong as in docked mode. Soon as I grab it in my hand it loses signal again. I usually have strong signal at my location on other phones, so it should'nt be a blind spot.

I have tried restoring, and redoing the whole process like 10times now. Tried restoring to a "virgin" state, http://limitededitioniphone.com/how-...-virgin-state/
Tried different unlocking methods, both pc and mac.

I did upgrade my firmware to 1.0.2 before unlocking it, some guides warn about not doing this. All other things are working just fine, except I canīt use it as a phone....

Quite far to go for returning the phone if you live in Sweden

Anyone who can a assist me on this one? Please....

Regards Christian.