Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: SSH with iPhone

  1. #1
    Default SSH with iPhone
    So, I've been trying to set up SSH for days with my iPhone to send those three "magic files" to my iPhone to get youtube to work and I am just so clueless about doing so. Can someone please help me?

    Oh, and I'm using a mac and I activated my iPhone through iActivator.

  2. #2
    Easy instructions:
    1) Download AppTapp Installer from here.
    2) Install AppTapp Installer.
    3) Open Installer app on your iPhone.
    4) Install Community Sources.
    5) Install BSD Subsystem.
    6) Install OpenSSH.
    7) No go to Settings>Wi-Fi
    8) Click the blue arrow next to the network you are connected to.
    9) Write down your IP address.
    10) Download or open an FTP client (For a list of some FTP Clients see the bottom of this post).
    11) Create a new connection with the protocol SFTP (SSH Secure File Transfer Protocol).
    12) Enter the IP address you wrote down as the host.
    13) The port number is 22.
    14) The username is "root" without the quotes.
    15) The password is "dottie" without the quotes.
    16) Click connect, and usually on the first try, you will be successful.
    17) Voila! You're done, but running/having OpenSSH on your iPhone drains battery, so be aware.

    Some examples of FTP Clients:

    FireFTP (Mozilla Firefox plugin)


    Hope this post helps!

  3. #3
    Has anyone been able to get youtube to work? I've been searching for the past hour trying to get it to work without any luck.

  4. #4
    I have OpenSSH and I already went through the ssh set up and I just cannot get it to work. I reset my password from dottie and then when I went in to use it in Fugu or Cyberduck it just absolutely would not work. The IP address would not respond. Being the n00b that I am, I tried the DNS server because I thought that would work; it logged on, but none of my passwords work. I was thinking that I should just start fresh with an iTunes restore. Oh, and I thought I should mention that I'm trying this on my school's crappy Internet. It doesn't even allow for outgoing mail to send through apple mail..... I don't know that that has anything to do with it, but I thought that might help. Anyway, do you think that a restore and starting fresh is the answer? I have no idea. I am so frustrated by now.... I feel like I have tried EVERYTHING!!
    I am madly in love with my iPhone.

  5. #5
    I forgot to mention that until you successfully connect via SSH to the iPhone for the first time, the SSH Service is still generating connection salts. I had to reboot my computer and my iPhone after installing OpenSSH and before trying to set up a connection. That could be one reason, or that you school's network has port 22 blocked or something.

  6. #6
    Your school probably has access point isolation enabled. Try using your own wireless network or a friend's.

  7. #7
    Green Apple mjdaul's Avatar
    Join Date
    Aug 2007
    Milwaukee, WI
    Thanked 26 Times in 15 Posts

    make sure that you have the file 'sftp-server' in the /usr/libexec folder

    use terminal and run:
    cd /usr/libexec

    if the file is in the list try doing:
    chmod +x sftp-server

    if its not there, you need to put it there

  8. #8
    im not sure if this is the correct place to post my issue,so here it goes.
    im trying to set a pass word on winscp but i keep getting an error that sais, file cprogram files\putty\putty.exe'not foun,what im i doing wrong?please advice,also i noticed that there is an update out there,but its beta,should i update?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts