Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: open ssh problems 1.1.3

  1. #1
    Default open ssh problems 1.1.3
    hi to all
    I keep getting a connection refused message when I try to ssh into my phone using fugu.
    It's as though the open ssh is not functioning properly.
    when you go into ssh preferences where you can switch it off & on if you switch it off then press the home screen button then go back into ssh it shows it being switched on again even though you have just switched it off!!
    basically its behaving a bit strange really.
    Just cant ssh in, can anyone help with this?
    thanks in advance.

  2. #2
    I am also wondering how i can install SHH terminal on my iphone..thanks

  3. #3
    Default you try the 'delete known host' command?
    Quote Originally Posted by mrback View Post
    hi to all
    I keep getting a connection refused message when I try to ssh into my phone using fugu.

    thanks in advance.
    enter

    rm -f ~/.ssh/known_hosts

    into 'terminal' on yer Mac, return

  4. The Following 2 Users Say Thank You to Clem-Clone For This Useful Post:

    kurczak (2008-03-04), SeptemberC (2009-04-12)

  5. #4
    hi, thanks for that suggestion.
    that worked at first but when I try to turn off/on ssh in preferences on the iphone it refuses connection again.
    Do I have to type that into terminal every time I want to ssh in?
    when you turn ssh off in ssh preferences then go back to home screen then go back to ssh preferences its turned on again... grrr

    stopped working even after using the terminal command....

    stopped working even after using the terminal command....
    Last edited by mrback; 2008-02-13 at 11:09 PM. Reason: Automerged Doublepost

  6. #5
    Can anybody confirm if after you use ZiPhone on a 1.1.3 otb and install ssh can you login to the iphone? does username: root and password: alpine works?

  7. #6
    confirmed, I have done it, I usually run safari and it works fine...alpine, root and port 22

  8. #7
    Yes, work for me .
    root and Alpine in 1.1.3 OTB

  9. #8
    Tried the delete know hosts command and still getting connect refused when using sftp to the iphone.

  10. #9
    is anybody know an app like services that work with 1.1.3 and that allow me to turn off ssh !? I tried Service but it dont seems to work...

  11. #10
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    Ssh problem should be solvable by adding I.unlock.no as a source, refresh, go to folder called unlocking tools and install the one for ibrickr problem. I can't remember the name but that should allow you to ssh. I had the same problem wiu both cyberduck on mac and iphonebrowser on of andthis solved it

    For turning on and off ssh use either netservices app or bossprefs

  12. #11
    Tried the ibrickr fix mentioned above and still getting connection refused.

  13. #12
    same problem ^

    I used ziPhone to unlock my 1.1.3, now I cannot SSH into the phone. I tried deleting known hosts, installing the iBrickr patch mentioned, and am on the virge of restoring back to 1.1.2 where everything was solid.


    any other suggestions are appreciated

    thanks


    EDIT: installing the iBrickr patch mentioned and restarting the phone seemed to do the trick. I can now ssh into the phone
    Last edited by nimavafi; 2008-03-04 at 03:17 AM.

  14. #13
    Hi
    how can i check if i have ssh installed and how do i turn it on/off. ive been trying to connect using sftp method with no success. all i get is msg: permission denied.
    help anyone?
    kurczak

    .......OK. i used the terminal command and everything worked. thx clem - clone!
    Last edited by kurczak; 2008-03-04 at 04:17 PM.

  15. #14
    I had your same problem, I solved it installing BossPrefs

  16. #15
    What's Jailbreak? MasterXXXShake's Avatar
    Join Date
    Dec 2007
    Location
    Atlanta USA
    Posts
    20
    Thanks
    1
    Thanked 4 Times in 3 Posts

    I had the same problem earlier this week. I removed and reinstalled OpenSSH and then used BossPrefs to turn it off then back on agian before the first time I reconnected.

    I'm not sure which fixed it, but that's what I did to get mine working.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •