Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SSH WIKI Worked Perfect... Except

  1. #1
    Default SSH WIKI Worked Perfect... Except
    Okay, so I did a complete restore using iTunes, to ensure a fresh start. Then, I executed the step-by-step instructions in the WIKI's to get MacPorts, and iPHUC and all the other goodies installed, including SSH. No issues, I can do ringtones and icons and iPHUC all day long.. installed without a hitch, you might say exactly as the WIKI's said it would/should. Except…

    ..except that when I try to connect via SSH, the connection just times out. I checked/doubled-checked the IP I am pulling on the iPhone, it’s as it should be. I also confirmed no firewall issues exist for port 22. Still, the connection times out. Here’s a debug’d output of the last attempt:

    MacBook:~ myUserName$ ssh -vv [email protected]
    OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
    debug1: Reading configuration data /etc/ssh_config
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to 192.168.2.25 [192.168.2.25] port 22.
    debug1: connect to address 192.168.2.25 port 22: Operation timed out
    ssh: connect to host 192.168.2.25 port 22: Operation timed out

    Any thoughts on what the “hang up” might be? At this point, I am running a completely stock iPhone with your program executed/installed against it. Any feedback will be more than welcome, so thanks in advance!

    (I did a bit of searching first, on Google and multiple forums, so no justf**kinggoogleit.com links please.)
    - iPhoneWriter.com

  2. #2
    Former Owner / Founder of ModMyi Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,516
    Thanks
    577
    Thanked 4,905 Times in 1,247 Posts

    Make sure you have set your iPhone settings to not have the screen go dim at all?
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  3. #3
    Quote Originally Posted by poetic_folly View Post
    Make sure you have set your iPhone settings to not have the screen go dim at all?
    Well, I checked it and made sure the screen stayed on/unlocked while I tired again. Same result... the SSH connection just times out.

    Is there a command that can be executed within iPHUC to change permissions on a file (that's about the only thing I need SSH for, near as I can tell as I can copy App's to/fro using iPHUC) or someway to manually launch the SSHD service on the iPhone.

    Frustrating!

    Okay, so I finally figured out what was going on. To review, although I was able to do the SSH install without error, I couldn't connect... the connection attempt would just time out. So, I re-read the WIKI's, consulted the forums, did some Googling and tried again. Same result.

    So, not being one to give up and taking it somewhat personally at this point, I looked for (and tried) alternate method's. Different combinations of Restoring my Apple iPhone, along with ./jailbreak vs. iFunastic vs. iActivator, and all variations of step-by-step and "easy" installs. Long story short, each method that worked without error (successfully) end with the same result of being unable to connect... the connection attempt would just time out.

    I pressed on, and I am glad I did. As luck would have it, on yet another iTunes->Restore for my Apple iPhone, I decided to try *not* synching the iPhone after the restoration, basically keeping it as close to the "out of the box" product as possible. The iPhone was activated, but I didn't let it synch and that made all the difference. Something about eh synching of the data *before* installing SSH was the culprit behind being unable to connect.

    The end result? Well, after that last iTunes->Restore, the SSH installation process went without a hitch and I was able to successfully SSH into the iPhone. Given I was already able to ./jailbreak and iPHUC, being able to SSH opened up the flood gates and my Apple iPhone is now fully tweaked.

    Some notes I discovered along the way, in hopes that all of this information will help someone else.
    The ModMyI iPhone Skinner rocks. Use the file it produces with (a .IPB file) along with Install IPB to easily and fully customize the look of the Apple iPhone.
    The Install IPB application works best with the iPhone *after* the iPhone has been "freed" using iFuntastic. It doesn't seem to work right using ./jailbreak or iActivator.
    Whatever iPhone Skinner doesn't change, iFuntastic can (like the mail alert sound or battery cons, etc.)
    iFuntastic cannot be used to install new applications.
    There are several "quick and easy" install programs for SSH. They all seem to work best with iActivator vs. iFuntastic. Ultimately, I prefer the package put together by BlueDonkey, which does not require using iActivator or iFuntastic or anything first. Using it *immediately* after the "clean' iTunes-Restore was the ideal combination for me (iFuntastic, iActivator and iPHUC were all installed, I just didn't use any of them. BlueDonkey's package has it all covered.)
    The ModMyI WIKI's are awesome, but you have got to follow them precisely. Take your time and focus Danielson.
    Once SSH is installed and you are able to successfully SSH into your iPhone, everything else is a cakewalk.
    Installing new applications works best with iActivator, iPHUC and SSH *but* using SCP to copy the application to the iPhone instead of iPHUC (it takes fewer steps.)

    A huge thanks to everyone who offered assistance along the way. Every little bit helped and ultimately got me to the goodness I am enjoying now. I hope this collection of tidbits steers someone else in the right direction along the way. It feels good when the kid gloves come off!
    Last edited by iPhoneWriter; 2007-08-18 at 04:42 AM. Reason: Automerged Doublepost
    - iPhoneWriter.com

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •