Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: OSX & iPHUC issue. Help? :)

  1. #1
    iPhone? More like MyPhone Daerid's Avatar
    Join Date
    Jul 2007
    Location
    Seattle, WA
    Posts
    291
    Thanks
    2
    Thanked 23 Times in 18 Posts

    Default OSX & iPHUC issue. Help? :)
    I have followed the directions in the guide to a "T", and run into an issue at "Install Readline" "Step Two"

    I get this error.

    ---> Configuring ncursesw
    Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org _release_ports_devel_ncursesw/work/ncurses-5.6" && ./configure --prefix=/opt/local --enable-widec --disable-rpath --with-shared --without-debug --without-ada --enable-safe-sprintf --enable-sigwinch --mandir=/opt/local/share/man " returned error 77
    Command output: checking for egrep... grep -E
    Configuring NCURSES 5.6 ABI 5 (Thu Aug 9 16:28:54 PDT 2007)
    checking build system type... i386-apple-darwin8.10.1
    checking host system type... i386-apple-darwin8.10.1
    checking target system type... i386-apple-darwin8.10.1
    Configuring for darwin8.10.1
    checking for prefix... /opt/local
    checking for gcc... /usr/bin/gcc-4.0
    checking for C compiler default output... configure: error: C compiler cannot create executables

    Error: The following dependencies failed to build: ncurses ncursesw
    Error: Status 1 encountered during processing.

    I have no other programs running, and even tried restarting the Mac.

    Help would be greatly appreciated.

    - Daerid

    Well, I cant delete this, but I just found some help in another thread saying to re-install xcode, so I am doing that and seeing if that helps.
    Last edited by Daerid; 2007-08-10 at 01:36 AM. Reason: Automerged Doublepost

  2. #2
    What's Jailbreak?
    Join Date
    Aug 2007
    Location
    Desert
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    It should help - I ran into that same problem. The Xcode install righted the situation.

  3. #3
    Looks like GCC is outdated. Like ShesCake said, updating to the latest devtools should solve your issue.
    http://developer.apple.com/tools/xcode/

    -Digitol-

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •