Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: problems with cyberduck

  1. #1
    Exclamation problems with cyberduck
    hi! I have some problems with connecting to my iPhone using cyberduck. It just stopped worked for some reason. "The kexTimeout (30000 ms) expired". Someone know why and if there is a way to fix it?

  2. #2
    I am having the same problem. Can anyone help? Is this because I remove the known_hosts file in the .shh folder?
    Thanks

  3. #3
    Quote Originally Posted by smackjack View Post
    hi! I have some problems with connecting to my iPhone using cyberduck. It just stopped worked for some reason. "The kexTimeout (30000 ms) expired". Someone know why and if there is a way to fix it?
    What happens (what message do you get) if you try connecting via Terminal?

    ssh -l root your phones IP address

    ie: like

    ssh -l root 192.168.1.2

    It sounds like a CyberDuck issue, at first guess. The kext timeout is certificate related, but whether it's CD or SSH itself would be the question. Removing the known_host file won't do this, as SSH will generate a new one. Using a wrong known_host file might cause problems. Do you have a firewall involved ...?
    Last edited by jwdav; 2007-10-28 at 09:12 AM.

  4. #4
    Thanks for your help. I was able to log in using terminal. Let me explain a litle bit more so hopefully someone can help me out. I have two iPhones. A while ago I unlocked them with 1.0.2 firmware. I had no problems whatsoever connecting to these two phones via cyberduck to do the unlocking. Yesterday, I decided to virginize, upgrade firmware 1.1.1 and then unlock one of the two phones. I was able to do that without a hitch. So I proceeded to do the same thing with the second phone. I got stuck with the very first step trying to connect to the phone via cyberduck. I just kept giving me the error message timed out. I tried many times and different approaches including restarting my mac, renew lease for my wifi so I can get the most updated IP address, remove SSH and reinstall it, change password on SSH and so on ... all in vain. What is so frustrating is that I could connect to both phones before, now I can only connect to the 1.1.1 unlocked phone but not the 1.0.2 unlocked phone.
    Please help me as I am so DESPERATE. Thank a lot!

    oh, I also remove and install a clean version of cyberduck as well. It did not work. By clean, I mean I remove all the files associated with the previous version of Cyberduck.
    Last edited by hurmine; 2007-10-28 at 10:53 AM. Reason: Automerged Doublepost

  5. #5
    Since Terminal works, that narrows it down to Cyberduck. I'd guess it has lost track of/messed up something associated with the ssh certificate. If you've deleted everything you can find, and it still does it, the best option might be to try another sftp client - Fugu or Transmit for example.

  6. #6
    Thanks jwdav! I did try Fugu and Transmit as well and they still cannot connect. I can use all of these three (Cyberduck, transmit and fugu) to connect to the other phone that I had virginized and unlocked. If you have other thoughts, I wlll be so glad to hear.
    Thanks.

  7. #7
    I'm starting to think that perhaps SSL is damaged when installing SSH from Independence over top of an OpenSSH install on the phone.

    Has anyone had issues connecting to iTunes after updating? Issues being syncing of contacts/calendars etc. appearing to work, but actually not updating anything, or inability to even connect to iTunes?

    This would also show up in the console/system log as an SSL failure during sync.

    There seem to be a lot of seemingly related issues around this - I know in my case, I had enough minor issues around SSH and SSL, that I reset and restored the iPhone to get it back to a clean state.

    Read up before you think about reset and restore, as the process can & will vary depending upon the history and current status of your iPhone.
    Last edited by jwdav; 2007-10-29 at 12:14 AM.

  8. #8
    I am also having problems with Cyberduck. I was going to virginize so I could upgrade to 1.1.1, however, Cyberduck will not connect. I don't know if it is the same problem you all are having, or related to the fact that I upgraded my OS to Leopard.
    People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf.
    George Orwell


  9. #9
    Problem solved with Cyberduck!!! For those of you who are still having problem with SFTP soft such as Cyberduck, I found out the problem that should take minutes rather than days for me. I tried everything possible, and the problem for cyberduck timing out on me is just the wrong IP address. I still do not know why because on my phone the IP address is always 192.168.1.100 and I connected with this IP address before. But when I change the SFTP server to 192.168.1.101 it connected within seconds even though the IP address I read from the iPhone setting is still the .100. I renewed the lease and it always stays the same. At this point, I am not sure my iPhone gives the wrong IP or Cyberduck misreads it, but I am happy I got it to connect.

  10. #10
    i never had luck with cyberduck, go with cash and PF... use transmit, works like a pro

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •