Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Skype To No longer Work on Older Macs

  1. #1
    What's Jailbreak? Akshay Masand's Avatar
    Join Date
    Sep 2011
    Location
    New York City
    Posts
    5,897
    Thanks
    3
    Thanked 200 Times in 179 Posts

    Default Skype To No longer Work on Older Macs


    Microsoft recently announced that it has ended Skype support for Macs running OS X 10.5.8 Leopard or earlier. The news comes after Skype users began to complain on the company’s forum stating that they were being locked out from accessing the service on their devices. As the complaints continued to roll in, many started to conclude that Skype wasn’t working correctly on Macs that were running older versions of the OS X operating system, a hunch that turned out to be true in this case.

    The Redmond Washington company recently confirmed the change in a roundabout way in an answer to a question regarding Skype compatibility with OS X 10.6 Snow Leopard, which as of right now continues to remain unaffected. Rene, a staff member on the Skype message board, wrote the following regarding the matter:

    Hi everyone,

    there seems to be a lot of confusion around this. First, let me assure you that no-one is locking you out from using Skype on OS X 10.6 - 10.8 and there is no need to upgrade to Mavericks or (the new OS X now in dev preview) Yosemite if you don't want to.

    All OS X 10.6 - 10.8 users can head over to Downloading and get version 6.15. This is a very solid release and you can still use all of the main features without any problems (i.e. group video, group chats, screen sharing etc).

    Note that you should only use the link above, it serves you with a correct update for your OS version, direct links (to DMG files) can work, but are not guaranteed to do so.

    That said, we still encourage you to stay up to date, meaning upgrading to Mavericks and getting the latest Skype.

    Hope this clarifies things a bit.

    If you have problems updating, please let us know in this thread and I'll try to help you.
    For those of you who didn’t connect the dots, Apple’s OS X 10.6 Snow Leopard requires that Macs have an Intel processor. What this means is that Microsoft is removing the Skype service from Mac machines that are roughly eight years old. Some people who have older Macs have found workarounds that allow them to continue to use the service, including a method which blocks the software’s updater from connecting with update servers. Although solutions work in some scenarios, their success still varies on a situation-to-situation basis.

    Overall, the move isn’t a surprise as Microsoft did mention that it would be retiring older versions of Skype for both Macs and Windows over the next few months back in June.

    Were any of you affected by this service change? If so, what are you doing to deal with it?

    Source: Skype (Community) via AppleInsider

    Twitter: @AkshayMasand

  2. #2
    iPhoneaholic nienque's Avatar
    Join Date
    Feb 2013
    Location
    Leiden, Netherlands
    Posts
    354
    Thanks
    175
    Thanked 608 Times in 258 Posts

    This is not just a problem for people with pre-Intel Macs, but also for people who hate the waste of screen space in the current UI. If you prefer using 2.8, just add a line to your hosts file and you're set: explanation here.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •