I can not get the new mail sound to go silent when I turn it off in settings. The silent switch does work. I have downloaded silent mail and activated in winterboard, but that doesnt work either. I have some sort of a tweak that is effecting this and am wondering if someone has any ideas. I keep missing calls because I always have the silent switch turned off!