Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: I need help!

  1. #1
    Default I need help!
    I upgraded my iPod touch and i saw it wasn´t worth it. So should i wait for the iOs 4 Mc model jailbreak to release or should i downgrade my ipod and jailbreak it?

  2. #2
    I would downgrade it personally.

  3. #3
    Downgrade and jailbreak

  4. #4
    If it's an MC model, then sorry, you'll most likely run into error 3194 (3.1.3) or error 28 (3.1.2) The thing is, the default firmware for the iPod Touch MC model is 3.1.3, but since Apple stopped signing it, I couldn't really find a way to get around it. I'm not just about to give up though.

  5. #5

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •