Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Need 1g Help

  1. #1
    Default Need 1g Help
    Sup peeps?
    I have a 1st generation ipod touch its on firmware 1.1.2(3B48b)
    My question is this should i just go ahead and update it to 2.2.1
    And then quickpwn it? I'm more of an iphone user fairly new to the ipod side of things..Sorry for boring u guys with my dull questions..Also could't really find much threads on upgrading the firmware just a bunch of jailbreaking..
    I just want a hand UP!!! Not a hand out!!!

  2. #2
    My iPod is a Part of Me bteamer's Avatar
    Join Date
    Jun 2008
    Location
    California
    Posts
    1,686
    Thanks
    36
    Thanked 112 Times in 86 Posts

    YES. Definitely upgrade. 2.x is MUCH better, improved performance, Cydia is better than installer instead of vice versa on 1.x.x too. You have the Appstore, and much, much more. It is definitely worth the upgrade. And if you know where to look, you don't even have to pay for it.
    Quote Originally Posted by bhz1 View Post
    LOL! DOesnt everyone know that only real women know how to handle a stick?
    Quote Originally Posted by ALL DAY View Post
    As long as Miguel can blow...he's straight.
    Quote Originally Posted by bhz1 View Post
    I dread that first dusting of the white stuff.
    Quote Originally Posted by blkcadi View Post
    ready for a romp buddy? ohhhhhhhhhhhhhhhhh

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •