Hey guys, I thought I should share you my stories on upgrading to 1.1.3
With 1.1.4 being currently released, I don't think I'm going to go down that road for awhile until a more stable release of a jailbreak comes out.

Anyway, I would like to say my success with the 1.1.3 is an absolute failure. Why do I say this, then let me explain.

I have tried many different methods, some works but with some headaches, others literally screwed up my iPod Touch(I seriously thought I lost my iPod Touch!)

So let me explain to you what methods I have used and my ending result!

1.)iPodTouchMaster Upgrade Method: I am not sure how many of you know the dude off Youtube, but he goes by the name iPodTouchMaster and when something new happens in the scene, he is one of the few that makes a video showing you how to do it and shows you how to do it. Well my very first attempt at jailbreaking an iPod Touch 1.1.3 was to add his source to the installer and follow his instructions.
Video Here ----> [ame="http://youtube.com/watch?v=UQ7PsJXI0fg"]http://youtube.com/watch?v=UQ7PsJXI0fg[/ame]

Well my ending results of that one was that It took over 2 hours and it just sat there. He said that if that happens, just reboot and everything would be there. I done that and I had successfully jailbroken a 1.1.3 firmware. The downside was that nothing would install from the installer!

2.)My second attempt at jailbreaking 1.1.3 came from the guide here that I was reading. I had downloaded the 1.1.3 and SSH into my iPod Touch and put the firmware into /var/root/Media I think it said and then I done the Official 1.1.3 Upgrader in the installer. The tip said that the upgrader would find the firmware automatically there and would make it faster. So I was able to jailbreak that successfully(this method was awsome) but something still persisted. When I tried to add a source to the installer, it would freeze up. I had to keep holding the home button to take it back home. Other than that, everything worked fine.

3.)And finally, my very last attempt of jailbreaking 1.1.3 was my most recent attempt which scared the living day lights outta me because I thought I lost my iPod Touch forever! I was following this video on YouTube:
[ame="http://youtube.com/watch?v=W8fwUd2xyK8"]http://youtube.com/watch?v=W8fwUd2xyK8[/ame]

I followed the video instructions and when things where complete, it rebooted my iPod Touch. It sat there and I waited over 5 minutes for the thing to show the home screen, nothing. I thought something was a little weird and so I pressed the power + home button and rebooted the device. I restarted it again and waited 7 minutes this time, now I knew something was up. I could not figure out how to get the thing in recovery mode so I could just restore my firmware to 1.1.2, so I started searching like a mad man online on how to do this. I finally found out how, you hold the home button and plug in your device and it would automatically do it, from here my panic had shrunk as I knew I could restore my iPod Touch. I thought I had lost it forever.

Conclusion: 3 attempts as you can read and all such a failure. The 2 methods worked, but the installer gave me problems. If you have a solution to my problem on how to get the installer to work in 1.1.3 as I have explained my problem, it would be most appreciated. If you have any tips on how to prevent any problems or anything you might find helpful, please PM me or post, and I'll be quick on that solution. So there you have it, I hope you enjoy your reading and what possible problems you might face.