Hey guys!

I have a quick question regarding iLiberty+ 1.3 (the new version).

Will this work on a 1.1.3 iPod Touch? I've seen tutorials that say start with 1.1.4, but is that necessary?

Thanks for the help!

-Day