Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: User permissions in iFile

  1. #1
    Default User permissions in iFile
    I was messing around in iFile and I accidentaly allowed the folder mobile to be applied hierarchically. After that I couldn't use iFile normally anymore as it keeps saying it does not have permission to change the permissions I want it to set. Nor can I use dTunes to download things with torrents or anything.
    I tried doing the sbsettings fix user permissions option but it didn't do anything.
    I also tried to uninstall iFile and reinstall but that didn't help either.
    If anyone has a fix please help me.
    I'm running iOS 3.1.3 3rd Gen

    If I want to delete something I have to use iFunBox to manually delete as it doesn't want to work on it's own
    Last edited by MasterEzio; 2010-10-31 at 04:37 PM.

  2. #2
    Your going to need to restore the permissions via SSH. And it has to be SSH, iFunbox won't work.
    Want to drive an idiot insane? Click Here to find out how.

  3. #3
    How do I restore permissions via ssh?
    I only used iFunBox to delete stuff that wouldn't want to delete normally. I didn't use it for permissions, I don't think it's possible.

  4. #4
    Sorry to bring back an old thread, but I accidentally did the same thing on my iPhone 4. Turned on "Apply Hierarchically" for mobile, then turned it back off right away. Then the phone froze when I closed iFile, so I tried rebooting manually. Now it just gets to the Apple logo and has a spinning wheel.
    Help?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •