Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Can't Restore?

  1. #1
    Default Can't Restore?
    If you don't wanna read my sad story read from the bolded and underlined part and down.

    Okay, so i downloaded this new theme, which came with other crap, including Iblank, which i didn't know at first. Then on it didn't let me install ANY apps because there was NO space to put it.
    So i then decided to restore it.
    I restored it through my IPod Touch using General > Settings > Delete all content and settings. It took about 20 minutes to finish, and then my ipod just shut down. I tried to re-open it, It kept getting stuck at the Apple Logo. I looked up some things on google and found out about the recovery mode.
    After being on recovery mode, i connected my USB cord and it connected to Itunes as recovery thing.
    I pressed restore, it said a update had to be done, and i let the update finish. After that i pressed Restore, it said it couldn't connect to apple server. So i read some things on google and turned my firewall off for a bit.

    Then it started working, it did everything precisely, then just at the end it says "The Ipod "----" Could not be restored. an unknown Error has occured(1604)"

    How do i fix this and restore my Ipod touch 3.1.3 so its good as new again? PLEASE i need help badly.

    can someone please help me??
    Last edited by Shishir G; 2010-06-14 at 12:57 AM. Reason: Automerged Doublepost

  2. #2
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    1604 deals with USB problems.

    Error 1604: This error is often related to USB timing. Try changing USB ports, uninstalling and reinstalling USB ports, and other available USB troubleshooting steps (troubleshooting USB connections, device not recognized properly, computer won't recognize a FireWire or USB device). If you are using a dock, bypass it and connect directly to the USB 30-pin dock-connector cable. If the issue persists on a known-good computer, the device may need service.

    If the issue is not resolved by USB isolation troubleshooting, and another computer is not available, try these steps to resolve the issue:

    1. Connect the device to iTunes, confirm that the device is in Recovery Mode. If it's not in Recovery Mode, put it into Recovery Mode.
    2. Restore and wait for error 1604.
    3. When prompted, click OK.
    4. Close and re-open iTunes while iPhone remains connected.
    5. iPhone should now be recognized in Recovery Mode again.
    6. Try to restore again.

    If the steps above do not resolve the issue, try restoring using a known-good USB cable, computer, and network connection.

  3. #3
    Thanks for the info, but can you give me any idea about how to download usb drivers and stuff? Everytime i connect a new thing to my computers usb it says new device found.
    When i try to install it says that i need a specific software to make the computer recognize it.
    This also comes up when i put my ipod on recovery mode a pop-up comes up saying "Apple Mobile Device (recovery) new hardware found!"
    Then after that it says "The hardware was not installed because it cannot find the necessary software." when i try to install it.

  4. #4
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,824
    Thanks
    553
    Thanked 515 Times in 427 Posts

    What I recommend to you is that you find another PC, download a fresh version of iTunes on it, plug your phone into it and restore it on that one. I had this issue everytime I put a new firmware on my 1st gen iPhone. It really frustrated me. Every firmware...1604. It worked flawlessly on other machines though.

    You could try this:
    Try uninstalling the following items in order:
    Apple mobile device (might not be installed)
    Apple software update
    iTunes
    Quicktime

    Now restart computer.

    Now download iTunes again and save it to your desktop.

    Disable any anti-virus and internet security.

    Now install itunes again and plug in your phone.

    This may help too: Using MSCONFIG to troubleshoot conflicts in Windows XP

    Install iPhone drivers without iTunes and driver installs without iTunes.
    Last edited by CaptainChaos; 2010-06-14 at 02:19 AM. Reason: Automerged Doublepost

  5. #5
    Well, never mind close this thread.
    I went to apple store, they fixed it for free, actually they replaced it but whatever Thanks for trying.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •