Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: The application 'HelloWorld' cannot be opened

  1. #1
    Default The application 'HelloWorld' cannot be opened
    Okay, I am a bit dumbstruck here.
    I have firmware 2.0.2 and it's jailbroken.
    I installed gcc and the necessary tools as per:
    Developing for the iphone using the open toolchain and SDK 2.0 headers - antirez weblog
    (had to add make and ldid to get it to work but apart from that, pretty okay)

    After the app gets installed however I can't open the executable.
    It's there:
    iPhone:/Applications/HelloWorld.app root# ls -l
    total 32
    -rw-r--r-- 1 root admin 108 Sep 20 02:38 Default.png
    -rwxr-xr-x 1 root admin 14192 Sep 20 02:39 HelloWorld*
    -rw-r--r-- 1 root admin 812 Sep 20 02:38 Info.plist
    -rw-r--r-- 1 root admin 9 Sep 20 02:38 PkgInfo
    -rw-r--r-- 1 root admin 2399 Sep 20 02:38 icon.png

    ..and the permissions seem right....I think?
    I have no apps installed from the AppStore...which I see often mentioned when people have probs with 'cannot be opened'.

    Oh yes, the application has been signed with ldid -S.

    Anyone with any clues?...it would sure be appreciated.

    Thanks!

    Oh yeah...I should add, this means that the icon is there but when I tap it I get a popup telling me 'The application 'HelloWorld' can not be opened'.

    I'm still clueless (
    Last edited by soucerer; 2008-09-21 at 10:33 AM. Reason: Automerged Doublepost

  2. #2
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Orlando FL
    Posts
    767
    Thanks
    17
    Thanked 23 Times in 22 Posts

    its not signed...
    iTouch 2.0 (free update/pwn'd)
    iPhone 3G white (pwn'd)
    MacBook Pro 15inch (using tethered)

    2 broken wrists so give me a break. no more 2007 Yamaha r6

  3. #3
    Thats weird, I did ldid -s on it...isn't that the app to sign it?


    (tried -s as well as -Sseemed to make no difference)

    Anyhow, thanks, I'll look into it again (

    Well, I'm at a loss, I definitely signed it (ldid -S HelloWorld). No asserts or nothing so seems okay....but no go.

    Darn....I really hope to not have to save up for a Mac.
    Last edited by soucerer; 2008-09-22 at 06:33 AM. Reason: Automerged Doublepost

  4. #4
    "The application can not be opened" usually is a signing problem.

    Just in case have you checked "HelloWorld.app" directory permissions?
    Last edited by buzios; 2008-09-22 at 01:32 PM. Reason: Automerged Doublepost

  5. #5
    Well, despite that being a good suggestion - I checked and the attributes seem right, and to make sure I chmodded em to no avail.
    Tried respringing, but get 'not rebuilding cache because pre 2.1'.

    I'm at a loss (

  6. #6
    Well...it was fixed the moment I installed an app from the appstore. Don't ask why but that seems to add that special something I assume.

    Unfortunately this was after about 5 reinstalls and cygwin reinstalls and whatnot....byt yay!...it works (o:

  7. The Following User Says Thank You to soucerer For This Useful Post:

    yrf009 (2009-03-19)

  8. #7
    How did you download your own software from AppStore? Thanks!

  9. #8
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    He didn't install his own software. He just downloaded a random app from the App Store. I've had to do this to fox the same issue. It's a mystery as to why this works.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •