Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone Installation error

  1. #1
    Default iPhone Installation error
    Hello,

    I'm new to iPhone and i have a rookie question:
    I downlaoded the latest X-Code (3.1) which is, as far as i understand, purposed for iPhone OS 2.0.
    I created a very simple "hello world" application and installed it on my iPhone which has OS 1.1.4
    But when i click on the app. icon nothing happens except for the icon which is palced all over the screen for couple of seconds.
    My question is, can i install an app. which compiled on X-Code 3.1 on a device with OS 1.1.4?
    If not, i tried to locate a former SDK for the 1.1.4 but couldn't find any, does anyone have a valid link?
    Thanks.

  2. #2
    you can only install applications on your device if you are an approved developer (apple approves almost nobody at this point) and pay at least $99 a year.
    if you are, you get the iphone OS 2.0 beta to install on your iphone.

    on other iphones applications created with the SDK cannot be run.

  3. The Following User Says Thank You to BlackWolf For This Useful Post:

    robybd (2008-04-24)

  4. #3
    Hi,
    I didn't understand 1 thing, how can i create application for the iPhone OS 1.1.4?
    The iPhone i'm using was jail-break so i shouldn't have a problem to run any app.
    I have the sdk for 2.0 but i can't run any application i create as my iPhone OS is 1.1.4
    Thanks again.

  5. #4
    Quote Originally Posted by robybd View Post
    Hi,
    I didn't understand 1 thing, how can i create application for the iPhone OS 1.1.4?
    The iPhone i'm using was jail-break so i shouldn't have a problem to run any app.
    I have the sdk for 2.0 but i can't run any application i create as my iPhone OS is 1.1.4
    Thanks again.
    you simply can't. apps created with the official SDK cannot be run on 1.1.4, jailbroken or not. period. they can only be run on 2.0 beta if you are a paying developer.

    applications for 1.1.4 (= jailbreak-applications) can only be created via toolchain (see stickies in this forum).

  6. The Following User Says Thank You to BlackWolf For This Useful Post:

    robybd (2008-04-27)

  7. #5
    Ok, thanks a lot.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •