Page 1 of 9 123 ... LastLast
Results 1 to 20 of 176

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Weather Elements HD 6 Version late 2014

  1. #1
    Default Weather Elements HD 6 Version late 2014
    Weather Elements HD 6 Version late 2014



    For iPhone 6 / 7

    Download

    required:

    • Lockhtml3 or groovyLock
    • iFile or Filza


    Installation:

    Copy the folder "Weather Elements.theme" via iFile / iFunbox / ssh to Library/Themes.

    Copy the folder "WeatherElements.webclip" to var/mobile/library/WebClips.

    Respring. Tap the WeatherElements icon on the homescreen & make your Settings - ZIP-Code or Location e.g. Berlin, Germany:



    Save - if it's successful. there will be a confirmation

    Now let's do a little handwork:

    Copy via iFile the following file and folder:

    /var/mobile/Library/WebClips/WeatherElements.webclip/Storage/Databases.db (file)
    /var/mobile/Library/WebClips/WeatherElements.webclip/Storage/file_0 (folder)

    navigate to /var/mobile/Library/Caches choose "Create Link" to create a sym link - Now the database is ready to read the weather conditions.

    Apple changed with the iPhone 6 / 6+ the file permissions - sometimes the database could be blank or will not be saved. So the permissions in the filesystem have to changed.

    Navigate back to the folder "WeatherElemens.webclip:



    open the file attribute:



    Change the permissions like that: Owner / Group to "mobile", Access permissions for "user" "Group" "world" to "read - write - execute". Do this with all files and folders in the "WeatherElements.webclip" folder:

    • db.html
    • Ordner Storage
    • Ordner file__0
    • Databases.db


    If the database will be still blank or still not saved after a respring or reboot, change the permissions for the folder var/mobile/library in the same way like above.

    Choose the theme via LockHTML3 o. GroovyLock.


    Invalid location: try another location or choose "10001" and use the gps search.

    4 different designs:
    • Basic
    • Grassy Hills
    • Rocky Mountains
    • Classic


    7 different languages:
    • Englisch
    • German
    • French
    • Espanol
    • Italiano
    • Dansk
    • Arabic



    Lockscreen clock / date in the picture above are hidden by hideme8.

    CREDITS

    go to: brandon28139, zed, CeiBaer, rasputin007, hell7, mokabaer, raveking, Yveswo, bostaunieux, scotchtape, cameron213, jazzfanatic, methman, FlashPix, Katra, MNIDHK u.a.


    **********************************

    Developers welcome to find another way for setting up the theme, redesing the Setup like an "normal" app or ad more weather conditions in the forecast screen

    **********************************

    Since Macthemes.net is gone, we tried to keep this beautiful theme alive.

    CU
    Zed
    (WE Senior product Manager )
    Last edited by Zed63; 2017-02-14 at 09:39 AM.
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz

  2. The Following 9 Users Say Thank You to Zed63 For This Useful Post:

    A11AST3R (2014-12-01), Blue (2014-12-03), Irish_Man (2015-11-02), jm26200 (2014-12-03), Laxu (2014-12-24), lostinthemes (2016-11-30), Mary48336 (2015-04-02), WhatDoIknow (2014-12-01), yangchengly (2015-03-27)

  3. #2
    Loved this on my iP4, and would love to get it on my iP6
    Here is a link to my public folder where you will find iWidgets/Lockscreen Widgets/and misc. things I have created
    https://www.dropbox.com/sh/mwr4pbu5i...4gxv1RjBa?dl=0

  4. #3
    Livin the iPhone Life
    Join Date
    Jan 2014
    Location
    United Kingdom
    Posts
    1,774
    Thanks
    1,608
    Thanked 2,439 Times in 1,051 Posts

    Fantastic 👍 just one thing I done differently was to copy the theme file into mobile/groovy lock rather than stash/themes

    -imageuploadedbymodmyi1417412712.194968.jpg

  5. #4
    i'm very sorry - but the first post disappears after editing some mistake? What happens here? Is there any possibility to get this back?

    Help needed !

    Zed
    Last edited by Zed63; 2014-12-01 at 08:20 AM.
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz

  6. #5
    Livin the iPhone Life
    Join Date
    Jan 2014
    Location
    United Kingdom
    Posts
    1,774
    Thanks
    1,608
    Thanked 2,439 Times in 1,051 Posts

    Maybe only by going back via the computer to before you edited if you still have the page open?

  7. The Following User Says Thank You to Matthews436 For This Useful Post:

    Zed63 (2014-12-01)

  8. #6
    no way - i sent a message to the board team. Maybe the can restore the post. If not, i' ll reopen it later this day.
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz

  9. #7
    Etch A Sketch Sk37cH's Avatar
    Join Date
    May 2011
    Location
    Oz maaaaaate ;)
    Posts
    2,533
    Thanks
    6,115
    Thanked 10,215 Times in 2,246 Posts

    Default Weather Elements HD 6 Version late 2014
    Quote Originally Posted by Zed63 View Post
    i'm very sorry - but the first post disappears after editing some mistake? What happens here? Is there any possibility to get this back?

    Help needed !

    Zed
    It's an anti-spam feature that kicks in for meme era with under a certain post count (10-20 I believe). Everytime you make a change, it needs to be approved by a moderator before it'll show again. Easiest way around this? Don't make changes to your original post until you've reached your post count. There's general chit-chat forums to introduce yourself on that way your post won't disappear and re-appear on you Cheers.

  10. The Following 2 Users Say Thank You to Sk37cH For This Useful Post:

    dmick89 (2015-01-09), Zed63 (2014-12-01)

  11. #8
    I'm addicted to jailbreak lostinthemes's Avatar
    Join Date
    Dec 2010
    Location
    Istanbul, Turkey
    Posts
    596
    Thanks
    7,098
    Thanked 478 Times in 228 Posts

    Yes, we need to see this...

  12. #9
    ok,

    thanks for the explanation - so i have to wait until a mod approved the changes i've made. Sorry again for that trouble.

    But: i was able to edit post#3 ??

    CU
    Zed
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz

  13. #10
    Theme Creator
    Join Date
    Apr 2008
    Location
    In a state of confusion
    Posts
    1,170
    Thanks
    519
    Thanked 648 Times in 427 Posts

    Yeah I'm looking forward to getting this back on my phone!

  14. #11
    Livin the iPhone Life
    Join Date
    Jan 2014
    Location
    United Kingdom
    Posts
    1,774
    Thanks
    1,608
    Thanked 2,439 Times in 1,051 Posts

    Follow the instructions in post 1 and you will have it 👍

  15. #12
    Theme Creator
    Join Date
    Apr 2008
    Location
    In a state of confusion
    Posts
    1,170
    Thanks
    519
    Thanked 648 Times in 427 Posts

    im having issues. First, no wording populates the webclip when I tap on the icon. I know what to tap on because of the images on modmyi, but otherwise it's all blank. Second, when I hit the save button at the bottom, I don't think its saving. I don't get any indications that my setting have been saved. And lasts when I try to create the sym link, am I supposed to name it? Because when I try to just create a sum link, I file tells me I already have one by that name.

    Edit: I think I got most of it. I opened the webclip in file and the boxes populate and the setting saved there (clicking on the icon though they do not work). I also managed to figure out the sym link issue. So now I can get the base wallpaper to show up, but when I hit the green "refresh" arrow it tries to retrieve the weather and give me the invalid location error, regardless of what I enter (can't seem to use the gps option when I open the webclip in file either).
    Last edited by 1hihum; 2014-12-01 at 08:48 PM.

  16. #13
    Default Weather Elements HD 6 Version late 2014
    Hi,

    the reason for your issues is the missing permissions in the file system.

    Try this:

    delete the sym-links in the folder "caches". Reboot. Navigate to the folder "var/mobile/library/ WebClips" Change the Ownership / permissions as i described in post #1.

    Respring and try to make the settings. In the database is saved, create the symlinks. Respring and it should work.

    Good luck.

    CU
    Zed
    Last edited by Zed63; 2014-12-01 at 09:00 PM.
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz

  17. #14
    Theme Creator
    Join Date
    Apr 2008
    Location
    In a state of confusion
    Posts
    1,170
    Thanks
    519
    Thanked 648 Times in 427 Posts

    Ok so I think I've got it all sorted out. I opened the weblclip in ifile and got the boxes to populate and the settings to save. So the base wallpaper shows up, but when I try to refresh the weather I get a n invalid location error (using my zip code which worked before).
    Last edited by 1hihum; 2014-12-02 at 03:45 AM.

  18. #15
    Did you change the permissions?

    CU
    Zed
     iPhone 7 128GB @IOS 10.1.1  iPad air WiFi + Cellular 64GB @IOS 8.1  iMac 27" 3.2 GHz

  19. #16
    Default Weather Elements HD 6 Version late 2014
    So this is what I get
    Last edited by oO BlackRa1n Oo; 2014-12-02 at 01:36 AM.

  20. #17

  21. #18
    Etch A Sketch Sk37cH's Avatar
    Join Date
    May 2011
    Location
    Oz maaaaaate ;)
    Posts
    2,533
    Thanks
    6,115
    Thanked 10,215 Times in 2,246 Posts

    Quote Originally Posted by Zed63 View Post
    ok,

    thanks for the explanation - so i have to wait until a mod approved the changes i've made. Sorry again for that trouble.

    But: i was able to edit post#3 ??

    CU
    Zed
    I think you mean post #4, as post #3 isn't yours.

    There's no images or links in that post, hence it has little to be classed as *potential* spam. Spammers usually include links in the posts. Make sense?

  22. #19
    Theme Creator
    Join Date
    Apr 2008
    Location
    In a state of confusion
    Posts
    1,170
    Thanks
    519
    Thanked 648 Times in 427 Posts

    Quote Originally Posted by oO BlackRa1n Oo View Post
    -imageuploadedbymodmyi1417480619.220441.jpg
    I was getting the same thing. After fixing the permissions issue (a conflict with a prior version of Weather Elements I had tried on my phone) I just opened the db.html file in ifile and set it up there (the texts will populate in ifile and it will save there as well). Once I got it set up there and had all of the permissions straight it worked. Once it started working correctly I hit the icon and the boxes populated properly.

  23. The Following User Says Thank You to 1hihum For This Useful Post:

    oO BlackRa1n Oo (2014-12-02)

  24. #20
    Quote Originally Posted by 1hihum View Post
    I was getting the same thing. After fixing the permissions issue (a conflict with a prior version of Weather Elements I had tried on my phone) I just opened the db.html file in ifile and set it up there (the texts will populate in ifile and it will save there as well). Once I got it set up there and had all of the permissions straight it worked. Once it started working correctly I hit the icon and the boxes populated properly.
    -imageuploadedbymodmyi1417495970.145421.jpg
    Working like a champ! Missed this LS!!

  25. The Following User Says Thank You to oO BlackRa1n Oo For This Useful Post:

    Zed63 (2014-12-02)

Page 1 of 9 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •