Page 598 of 614 FirstFirst ... 98498548588596597598599600608 ... LastLast
Results 11,941 to 11,960 of 12265

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: UniAW7

  1. #11941
    iPhoneaholic mohseen488's Avatar
    Join Date
    Feb 2011
    Location
    Kabul, Afghanistan
    Posts
    410
    Thanks
    972
    Thanked 1,369 Times in 239 Posts

    Quote Originally Posted by NewD View Post
    I had this happen once with XenHTML. The only thing that cleared it was a hard reboot and re-jailbreak. I'm assuming you're on iOS 10 with either Yalu102 or Mach_Portal?
    Yes, I am on 10.2 Yalu102


    Sent from my iPhone using Tapatalk
    If you like my Post please hit the Thanks button on the bottom Left Corner.


  2. #11942
    Livin the iPhone Life nik1975's Avatar
    Join Date
    Feb 2008
    Location
    Thessaloniki, Greece
    Posts
    1,908
    Thanks
    4,509
    Thanked 1,485 Times in 879 Posts

    Default UniAW7
    Quote Originally Posted by NewD View Post
    Are you trying to use it in LockHTML4, Nik? And what phone and firmware are you on? Don't think you have a problem with WW3.. as you'd see a "no widgetweather.xml" warning if that were the issue.

    My guess is you're accidentally answering "yes" to the optimization question LH4 asks you when you choose a widget.. or when choosing - options appear and you choose some options and hit save. Both of those actions will break a widget in LH4... something Busche hasn't fixed in 3 jailbreaks.

    So get rid of UniAW7_WW3 and download a fresh one.. then delete the
    options.plist
    Info.plist
    widget.plist
    Widget.html

    Then when you choose the widget in LH4 it should ask you to optimize the widget. Answer NO! And then the widget should work after a respring.

    If you still never see the Optimize warning and still see options when you choose, then go to var/mobile/Library/Preferences and scroll way down to the bottom and look for LockHTML preferences and delete them. Then respring -,then try to choose the widget again. You'll know it's going to work in LH4... when you get the alert to Optimize or not. Answer NO.. and it will work.

    If it doesn't - something's conflicting on your phone.
    No i dont use lockhtml at all
    I use only convergance, and i have iphone 5 with ios8.4
    Is it compatible with iphone 5?
    And also i see a folder.anemone
    I dont use anemone is that cause the problem?

    Sent from my iPad using Tapatalk Pro
    Last edited by nik1975; 2017-03-14 at 02:26 PM.

  3. #11943
    Nik, let's start over.

    Your on 8.4, so are you using Groovylock? Do you have GroovyAPI installed?


    Sent from my iPhone using Tapatalk

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0

  4. The Following User Says Thank You to King_O_Hill For This Useful Post:

    nik1975 (2017-03-14)

  5. #11944
    Livin the iPhone Life nik1975's Avatar
    Join Date
    Feb 2008
    Location
    Thessaloniki, Greece
    Posts
    1,908
    Thanks
    4,509
    Thanked 1,485 Times in 879 Posts

    Quote Originally Posted by King_O_Hill View Post
    Nik, let's start over.

    Your on 8.4, so are you using Groovylock? Do you have GroovyAPI installed?


    Sent from my iPhone using Tapatalk
    I have installed Groovylock and Convergance,but i use only convergance for all the themes on lockscreen
    And yes i have groovyAPI as well


    Sent from my iPhone using Tapatalk Pro

  6. #11945
    Quote Originally Posted by nik1975 View Post
    I have installed Groovylock and Convergance,but i use only convergance for all the themes on lockscreen
    And yes i have groovyAPI as well


    Sent from my iPhone using Tapatalk Pro
    You can use Groovylock with convergance. You just need a "empty" theme to pick in convergance and then use Groovylock to pick your LS. That's the way I always ran it on iOS 8.4

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0

  7. The Following User Says Thank You to King_O_Hill For This Useful Post:

    NewD (2017-03-14)

  8. #11946
    Livin the iPhone Life nik1975's Avatar
    Join Date
    Feb 2008
    Location
    Thessaloniki, Greece
    Posts
    1,908
    Thanks
    4,509
    Thanked 1,485 Times in 879 Posts

    Default UniAW7
    Quote Originally Posted by King_O_Hill View Post
    You can use Groovylock with convergance. You just need a "empty" theme to pick in convergance and then use Groovylock to pick your LS. That's the way I always ran it on iOS 8.4
    Ok,but still newd base doesnt work and Mermads also
    I try they way you ve said,but doesnt work the new themes

    Sent from my iPad using Tapatalk Pro

  9. #11947
    Livin the iPhone Life nik1975's Avatar
    Join Date
    Feb 2008
    Location
    Thessaloniki, Greece
    Posts
    1,908
    Thanks
    4,509
    Thanked 1,485 Times in 879 Posts




    Sent from my iPhone using Tapatalk Pro

  10. #11948
    iPhoneaholic mohseen488's Avatar
    Join Date
    Feb 2011
    Location
    Kabul, Afghanistan
    Posts
    410
    Thanks
    972
    Thanked 1,369 Times in 239 Posts



    Credits to creators

    Love it


    Sent from my iPhone using Tapatalk
    If you like my Post please hit the Thanks button on the bottom Left Corner.


  11. #11949
    Default UniAW7
    Delete

  12. #11950
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,710
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Default UniAW7
    Quote Originally Posted by nik1975 View Post
    Ok,but still newd base doesnt work and Mermads also
    I try they way you ve said,but doesnt work the new themes

    Sent from my iPad using Tapatalk Pro
    So.. so strange that it's not working for you Nik. I tested in Convergence on my iPhone 5 on 8.1.2 just now.. again.. still working.. just like yesterday.

    The fact the Chevy's BLUR widget DOES work for you and that the new Base AND Menard's MOD of the new base DON'T work for you suggests there's something in the new coding that is the root of your problem.

    But if it works in Convergence on my iPh5 on iOS 8... then that points to something only on your phone that's the issue and not the code.

    I have SO been in your situation before and it's enormously frustrating. But if I can't reproduce the problem here - I can't get to the bottom of it.

    King_O_Hill is the best trouble shooter I know.. maybe he can nail it for you.. I'll screen shot you my settings in Convergence and see if there are any details deferences.

    The Anemone HTML folder shouldn't be an issue. It's just the new way of packaging the widgets so they will work in AnemoneHTML as well as all other HTML tweaks.

    So Nik, did ANY versions of the new base - this last month or so - work for you? I've done several updates.

  13. #11951
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,710
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Default UniAW7
    Quote Originally Posted by mohseen488 View Post
    Yes, I am on 10.2 Yalu102
    Did rebooting and reJBing work for you?

  14. The Following User Says Thank You to NewD For This Useful Post:

    mohseen488 (2017-03-14)

  15. #11952
    iPhoneaholic mohseen488's Avatar
    Join Date
    Feb 2011
    Location
    Kabul, Afghanistan
    Posts
    410
    Thanks
    972
    Thanked 1,369 Times in 239 Posts

    Quote Originally Posted by NewD View Post
    Did rebooting and reJBing work for you?
    Respringed many times, sometimes work and some times blank ☹️


    Sent from my iPhone using Tapatalk
    If you like my Post please hit the Thanks button on the bottom Left Corner.


  16. #11953
    Livin the iPhone Life nik1975's Avatar
    Join Date
    Feb 2008
    Location
    Thessaloniki, Greece
    Posts
    1,908
    Thanks
    4,509
    Thanked 1,485 Times in 879 Posts

    Quote Originally Posted by NewD View Post
    So.. so strange that it's not working for you Nik. I tested in Convergence on my iPhone 5 on 8.1.2 just now.. again.. still working.. just like yesterday.

    The fact the Chevy's BLUR widget DOES work for you and that the new Base AND Menard's MOD of the new base DON'T work for you suggests there's something in the new coding that is the root of your problem.

    But if it works in Convergence on my iPh5 on iOS 8... then that points to something only on your phone that's the issue and not the code.

    I have SO been in your situation before and it's enormously frustrating. But if I can't reproduce the problem here - I can't get to the bottom of it.

    King_O_Hill is the best trouble shooter I know.. maybe he can nail it for you.. I'll screen shot you my settings in Convergence and see if there are any details deferences.

    The Anemone HTML folder shouldn't be an issue. It's just the new way of packaging the widgets so they will work in AnemoneHTML as well as all other HTML tweaks.

    So Nik, did ANY versions of the new base - this last month or so - work for you? I've done several updates.
    The truth Is that i didnt try any of your previous versions so i dont know if they work.
    But no only Blur,but everything that i used to work are working fine for example NewUniAW7.1 chevymusclecar Is working.
    Also your newsest Base doesnt work with sbhtml also
    So i think that it has maybe something with the Cole
    I hope King can help or anyone Who has something in history mind


    Sent from my iPad using Tapatalk Pro

  17. #11954
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,710
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Quote Originally Posted by mohseen488 View Post
    Respringed many times, sometimes work and some times blank ☹️
    Not 'respring'... REBOOT and RE-JAILBREAK. That's what fixed it for me in XenHTML the one time I could only see it in the choice window - but then it wouldn't show on the LS. Try a full reboot.. and re-jailbreak, please..

  18. The Following User Says Thank You to NewD For This Useful Post:

    mohseen488 (2017-03-15)

  19. #11955
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,710
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Quote Originally Posted by nik1975 View Post
    The truth Is that i didnt try any of your previous versions so i dont know if they work.
    But no only Blur,but everything that i used to work are working fine for example NewUniAW7.1 chevymusclecar Is working.
    Also your newest Base doesn't work with sbhtml also
    So i think that it has maybe something with the Cole
    I hope King can help or anyone Who has something in history mind
    Just checked in SBHMTL on my iPh5 on 8.1.2 also.. and both widgets work there too on Springboard? Have you tried GroovLock? See if it works there..

    But I have one more idea... I don't know if we asked you to make sure you're on the most recent version of WW3 which 3.0-12 from Cydia. Make sure you do NOT have the repo with SDDEV's name in it in your sources.. Get rid of that repo.. Then see if Cydia shows you needing an update for WW3. If so.. do it..

    These new bases require the most recent version of WW3 which has a map.xml in it that calls extra API sources. If that newest map isn't on your phone - the widget will fail..

    So IF your WW3 IS up to date already.. try this.. In the UniAW7.1_WW3 folder I included a copy of the most recent map.xml.. Please copy it in iFile then paste in var/mobile/Library/WidgetWeather folder. Replacing the one that's already there.. Then respring.. See if that makes a difference.

    The only uniqueness to your iPh5 on iOS8 and mine.. might be that you have an older version of WW3. Though I think I remember you above showing us - that you were up to date... hmmm.. Well.. try the newest map copy/paste I just mentioned.

    Morkino is another guy on iPh6 iOS8.4 using GroovyLock+ and GrroovyBoard+ and has no problem with these bases.

  20. #11956
    Livin the iPhone Life nik1975's Avatar
    Join Date
    Feb 2008
    Location
    Thessaloniki, Greece
    Posts
    1,908
    Thanks
    4,509
    Thanked 1,485 Times in 879 Posts

    So,i dont have in cydia sddev at all,and my version is the latest 3.0-12
    Try with replace the map.xml but nothing!!!
    Also i try with with groovylock but nothing!!!
    The Base themes that comes with ww3 are working also fine
    So,should i make some settings in the widget weather Menu from settings?
    I dont know what else to think!!


    Sent from my iPad using Tapatalk Pro

  21. #11957
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,710
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Nik..This is beginning to remind me of a very old 'ghost problem' we used to have with WW3... where at certain places in Europe and Asia weather.com doesn't report an updatetimestring to the xml file..

    Can you open your widgetweather.xml file in var/mobile/Documents and search for "updatetimestring" and let me know if it's blank..

    If blank - it will look like this:

    Code:
    <updatetimestring></updatetimestring>
    .. and THAT will be what's causing your trouble...

    In the bases for WW3 (03_WW_OFH_BASE & 03_WW_OFH_LS), which Chevy built his BLUR LS widget off of.. I added some code from Rasputin007 to CREATE an updatetimestring if it doesn't get reported by weather.com to the xml file... But I forgot to add that failsafe code to the newest UniAW7.1 base meaning it also wouldn't be in any of Menard's mods... That would explain why Chevy's widget and the WW3 base widgets work - but not the new U7_WW3 base nor Menard's..

    Check that for me and report back.. and in the meantime I will update the main.js with the 'override' code to fix why Greece doesn't get that important piece of data from weather.com. NONE of the U7 widgets will work withouth updatetimestring in the xml file -unless they have the workaround code.
    Last edited by NewD; 2017-03-14 at 09:06 PM.

  22. The Following User Says Thank You to NewD For This Useful Post:

    nik1975 (2017-03-14)

  23. #11958
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,710
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Nik.. Here is a link to the main.js files for UniAW7.1_WW3 and Menard_LS-R with the radar... Replace the main.js files in each of those widgets with the corresponding one in this zip file.

    Of course, rename them from main-Menard.js and main-U7WW3.js to just 'main.js' once you erase the older main.js'..

    I think that should solve your problem.

    This little problem rears its ugly head once every few months -- and we should recognize it sooner -- but it always takes us a little while to recognize the issue.

    Let me know if it works..

    For Nik:
    https://dl.dropboxusercontent.com/u/...mainJS-Nik.zip

  24. The Following 2 Users Say Thank You to NewD For This Useful Post:

    kristatos (2017-03-14), nik1975 (2017-03-14)

  25. #11959
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,710
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    And, of course.. this requires an update to the UniAW7.1_WW3 base again.. and other mods you guys have done.. so people in Nik's situation don't have the issue...
    Link in my signature still good to get this update..
    Modders all you need to really do to update your mod to prevent this issue is to look for this code...
    Code:
    /////////////WORKAROUND CODE ONLY/////////
    if (xmlDown == false) {
    	obj.updatetimestring = $(data).find('updatetimestring').text();
    } else { getLiveUpdate (); }
    /////////////END WORKAROUND///////////////
    ... and immediately below the END WORKAROUND LINE add this code:
    Code:
    if (!obj.updatetimestring) {
    	d=new Date();
    	var year=d.getFullYear();
    	var month=d.getMonth();
    	month =month+1; //month are displayed from 0 to 11, hence the +1
    	var day=d.getDate();
    	var hour=d.getHours();
    	var minute=d.getMinutes();
    	var second=d.getSeconds();
    	var timeOfDay = ( hour < 12 ) ? "AM" : "PM";
    	if (hour>12) hour=hour-12;
    	if (hour<10) hour="0"+hour;
    	if (minute<10) minute="0"+minute;
    	if (second<10) second="0"+second;
    	if (month<10) month="0"+month;
    	if (day<10) day="0"+day;
    	obj.updatetimestring =(year+"-"+month+"-"+day+" "+hour+":"+minute+":"+second+" "+timeOfDay);
    }
    Don't touch anything else.

    Link again to newest base if you can't see my signature:
    https://dl.dropboxusercontent.com/u/...iAW7.1_WW3.zip

  26. The Following User Says Thank You to NewD For This Useful Post:

    kristatos (2017-03-14)

  27. #11960
    Livin the iPhone Life nik1975's Avatar
    Join Date
    Feb 2008
    Location
    Thessaloniki, Greece
    Posts
    1,908
    Thanks
    4,509
    Thanked 1,485 Times in 879 Posts

    So,i checked in widgetweather.xml it is not blank
    I replace the main.js you upload but nothing change!!


    Sent from my iPhone using Tapatalk Pro

Page 598 of 614 FirstFirst ... 98498548588596597598599600608 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •