Page 246 of 614 FirstFirst ... 146196236244245246247248256296346 ... LastLast
Results 4,901 to 4,920 of 12265

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: UniAW7

  1. #4901
    Quote Originally Posted by NewD View Post
    Your wife's xml has the field in tact. Something on your phone is preventing that data from being received from the weather.com. There is nothing wrong with UniAW7 and nothing wrong with Widgetweather as your wife's phone proves. Your only hope is to do a complete restore after the new jailbreak becomes available. There is some corrupt file or tweak on your phone not allowing the feed to record the updatetimestring in 'your' xml.

    I wish there were a easy solution. But there isn't..

    One last thing to try that's pretty disruptive to your settings and will take a lot of resetting up your phone... But go to Settings-->General-->Reset--> Reset All Settings.. This will clear every setting from your phone and reset absolutely everything on your phone.. (no loss of jailbreak though).. But it could get it working. I've heard of that Reset working for weird stuff like this in the past.

    Good luck,
    Grant
    Thank you for your efforts in helping.

    I will try resetting all settings. Hopefully it will fix the problem.

  2. #4902
    Default UniAW7
    i seem to have the same issue as bliken...added in the main.js i have w the switch as well as the var in the config.js & got no xml file...used original main.js (this is no-timed walls version btw) and did the one line of code commented out jQuery line added in groovyAPI & still no xml file

  3. #4903
    Quote Originally Posted by Simon View Post
    Is it always exactly 30 minutes behind or does it just seem to stick at a random time?
    Yes, It's always exactly 30 minutes behind.

  4. #4904
    Quote Originally Posted by mohitpuniya View Post
    Yes, It's always exactly 30 minutes behind.
    It's not normal & I don't know why it's doing this, but if it's always exactly 30 minutes you should be ably to get around it by doing this:

    In the main.js file, add the line in red:

    Code:
    // LOOK FOR UTC/GMT CORRECTION AND FORCE THE CLOCK TO UPDATE
    UTC = obj.timezone + currentTime.getTimezoneOffset()/60;
    updateClock();
    UTC = 0.5;


    Also: If you notice your sunrise/set times are also off by 30 minutes you can fix this in the Config.js file var GMT = 0.5;
    Last edited by <Ian Nicoll/>; 2015-03-24 at 01:47 PM.

  5. The Following 6 Users Say Thank You to <Ian Nicoll/> For This Useful Post:

    #m37h{ (2015-03-24), ferlop15 (2015-03-25), King_O_Hill (2015-03-25), lostinthemes (2015-03-31), NewD (2015-03-24), Simon (2015-03-24)

  6. #4905
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Weird. Maybe he's in one of those time zones that are half an hour out of normal time zones.

  7. The Following 2 Users Say Thank You to Simon For This Useful Post:

    <Ian Nicoll/> (2015-03-24), King_O_Hill (2015-03-25)

  8. #4906
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,712
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Quote Originally Posted by Simon View Post
    Weird. Maybe he's in one of those time zones that are half an hour out of normal time zones.
    There are such a thing?

  9. #4907
    There seems to be a lot of main.js files floating around.

    Note I updated the widget a few days ago removing some classes & making all temperature displays use the same color coding as the main temp, this will means other (older) main.js files will no longer work with newer version as the classes were also defined in the html files.

    I would suggest instead of posting complete main.js files it's better to post just the part(s) of modified code, otherwise things will get very confusing for those who don't update to the latest version.

    Thanks to all of you who keep helping out & supporting this widget.

  10. The Following 7 Users Say Thank You to <Ian Nicoll/> For This Useful Post:

    #m37h{ (2015-03-24), ferlop15 (2015-03-25), jawonder (2015-03-24), King_O_Hill (2015-03-24), kristatos (2015-03-24), Marty McFly (2015-03-24), Mary48336 (2015-04-01)

  11. #4908
    Quote Originally Posted by NewD View Post
    There are such a thing?
    There are for sure timezones that are so many hours plus a half hour. I've been in some but can't remember where (too much traveling).
    List of UTC time offsets - Wikipedia, the free encyclopedia

    Quote Originally Posted by Simon View Post
    Weird. Maybe he's in one of those time zones that are half an hour out of normal time zones.
    I'm sure he is, but I thought WW2 would have got this from GMT data, maybe he can check his xml file & see if his GMT data (<timezone>) is correct (showing the half hour extra).

    Quote Originally Posted by sabbagh View Post
    Thank you for your efforts in helping.
    I will try resetting all settings. Hopefully it will fix the problem.
    I have no clue why your sunrise/set times + timestamp are not appearing in your xml file, perhaps King O Hill is your best bet to help you out more, he's the WW2 man.
    Last edited by <Ian Nicoll/>; 2015-03-25 at 01:23 AM.

  12. The Following 4 Users Say Thank You to <Ian Nicoll/> For This Useful Post:

    ferlop15 (2015-03-25), King_O_Hill (2015-03-24), kristatos (2015-03-24), Simon (2015-03-24)

  13. #4909
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Quote Originally Posted by NewD View Post
    There are such a thing?
    yes

  14. #4910
    Quote Originally Posted by Boots View Post
    i seem to have the same issue as bliken...added in the main.js i have w the switch as well as the var in the config.js & got no xml file...used original main.js (this is no-timed walls version btw) and did the one line of code commented out jQuery line added in groovyAPI & still no xml file
    You get it working Boots? If not. Try a fresh download and try again. Worked for me.

  15. #4911
    iPhoneaholic Splatty79's Avatar
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Posts
    499
    Thanks
    434
    Thanked 711 Times in 235 Posts

    Quote Originally Posted by Simon View Post
    yes
    South Australia is like that. Strange people

  16. The Following User Says Thank You to Splatty79 For This Useful Post:

    <Ian Nicoll/> (2015-03-24)

  17. #4912
    Quote Originally Posted by Splatty79 View Post
    South Australia is like that. Strange people
    Ah yes, I remember now, the two I was in was Adelaide & Sri-Lanka.

  18. The Following User Says Thank You to <Ian Nicoll/> For This Useful Post:

    Splatty79 (2015-03-25)

  19. #4913
    Quote Originally Posted by TiLT1oNE View Post
    Hi @ all,

    I have a prob when I try to mod some sbhtml/gl themes. Im on my macbook with tacoHTML or my windows machine, with the the special chrome shortcut (--disable-web-security --enable-file-cookies). When I try to edit some themes I add one line to my wallpaper.html/lockbackground.html file:
    Code:
    <div id="TestBackground"></div>
    and add one container in my style.css:
    Code:
    #TestBackground {
    position: absolute; top: 0; left: 0;
    background-image: url('Background.jpg');
    background-size: 375px 667px;
    width: 375px;
    height: 667px;
    z-index: 0;
    }
    and I put a jpg named as Background.jpg (750px x 1334px)to the root dir of the theme. That worked really well, after the changes I have the TestBackground. BUT when I try to edit some things and put some things to another positions i.E The forecast, or the weathericon, it looks okay on my tacoHTML but when I copy it to my i6, it looks different than the one on my macbook. The forecast and the weathericon is too hight or low, what can I do, to get exact the same dimension on my macbook or my win machine with chrome, like the dimensions of my i6 screen?

    Thanks in advance
    Hi UNiAW Crew

    Sorry for quoting my own post, but can please anyone help me out with that?

  20. #4914
    Code Dependent NewD's Avatar
    Join Date
    Jan 2012
    Location
    Northeast US
    Posts
    5,712
    Thanks
    8,338
    Thanked 16,467 Times in 7,697 Posts

    Quote Originally Posted by <Ian Nicoll/> View Post
    There are for sure timezones that are so many hours plus a half hour. I've been in some but can't remember where (too much traveling).
    Quote Originally Posted by Simon View Post
    yes
    Quote Originally Posted by Splatty79 View Post
    South Australia is like that. Strange people
    Quote Originally Posted by <Ian Nicoll/> View Post
    Ah yes, I remember now, the two I was in was Adelaide & Sri-Lanka.
    Wow.. Well you learn something new every day!! I would have never guessed there were whole regions 30 minutes off from the hour. Thanks for the education, guys! Wonder if SDDev can factor this in somehow in how WW2 puts data in the XML.. Or maybe we'll have to put a conditional in our widgets, Ian, to account for it?

  21. The Following 4 Users Say Thank You to NewD For This Useful Post:

    <Ian Nicoll/> (2015-03-25), jawonder (2015-03-24), kristatos (2015-03-24), Simon (2015-03-25)

  22. #4915
    Quote Originally Posted by NewD View Post
    Wow.. Well you learn something new every day!! I would have never guessed there were whole regions 30 minutes off from the hour. Thanks for the education, guys! Wonder if SDDev can factor this in somehow in how WW2 puts data in the XML.. Or maybe we'll have to put a conditional in our widgets, Ian, to account for it?
    When I was in both Adelaide and Sri Lanka, the widget showed the correct time, I can't remember if we were using WW back then, but I know WW2 wasn't out at that time.

    I would like to see his xml file to see if his timezone is correct or not. If it's not showing the ".5" then it's possible WW2 has been coded to get timezones in whole numbers only (no decimal point), the reason I think this is, if it were coded to accept one decimal place (which it should be) then my GMT would show "<timezone>GMT+8.0</timezone>" instead of "<timezone>GMT+8</timezone>"
    Maybe Brian can check for us.

  23. The Following 3 Users Say Thank You to <Ian Nicoll/> For This Useful Post:

    ferlop15 (2015-03-25), King_O_Hill (2015-03-25), Simon (2015-03-25)

  24. #4916
    at the moment, still on 7.0....thx



    --------------------------------------
    congrats to NewD, for Gold....forgot to mention awhile back, but considered you Gold status long long ago,
    Last edited by ferlop15; 2015-03-25 at 03:50 AM.

  25. The Following 10 Users Say Thank You to ferlop15 For This Useful Post:

    #m37h{ (2015-03-25), <Ian Nicoll/> (2015-03-25), Boots (2015-03-25), Glawrence33 (2015-03-25), King_O_Hill (2015-03-25), kristatos (2015-03-25), Marty McFly (2015-03-25), Mary48336 (2015-04-01), NewD (2015-03-25), Simon (2015-03-25)

  26. #4917
    Quote Originally Posted by TiLT1oNE View Post
    Hi UNiAW Crew
    Sorry for quoting my own post, but can please anyone help me out with that?
    Wont work because on PC/Mac the widget defaults to iPh6Plus screen size & you are adding & editing to an iPhone6 size image, however, it would work correctly if you temporarily set in the Config.js: var iPhoneType = "iPh6";

    But there is a better way to do what you want:
    Don't add another image div, just go to "Images/Wallpapers/User" folder & temporarily replace the "Default.png" image with your image (must be .png file & named "Default.png"), then in Config.js set this: var Wallpaper_options = "user";

    Remember to set the width of the preview window in Taco to the exact width of the widget before doing your editing.

    To get a nice big preview for editing, temporarily set var iPhoneType = "editMode"; in Config.js, but remember to put it back to var iPhoneType = "auto"; when you're all done.
    Last edited by <Ian Nicoll/>; 2015-03-25 at 02:12 AM.

  27. The Following 5 Users Say Thank You to <Ian Nicoll/> For This Useful Post:

    #m37h{ (2015-03-25), ferlop15 (2015-03-25), King_O_Hill (2015-03-25), kristatos (2015-03-25), Simon (2015-03-25)

  28. #4918
    Quote Originally Posted by mohitpuniya View Post
    Yes, It's always exactly 30 minutes behind.
    Can you zip your xml file and email it to [email protected]?

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0

  29. The Following 3 Users Say Thank You to King_O_Hill For This Useful Post:

    <Ian Nicoll/> (2015-03-25), mohitpuniya (2015-03-25), NewD (2015-03-25)

  30. #4919
    Quote Originally Posted by King_O_Hill View Post
    Can you zip your xml file and email it to [email protected]?
    Awe, I wanna see I wanna see

  31. The Following 4 Users Say Thank You to <Ian Nicoll/> For This Useful Post:

    King_O_Hill (2015-03-25), Mary48336 (2015-04-01), mohitpuniya (2015-03-25), NewD (2015-03-25)

  32. #4920
    Quote Originally Posted by <Ian Nicoll/> View Post
    There are for sure timezones that are so many hours plus a half hour. I've been in some but can't remember where (too much traveling).
    List of UTC time offsets - Wikipedia, the free encyclopedia



    I'm sure he is, but I thought WW2 would have got this from GMT data, maybe he can check his xml file & see if his GMT data (<timezone>) is correct (showing the half hour extra).



    I have no clue why your sunrise/set times + timestamp are not appearing in your xml file, perhaps King O Hill is your best bet to help you out more, he's the WW2 man.
    Thanks for all the help Ian. I have checked my xml file and find that my timezone is showing GMT+5 instead of GMT+5.30. So i manually changed it but it revert to GMT+5 as i respring my phn or after update.Apart from that it fetch all the data correct,like city,address. Plz help me to correct this issue.I tried to change value in main.jsp also and added UTC=0.5; but after that i only get blank screen.

  33. The Following User Says Thank You to mohitpuniya For This Useful Post:

    King_O_Hill (2015-03-25)

Page 246 of 614 FirstFirst ... 146196236244245246247248256296346 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •