Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: New Theme Preview - "Lazy Day" packaged for SummerBoard

  1. #21
    My iPhone is a Part of Me lifesmymachine's Avatar
    Join Date
    Aug 2007
    Location
    Los Angeles
    Posts
    529
    Thanks
    3
    Thanked 51 Times in 41 Posts

    Quote Originally Posted by unclear View Post
    Sorry, went out of town today! Everything is all done, just need to do a couple icons for a few apps that came out today. I'm gunna go ahead and wait until tomorrow afternoon to post it.
    mmk, i guess i can go to sleep then....
    "The glory is not in never falling, but in rising every time you fall."

  2. #22
    I think your theme looks great! It's not necessarily my style, but I look forward to seeing your other creations in the future

    Keep up the good work!

  3. #23
    Exclamation Summerboard Icon Alignment
    Quote Originally Posted by unclear View Post
    I'm also having a little trouble with SummerBoard's alignment bug, and have found ways around it, but they leave me slightly less than satisfied.. Sorry, but being my first, I want this release to be perfect! Hopefully this bug will be patched soon, but if not I suppose I'll have to settle. Anyway, you can still expect everything soon!

    minor UPDATE... check the first post in this thread.

    I'm hoping someone can clue me in to this alignment problem. It happens with only the icons for the stock applications regardless of the size. Each icon looks like it is justified upper left instead of center-bottom like the 3rd party app icons.

    This happens for every Summerboard theme I have tried (I've installed 20 or so, including most of Lorings) and if I switch the theme icon preference to off all of the icons are aligned properly.

    I'm asking here because I have searched the forum a bit and can't find a satisfactory explanation for why this is happening. Is it simply a bug in Summerboard? If so it seems pretty significant because, like I said, it happens with EVERY theme that I try to display icons for. Thus making the theme feature of Summerboard pretty unusable (or at the very least, extremely ugly).

    I haven't heard of anyone else having this problem with the frequency that I have.... and I also haven't heard anyone state that it's only happening to their "stock app" icons.

    Does this resonate with any of you guys? I assume some of you more experienced theme creators don't have this problem, do you?

    I feel like I'm just missing a piece of information that would explain why this is happening and thus I can find a way to fix it hopefully! :-)


  4. #24
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    its actually fairly simple... The alignment is based off the icon.png in each Application folder. I'll call these your "hard-icons". SummerB doesnt actually replace these files when you change themes, instead it just uses the .pngs in your /var/root/Library/SummerBoard/Themes/ directory (I think).

    So if the theme icons happen to be 80x80 and your "hard-icons" are 60x60 (default) then you will experience the bug.

    In your situation, as you say you have tried loring's icons (which are all 60x60 to work with this bug) im assuming you've modified your "hard-icons".

    The fix is simple... To use lorings icons, just replace all your icon.pngs in /Applications/ with stock.

    Another method which works with any size icons is to just go through and replace all your "hard-icons" with your theme icons.

    UPDATE: Released! Click here!
    Last edited by unclear; 2007-09-21 at 06:16 AM. Reason: Released!

  5. #25
    Quote Originally Posted by unclear View Post
    its actually fairly simple... The alignment is based off the icon.png in each Application folder. I'll call these your "hard-icons". SummerB doesnt actually replace these files when you change themes, instead it just uses the .pngs in your /var/root/Library/SummerBoard/Themes/ directory (I think).

    So if the theme icons happen to be 80x80 and your "hard-icons" are 60x60 (default) then you will experience the bug.

    In your situation, as you say you have tried loring's icons (which are all 60x60 to work with this bug) im assuming you've modified your "hard-icons".

    The fix is simple... To use lorings icons, just replace all your icon.pngs in /Applications/ with stock.

    Another method which works with any size icons is to just go through and replace all your "hard-icons" with your theme icons.

    UPDATE: Released! Click here!
    Excellent!!! Thanks for the info...... I'm going to muck around with things right now and see if I can get everything looking right.


  6. #26
    iPhone? More like MyPhone
    Join Date
    Jul 2007
    Location
    New Orleans
    Posts
    198
    Thanks
    22
    Thanked 7 Times in 6 Posts

    hi could you tell me where to put the StatusBar.png i looked everywhere for it? do i need to rename it or something. awesome theme.you had to put alot of work into it.just thought you should know you did a great job. i hope you continue to make themes

  7. #27
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    Quote Originally Posted by Blackwidow74 View Post
    hi could you tell me where to put the StatusBar.png i looked everywhere for it? do i need to rename it or something. awesome theme.you had to put alot of work into it.just thought you should know you did a great job. i hope you continue to make themes
    The included 'ReadMe.txt' will probably explain it more in depth, but you need to have SummerBoard installed..

    Put the StatusBar.png in (root:)/var/root/Library/SummerBoard/Themes/LazyDay/ directory. In your SMBPrefs (SummerBoard Preferences) make sure you have "Use Theme Status Bar" and "Solid Status Bar" in the ON position..

    By the way, the theme has its own thread here:
    http://www.modmyi.com/forums/showthread.php?t=6224
    I'm subscribed to that one so I get email notification when ever someone replies(directly to my iPhone). If you have any more questions, post them in there and you'll get a faster response (although 6 minutes ain't bad).
    Last edited by unclear; 2007-09-22 at 04:45 AM. Reason: remove smilies...

  8. #28
    Let me help... KEEP IT IN ONE thread. Makes updating the information much easier.

    PS Theme looks great, nice job

Page 2 of 2 FirstFirst 12
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •