Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: I deleted var/stash/Applications.xxxxxx

  1. #1
    How this happened:

    I was removing all files that had to do with RetroArch. I went into iFile and did a search query for "RetroArch" and removed everything that was RetroArch related. This was after I deleted it from my Springboard to ensure no more trails of it was left behind.

    Why I was doing this:

    Simply, I was doing this because I wanted a fresh install of RetroArch.

    What happened because I deleted var/stash/Applications.xxxxxx:

    Honestly, I never deleted any folder named Applications.xxxxxx. The only thing that came up in my search were files pertained to RetroArch. I deleted them accordingly and when I deleted 1 of them, iFile crashed out on me. It was at that point when iFile didn't open back up. I figured it was some weird 1 time kind of glitch so I rebooted. Once I rebooted, I am now missing a number of applications including native applications such as:

    iFIle.app
    Cydia.app
    messages.app
    mail.app
    contacts.app
    settings.app
    + More

    What I have done to try and fix this so far:

    At this point, I have found my Applications folder still in iFile's trash located in var/mobile/Library/iFile/Trash/

    I copied this directory to my desktop. Once it was on my desktop, the folder was only named "Applications" without the extension .xxxxxx.

    While looking in my var/stash/ folder, I have noticed a directory named Applications.1ERT8S. This has all the applications located inside this directory. I don't know if this repopulated after I rebooted or not.

    What I tried doing taking the "Applications" directory I copied to desktop and pasting back into my var/stash/ directory. Once this was copied back into that directory, it was just copied as "Applications" without the extension.

    Also located with my var/stash/ directory were 2 more files. 1 folder named _.eqi5T2 and a file named _.eqi5T2.lnk.

    Since the "Applications" folder didn't have an extension on it and these 2 files didn't have a name in front of the extension, I tried adding the extension .eqi5T2 at the end of Applications.

    After rebooting, this did not work.

    The other "Applications.1ERT8S" I decided to rename as "Applications.backup". I took the .1ERT8S extension and tried using that instead of the .eqi5T2 extension. Additionally, the other 2 files with the extension .eqi5T2 I also renamed to .1ERT8S.

    After rebooting, this did not work.

    I'm not quite sure what to do at this point. Any help would be much appreciated. Thanks.

    [Update:]

    I've made slight progress.

    Within iFunBox, there is a section in the left sidebar labeled: System Applications

    I plugged my iPhone in to see if applications showed up within that directory. They in fact showed up in that directory and they are the same applications that you would see located in var/stash/

    I viewed that directory on my iPad and there were no applications showing up at all. I copied that original applications into that directory and rebooted.

    The progress that was made was I know have most of my applications showing back up.

    iFile doesn't seem to exist.

    Additionally, now that these applications are back, they are crashing when I open them.
    Last edited by DarkXShadowX21; 2014-06-22 at 07:26 PM.

  2. #2
    What ever you did, collapsed the whole system. Probably you don't want to do a restore, because that would mean 7.1.1 and bye bye jailbreak. What about all other native apps? If those are ok, than try using iLexrat, to get fresh IOS, you are on right now and fresh clean jailbreak, so that you can start all over again, by installing everything manually.

  3. #3
    What I've learned since I've made this is post is that the applications are not opening up because I have to fix the permissions.

    Only problem here is that, I can't open iFile because I can't execute the application. I can't execute Cydia. All the applications that initially went missing that I was able to get back simply don't open up.

    I am currently trying to figure out why my Network IP address of my iPad is. I can not open up the settings.app to be able to view this information so I'm trying to figure out another method to obtain it.

  4. #4
    I admire your efforts, but as far as I understand the matter, your only option is restore to 7.1.1. Everything else you are trying is SF, sorry

  5. #5
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    ^I agree, I would be very very surprised if it is fixable without a restore.

  6. #6
    Surprisingly, a fix is possible.

    So far, I've managed to get a few applications working.

    What I did so far is go to http://apt.saurik.com/

    I downloaded the latest versions of OpenSSH and OPENSSL and put them in a directory called var/root/media/Cydia/AutoInstall. Once I rebooted, these packages were installed on my device.

    Now that I have OpenSSH access to my device, I accessed my device through Terminal on Mac OS X.

    Once I had access, I used the following command to change the permissions of all the applications that initially ended up going missing.

    That command line would be:

    chmod 755 /Applications/YourApp.app/YourApp

    This would allow me to change the permission and execute the application that kept crashing out.

    The only problem I am having now is this does not work with Cydia and iFile isn't even showing up as installed on my device.

    To change all of the permissions in the directory you would use the following command.

    chmod -R +x /Applications/

    Cydia requires a different command line.

    That command line would be:

    chmod 4755 /Applications/Cydia.app/Cydia

    Once you are able to access Cydia, you can grab iFile and go back to having your device back to the way it was. ( Almost )

    One last thing I have to figure out,

    All the font has underscores and capital letters in all of my applications. I just have to figure out how to fix that and I'm all set.

    No restore or updating to 7.1.1 needed!
    Last edited by DarkXShadowX21; 2014-06-22 at 10:43 PM.

  7. #7
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Wow, great job. Good luck and keep us posted.

  8. The Following User Says Thank You to Bo Troxell For This Useful Post:

    DarkXShadowX21 (2014-06-23)

  9. #8
    Unreal, congratulations .... just as a suggestion, since you can access Cydia, install and run iLexRat....that way you will reset the jailbreak....everything will be again in the right place, without having to torture your grey cells

  10. #9
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    He will need to have Mobile Terminal installed as well as iFile working properly to use iLex Rat.

  11. #10
    Yes of course, I was kind of hopping he can install those

  12. #11
    Quote Originally Posted by bbrks View Post
    Unreal, congratulations .... just as a suggestion, since you can access Cydia, install and run iLexRat....that way you will reset the jailbreak....everything will be again in the right place, without having to torture your grey cells
    Ilex isn't needed.

    Quote Originally Posted by blkcadi View Post
    He will need to have Mobile Terminal installed as well as iFile working properly to use iLex Rat.
    Mobile Terminal isn't needed. I SSH'ed into my device using my network IP address using the native Terminal that OS X provides.

    What I also found out was the English.iproj files weren't copied over. What I'm doing now is when I come across any application where the naming convention isn't named properly, I just copy over the .strings file from the original backup into the new directory.

    Once in close the application and reopen it, everything is back to normal
    Last edited by DarkXShadowX21; 2014-06-23 at 02:11 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •