Page 1 of 2 12 LastLast
Results 1 to 20 of 36

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Anyone get boot loop after MobileSubstrate update this morning?

  1. #1
    Default Anyone get boot loop after MobileSubstrate update this morning?
    Anyone else get a boot-loop after updating Mobile Substrate? I'm on 3.2, and just clicked upgrade... I hadn't synced in like a week or two. So... yeah.. Luckily I have SHSH blobs from 3.2 - 4.2.1 so I'm good there. I just wish I didn't lose my data. Since I had to restore, I was considering trying 4.2.1, but I really liked my setup on 3.2. I doubt that all of the tweaks I use have been upgraded yet anyhow.. Damnit.

    I wonder how I will get back all of the apps that I bought/downloaded on my iPad through the App Store, but didn't sync yet to my PC. Trust me, there were quite a few that I have purchased... I know that I can check through my purchase history, but ugh. lol.
    And it will be like a taco inside a taco within a Taco Bell that's inside a KFC that's within a mall that's inside your dream!

  2. #2
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    Quote Originally Posted by StealthBravo View Post
    ssh into your phone to /library/mobilesubstrate/dynamiclibraries and rename dynamiclibraries to something else and then reboot
    MAybe give this a try. SB had it working; check his twitter history too.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  3. #3
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    It was an issue with a MS extension

  4. #4
    It happened to me when I upgraded mobilesubstrate, all I did was ssh in and issue a command of "reboot now" ( no quotes" and it brought me out of it and everythingnworks fine, didn't have to restore.

  5. #5
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    A new MS is ready to fix this ... but probably hasn't hit the Cydia update yet.

  6. #6
    Quote Originally Posted by Armoredangyl View Post
    It happened to me when I upgraded mobilesubstrate, all I did was ssh in and issue a command of "reboot now" ( no quotes" and it brought me out of it and everythingnworks fine, didn't have to restore.
    Hi
    I'm using 3gs and I just upgraded the MobileSubstrate.
    Now my phone keep restart. It didn't even able to go into IOS.
    It only show the apple logo with the busy progress.

    May I know how to SSH in now and issue the "reboot command"??
    I can't restore my phone now cause I haven't do a backup and there is a very important message in the phone.

    Please help... I really need to solve this problem ASAP.
    Thanx

  7. #7
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    ssh into your phone to /library/mobilesubstrate/dynamiclibraries and rename dynamiclibraries to something else and then reboot

  8. #8
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    From the Twitter posts, If you have SHSH installed, quickly log-in, rename dir /Library/MobileSubstrate/dynamiclibraries to something else, then reboot. I'm pretty sure you have a small time window (60 secs?) to do this. After it boots, rename it back to it's original name and either properly remove MS with Cydia or get an updated MS.
    Last edited by Mes; 2010-11-25 at 08:37 AM.

  9. #9
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    You can do that or simply rename the folder so its not found when it goes to load the extensions

  10. #10
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    ^^^ahhhh yes , even better

  11. #11
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    Well with the new MS this shouldnt be an issue in the future

  12. The Following User Says Thank You to StealthBravo For This Useful Post:

    makesmoves (2010-11-30)

  13. #12
    To ssh into the iPad follow this guide:

    SSH into iPad using WinSCP & CyberDuck | iPhoneHeat

    After it is installed on whatever system you use, type a command of "reboot now" (no quotes) and thats all there is to it. I cant speak as to the other above mentioned fix, but I know this worked for me.

  14. #13
    Quote Originally Posted by Armoredangyl View Post
    To ssh into the iPad follow this guide:

    SSH into iPad using WinSCP & CyberDuck | iPhoneHeat

    After it is installed on whatever system you use, type a command of "reboot now" (no quotes) and thats all there is to it. I cant speak as to the other above mentioned fix, but I know this worked for me.
    I have installed SSH.
    But my iphone is not boot. It is hang at the Apple logo screen.
    So I'm not able to know the IP.
    What should I do??

  15. #14
    If it is connected to your network via wifi, go into your routers setting..on mine i type home in a browser and I can see my ipad's local ip, the wifi turns on with the os...the page I read says basically the os is running but the gui is locked up.

  16. #15
    But the phone are connected to the office wifi router (before it goes died). So I'm still not able to know the IP.

  17. #16
    Well, all I can tell you is to connect to a network where you can view the ip addresses of connected devices, or otherwise find out the ip address otherwise you're SOOLAJWF and are going to have to restore.

  18. #17
    Well... I tried, believe me, I really really tried, to SSH in but had no luck. One thing I noticed was that my iPad seemed to freeze, and as it did my radios seemed to become disabled... I literally tried for hours to SSH in, with no luck. And actually, I had the hardest time to get the dang thing to restore. I kept getting stuck at "Waiting for iPad", and then iTunes would kick out error 9. I was using TinyUmbrella (latest), with the TSS server on. And yes, I do have my SHSH's stored both locally and in the cloud (thanks windows 7! lol). Eventually, I was able to restore, and get everything that I can think of as far as Cydia tweaks are concerned. Now I just have to figure out how to get the (legit) apps that I hadn't synced back to iTunes yet on my device or better yet iTunes... Hrm...

    THANK GAWD FOR MULTI ICON MOVER!!! Sorry, I wanted to shout it from the top of a mountain; but I didn't have a mountain, I had a camera and a microphone

    Quote Originally Posted by Armoredangyl View Post
    Well, all I can tell you is to connect to a network where you can view the ip addresses of connected devices, or otherwise find out the ip address otherwise you're SOOLAJWF and are going to have to restore.
    Also, Static IPs, on the home network FTW! That way, one can just create a desktop shortcut to the Static IP's session for easier one-button access.
    Last edited by Imahottguy; 2010-11-24 at 04:57 PM. Reason: Automerged Doublepost
    And it will be like a taco inside a taco within a Taco Bell that's inside a KFC that's within a mall that's inside your dream!

  19. #18
    I had the same issue with my Iphone 4 .. didn't know what exactly was causing it so i went through few restores but at the end it came down to the mobileSubstrate and the issue starts after I install the quickdo app but the problem my phone gets stuck on the apple logo and it's not detected so i can't even SSH it .. so is there is a fix for this issue .. in my last run I made sure to update the mobilesubstrate to the latest but still I had the same thing

  20. #19
    Same problem, upgraded MS, reboot device iPhone4, and stuck on logo, no way to put on DFU, not detected by PC, totally bricked :-( Hope there will be a fix for this.

    UPDATE, at least, I'm able to restore my iPhone, normal procedure, hold down power and home button,after 10 seconds, release power and keep holding home button until you're on DFU mode. I'm afraid not able to get out of logo screen, but now all is back to normal.
    Last edited by luigi37; 2010-11-24 at 07:57 PM. Reason: Automerged Doublepost

  21. #20
    Quote Originally Posted by killerbuzz View Post
    I had the same issue with my Iphone 4 .. didn't know what exactly was causing it so i went through few restores but at the end it came down to the mobileSubstrate and the issue starts after I install the quickdo app but the problem my phone gets stuck on the apple logo and it's not detected so i can't even SSH it .. so is there is a fix for this issue .. in my last run I made sure to update the mobilesubstrate to the latest but still I had the same thing
    Yes, there is a fix. Are you still in a boot loop? If so, you can DFU restore. Hopefully you had your SHSH blobs stored either locally or on Sauriks server... If you want to restore to older firmware, and you have your SHSH's, just use TinyUmbrella, or follow the guide on Sauriks site to modify your hosts file.
    And it will be like a taco inside a taco within a Taco Bell that's inside a KFC that's within a mall that's inside your dream!

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •