Page 2 of 2 FirstFirst 12
Results 21 to 32 of 32

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: iPad Location Service Problem - Please Help!

  1. #21
    iPhone? More like MyPhone fletch33's Avatar
    Join Date
    Aug 2007
    Under a Rug
    Thanked 26 Times in 18 Posts

    Quote Originally Posted by hollowman159 View Post
    This worked for me thanks about time I was tired of having to used terminal all the time..or having to wait till I get to my Mac. Lol
    thanks this just worked perfectly for me. glad to have this back and working again.
    "i believe louisiana is the pelican state"

  2. #22
    I lost Location Services. Solution 1 an d 2 , I tried. and tried restore.
    But after restoring iPad, same. doesn't work Location Services....

    I tried Loc. Srv. in different WiFi network,
    after that
    I got Location services.
    I didn't certain this. Anyone verify this, please.

  3. #23
    Quote Originally Posted by ainyul View Post
    thks for the detialed info/steps earlier; although i went trhough it 1 by 1 it didnt work for me; am tempted to do a restore and start from scratch but with the new itunes 9.2 i think i will wait...

    location services is important but do not want to risk losing out on JB..!!

    Quote Originally Posted by kinjutsu View Post
    You aren't required to use the newer iTunes 9.2.
    ok, finally started this last night; did a backup last night, took btwn 3-5 hours for the back up; went to bed, and this AM did a restore WITh a backup of files;

    after which i did the JB i saw the location services tab was still greyed out; so this time changed tactics and did a full restore WITH designation confirmed as NEW iPad;

    now location services on, did spirit JB; and will now reload apps; etc.

    will keep u updated; thanks to all again for your help..

    UPDATE: ok, did a complete restore; JB from scratch; location services working again..!!

    nice surprise though: all my apps via cydia and itunes all appeared on itunes and i was able to do a one shot deal of downloads to sync with ipad..>!!

    thks to all for your help!
    Last edited by ainyul; 2010-07-10 at 10:05 AM. Reason: Automerged Doublepost

  4. #24
    My iPhone is a Part of Me
    Join Date
    Sep 2007
    Thanked 19 Times in 17 Posts

    Quote Originally Posted by grmiller View Post
    For all that are having problems goto Cydia and Sources


    Refresh and than install the iPad Loction Service Fix there. It worked 100% for me. Try it out!
    Worked perfectly for me. Thanks

  5. #25
    ^surprisingly having problems with fullforce; innitailly apps such as speedtest, cnn, etc used to work full screen on ipad;

    they dont anymore; have i inadvertently changed a setting somewhere? any ideas out there?

    thx again!

  6. #26
    Had to restore in order to get location services back

    Oh well it was worth it, tons of work to get everything back in order tho.

  7. #27
    Quote Originally Posted by liutszho View Post
    Had to restore in order to get location services back

    Oh well it was worth it, tons of work to get everything back in order tho.
    i know what u mean, i had to do a restore as well, but now with location services i can use so many services; including bell mobile tv..!!

  8. #28
    Ok, this is weird.

    After restoring my iPad and re-jailbreaking, I realized my location services was not working again, so I tried editing the locationd.plist file--didn't work (This method used to work for me before this fresh restore). Tried installing the package from Cydia--didn't work. Tried uninstalling OpenSSH, Backgrounder--Didn't work. Tried issuing the launchctl commands from Terminal--didn't work.

    So I restored again to 3.2, so I have a freshly restored Wifi-Only iPad on 3.2 firmware (NOT jailbroken), and I set it up as a new ipad (instead of restoring from backup). I even tried going to Settings>Reset>Reset all settings.

    FOR SOME REASON, my LOCATION SERVICES is STILL NOT working! "Your Location could not be determined" in Maps.

    I'm confused because I was able to fix this easily by just editing the plist file, but now it won't work even when NOT jailbroken, with a fresh restore, how can this be? Anyone know what's going on? Thanks.


    OK, I tried restoring again, but this time I put it in DFU mode instead of Recovery Mode, and it seems location services is back.
    Last edited by JohnnyGlock; 2010-07-23 at 09:21 PM.

  9. #29
    if u have already done a restore, and then a RESET and it still doesnt work; why not take the easy route and go to an APPLE store if you have one nearby;

    once a reset is done all traces of JB are removed I am told, and get an exchange for a new model?

    May not be the answer you are looking for but may give you the end result you require?! Good Luck.

  10. #30
    Here's what finally work for me: General/Restrictions and disabled all. Not sure which one was messing with location services but evidently one was because now Location is working again.

  11. #31
    Alright, thank you guys for all the follow up.

    The nearest Apple Store is 2 hours from

    But I did call up Apple Care and asked for help.

    Now my location service is back, after I complained to the Apple Care Rep. and then he submitted my problem and my iPad software log to the engineers. Then I got the location service back in about 2 weeks.

    So my guess would be, they probably pushed my information to skyhook and forced it to go through...

    It is correct that restoring the firmware will break the Jailbreak and JB can't be detected. I've compared the clean iPad log to mine, so...

    Thank you all!

  12. #32

Page 2 of 2 FirstFirst 12
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts