i have been getting nes update from ibrickr lately...installer list 1.4.0 as current but brickr is 1.6.2 whats up with that ...