Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Installer.app space problem

  1. #1
    Default Installer.app space problem
    Installer.app has finally gone down to 0 bytes available.

    Thing is, I have 1.73 GB still free on my iphone.

    I know that the iphone has 2 partitions, and when "df -h" was run in mTerminal, I found that I had 300/300 MB used of the /dev/disk0s1 partition, which is most likely flash ram (I don't know).

    I have tried uninstalling apps, deleting texts, and etc, but no space seems to free up.

    My question is, what can I delete to free up space in that partition?

    Thanks in advance

  2. #2
    Hmm.. is it possible that the installer.app gives you a limit?

    and you have exceeded the limit and can no longer download stuff?

  3. #3
    I thought it was my imagination..but now im beginning to think its not.

    When I uninstall things from installer app ..im not sure im getting my free space back.

    at least installer app is not reporting it

  4. #4
    A theory I have is that the 1st partition holds all the information for the apps and stored stuff, not necessarily the apps themselves.

    So when you uninstall an app, it leaves the info in the 1st partition (which is the space that installer.app reports) but uninstalls the app which resides in the 2nd partition.

    Or maybe installer just doesnt report an uninstall and thinks you have no free space left when you actually do.

    ........ (2 hours later, doublepost merged)

    Figured it out!

    Apps are stored in the first partition, which has a 300mb limit.

    The first partition is anything not in the "Media" folder.

    Use mobile finder and delete anything that is not needed, including things in the "applications" folder, and check your free space by running "df -h" from terminal vt-100

    Uninstalling apps from "installer" gives you back space, too, but only the things you downloaded that arent stored in Media.

    Is there a way to resize that partition to give more space?

    -EDIT- (even later)

    Ok, so I got it.

    In Finder.app, go to settings and turn off "protect system files" (use at own risk)

    The delete any unneeded stuff not in /var/private/root/Media (the 2nd partition), and it should free up plenty of space on the 1st partition.

    Installer.app recognizes the free space and lets you install stuff now. Have fun!
    Last edited by phipman; 2007-09-16 at 11:53 PM. Reason: Epiphany

  5. #5
    Thanks for taking the time to look into this. Im going to end up waiting till im almost out of space before I attempt it though

  6. #6
    I have a iPod Touch and hit this same issue. After installing a bunch of stuff I had a 100% full /dev/disk0s1 partition.

    I found the simplest way to solve this for me was to simple move the /Applications folder to a spot on the second partition that has tons of free space.

    This is what I did.

    cd /
    mkdir /private/var/Applications (this is where I want stuff to end up)
    cp -Rf /Applications/* /private/var/Applications/ (make a copy of everything in the Applications folder)
    mv /Applications /Applications.old (get the /Applications dir out of the way)
    ln -s /private/var/Applications /Applications (Make a static link to the new Applications directory location from / )


    after verifying this worked I removed the /Applications.old folder.

    ls -la /Applications
    lrwxr-xr-x 1 root admin 24 Jan 11 20:08 /Applications -> private/var/Applications

    df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/disk0s1 300M 259M 39M 88% /
    devfs 15K 15K 0 100% /dev
    /dev/disk0s2 15G 110M 15G 1% /private/var


    Hope this helps... I now can install as many apps as I want and not have to worry much about running out of space.

    -Tibs

  7. #7
    Tibs

    I dont understand what you did to get the extra space. Can I have an 'Idiots' guide please?

    Thanks

  8. #8
    This is the idiots guide:
    http://www.modmyi.com/forums/showthr...light=bosstool

    All you need to do is uninstall and free up enough space to get bosstool installed then you can just run that.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  9. #9
    when i used bosstoll it stuck and didn't open and had to restore...avoid it fellows

  10. #10
    Avoiding BossTool = Fail

    You probably moved your apps and nothing else. You have to move the front and the ringtones before you can move the apps.

    BossTool FTW




Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •