Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: help with new installer repository

  1. #1
    Default help with new installer repository
    hey guys. i've spent all day setting up my own source repository for installer (for custom eBooks) and i'm really close to getting it working, but i keep getting an error when trying to install said eBook (main script execution failed!).

    i can see that installer is failing while trying to create the directory for the book. it's creating a file with the correct folder name but it's not a directory like it should be (it has no permissions and when i try to cd into it, it says it's not a directory). i've tried messing with some ifnot preflight stuff but i can't figure that out, that only made things worse. and it doesn't look like any other eBook providers run those commands anyway.

    after thinking about it for a while, i thought it was a permissions problem with the actual .zip file but i changed everything in the repository's directory to 777 and it's still not working. i'm stumped.

    here is the link to my xml file, if that helps. maybe i'm missing something:

    http://www.manonfire.cc/iphone/bahai.xml

    any help would be much appreciated.

    i think i may have figured it out. it wasn't permissions on the .zip, it was the permissions on the folder that was being zipped! sweet.
    Last edited by outchy; 2008-03-06 at 11:56 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •