Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Installer problem with 1.1.4

  1. #1
    Default Installer problem with 1.1.4
    After upgrading my phone from 1.0.2 to 1.1.4 and using INdependance to jailbreak my phone and install Installer 3.0 I found that every package I tried to install would give me the dreaded "Main script execution failed!"
    message. I after much futzing I was able to successfully run the installer by doing an ssh -l root from my computer and was able to install all my packages. However, if I understand things correctly my phone usually runs as user "mobile" and if I su to "mobile" and run installer I see the following error trying to extract a package:

    2008-03-05 12:17:05.797 Installer[92:d03] ATPackageManager: Status: Installing package...
    2008-03-05 12:17:05.805 Installer[92:d03] ATScript: Running script, dialect is: 300
    2008-03-05 12:17:05.815 Installer[92:d03] Executing script instruction: InstallApp with arguments ("Domino.app")
    2008-03-05 12:17:05.820 Installer[92:d03] ATScript: Installing App: /Applications/Domino.app
    2008-03-05 12:17:05.837 Installer[92:d03] ATUnpacker: Copying compressed path: Domino.app >> /Applications/Domino.app
    2008-03-05 12:17:05.844 Installer[92:d03] ATUnpacker: Extracting folder: Domino.app/ >> /Applications/Domino.app
    2008-03-05 12:17:05.850 Installer[92:d03] ATUnpacker: Could not extract folder, aborting operation!

    This appears to be a permissions problem given that the package installs just fine as root. I looked at the ownership of /Applications and it was
    Root.admin so I changed it to Root.wheel but this made no difference.
    Does anyone have any suggestions about how to fix this? I would like to be able to use installer normally without having to ssh in as root.

  2. #2
    try clearing your queue...

  3. #3
    Yea it is not the queue problem... I have cleared it multiple times and also reinstalled installer etc. Any other thoughts? Anyone know what the perms need to be on this?

    OK! I figured out my own problem! Wow only took about 10 hours of work to get my
    phone back to normal after doing the "simple" upgrade.

    The issue was that when I copied the Installer.app into place using INdependence it
    put the app's permissions in as root.admin NOT root.wheel reading the post about fixing the 1.1.3 installer more carefully I saw that I needed to set the sticky bit and put everything as root.wheel as follows:

    chmod +s Installer.app/Installer
    chown -R root:wheel Installer.app

    once I did this I was able to install from my Ipod to my hearts content! Since I had installed most of my apps using "root" I just copied over the installer plist files from
    /var/root/Library/Installer over to /var/mobile/Library/Installer and then Installer on my phone could now "see" all of my packages and I was able to install and update from my phone!
    Last edited by elbers_e; 2008-03-06 at 05:12 AM. Reason: Automerged Doublepost

  4. The Following User Says Thank You to elbers_e For This Useful Post:

    techgirl (2008-03-13)

  5. #4
    iPhone? More like MyPhone techgirl's Avatar
    Join Date
    Jul 2007
    Location
    Newark, New Jersey
    Posts
    227
    Thanks
    30
    Thanked 15 Times in 10 Posts

    Worked for me! Thanks so much!


    Techgirl at your service... Modding MyPhone since Day 1!

    AIM: lindseycholmes
    Skype: lindseycholmes
    Facebook: lindseycholmes


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •