Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: A thread for 1.1.4 Installer.app issues

  1. #1
    Default A thread for 1.1.4 Installer.app issues
    1)So I finally got installer back on my phone, but like many others, it was not working properly. In-fact it would crash and quit before showing the main screen.

    To correct this:
    SSH to phone and change permissions as follows.
    chmod 777 /Applications
    chmod 777 /Applications/Installer.app
    chmod 777 /Applications/Installer.app/Installer

    Great! Now installer opens. New problem!


    2)Now that I have installer opening, I attempt to upgrade to the newer Installer.app, but after extracting the package I get the dreaded
    ERROR: main script execution failed!

    To correct this:
    SSH to phone and change permision as follows:
    chmod 777 /var/mobile/Library

    This allows changes to all files within that folder, which should not cause any problems, unless you install malicious software, or delete files like a fool.

    Excellent, so now Installer update works! Woot!

    3) Now that I have installer v3.01 running, I have yet ANOTHER problem! I cannot uninstall or upgrade the Summerboard.app that is 'left over' from a previous version. Nor can I install certain new apps without getting the 'Main Script Execution Failed' error.

    I'm currently working this last secion... not sure how to fix it yet, but I imagine it's another permissions setting somewhere, or perhaps an issue with summerboard still running?

    If anyone has any ideas to help, or other Installer tips, please post them below. Please don't throw a billion requests for "how do I fix my iFone OMG!". Let's have a productive, collaborative thread for a change :-)
    Last edited by Coluch; 2008-03-04 at 09:04 AM.
    iPhone 4
    iOS 4.3.3
    Carrier: Fido
    OSX Snow Leopard 10.6.8

  2. The Following 2 Users Say Thank You to Coluch For This Useful Post:

    laving (2008-05-12), mqtredwing (2009-02-28)

  3. #2
    What's Jailbreak?
    Join Date
    Mar 2008
    Location
    Oklahoma
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I can't download ishare on 1.1.4 I always get error "package dowload failed". Also I wondered if anyone could give me a detailed description on changing where my apps are stored to increase the space limit. I've found it for 1.1.3 but not 1.1.4.... Sorry if this is the wrong place to post this.

  4. #3
    my problem is that i can SSH into my phone but cannot change the permissions for the Applications on it to 777 as i keep getting an error saying: "Operation not permitted"

    I have even tried using SCP to go in an try change the permissions to 777 but it still wont work i get a pop up window saying

    "---------------------------
    Error
    ---------------------------
    Cannot change properties of file 'Applications'.
    ---------------------------
    Command 'chmod 0777 "Applications"'
    failed with return code 1 and error message
    chmod: Applications: Operation not permitted."


    I was able to change the permissions on chmod 777 /var/mobile/Library no problem though!

    Any chance you can shed some light on me problem?

    thanks in advance.

  5. #4
    i have two issues... first when i try to reinstall (3.1 the newest one) it says
    "Not enough free space to update Installer! Please free at lease 512 KB of space."

    also when i install something it crashes when it gets too installing package
    always hit the thanks button

    no signature spam/links... Thanks

  6. #5
    Yeah, I've started getting a "main execution script failed" whenever I try to install something now. Seems sort of out of the blue. A little confused. Hopefully one of us will find a solution.

  7. #6
    Whenever refreshing the sources my installer tends to hang a lot. Like a different spot everytime. It forces me to close and try the refresh again, i remember this problem from the early versions of installer, but why is it back?

  8. #7
    This installer update is kinda frustrating. This is my story.

    I was using a previous version of installer and it was working fine. Then I get a notice that a new update of installer is out and I tap 'update'. But I get the usual error notice that package download failed. From then onwards everytime I try to download a package I would always get the same message. I fixed that by actually restarting the iphone.

    Now I'm stuck with a previous version of installer cuz I can't installer version 3. I tried downloading the Installer Fix (3.1) and re-tried downloading Installer 3.11 but it's always the same error which I get. I tried changing persmissions via windows (I used iPhone PC Suite) to 755 or 777 but up to no avail.

    The funny thing is this: when I tapped the uninstall tab, Installer 3.1 as listed as being installed... it gave me the possibility to "re-install" (not uninstall)... I tapped it but I got the same results.

    Would be grateful if someone could help.

  9. #8
    i had to restore last night so this morning i was working with a fresh iphone with installer on it (pwnage). i installed the sources from shai's apps (to save time) and began deleting the ones i didn't want/need. well, after closing out of installer and reopening it, it now goes to the white screen, hangs, and then closes.

    what gives? any ideas for me that does not involve ANOTHER restore? i hadn't even installed SSH, AFP, terminal, or mobilefinder on there yet...
    Last edited by billchase2; 2008-05-21 at 03:11 PM.
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad

  10. #9
    I Have The Same Issues-what's The Antidote Please >??

  11. #10
    I have been having issues since that new update. Installer was working fine until this update. I cannot install anything from INSTALLER. I thought it was the links, but I dont think thats the problem at all.
    It gives errors on everything I got to download, well at least when it did. Sometimes it starts downloading, then stops, and says unable to download. Very frustrating.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •